• Updated 2023-07-12: Hello, Guest! Welcome back, and be sure to check out this follow-up post about our outage a week or so ago.

Help with diagnosing and repairing a Micron video card

Hi everyone,

I was recently lucky enough to acquire an SE/30 with a Micron video card and grayscale CRT yoke board that the seller explained had been working but which had become intermittent and then ceased to function, preventing the machine from booting when it's inserted. I'd greatly appreciate people's experience on diagnosing and fixing these cards.

Here's what I have tried so far:

- I've replaced the grayscale board and wiring harness with a stock board and harness. The Mac boots happily, even with other PDS cards installed.

- When just the Micron card is installed (no Micron CRT yoke board or harness), I get the boot chime then the chimes of death and a blank, grey screen. I don't think I need the Micron grayscale harness connected to allow the system to boot? I assume it would just think it was going to be used with an external display instead.

- The most obvious potential problem is a darkened chip on the board, a resistor network, which definitely doesn't look right (photo below). It's dark, I think, because of grease from the CRT anode cap, which it had been touching when the board was inserted as it was sitting on top of a DiiMO accelerator board. I've tested the resistor network though and all the resistances seem within tolerance. Could the chip still be faulty somehow? Could there have been any HV arcing?

- There are a few traces on the back of the board where the solder mask has been scraped away from insertion/removal but there is still continuity.

So, my question is: what should I try next? What typically fails with these cards? Should I look for any chips that are getting unusually hot, which some other people seem to have reported on these cards?

I've attached some photos in case they're useful. Many thanks in advance for any help!



  • tempImageeWc9yN.png
    17.1 MB · Views: 29
  • tempImageXjWsRh.png
    17 MB · Views: 32
  • tempImageAAZw4P.png
    18.9 MB · Views: 28


Well-known member
@mac_enthusiast -I wonder if your problem doesn't have anything to do with the card, but possibly the output voltage from your power supply? I was having a similar problem with my SE/30; for a while, it worked fine with a network card, Daystar 030 accelerator, and a Grand Vimage video card. And then one day, it didn't work unless I used it without the accelerator.

Long and short of it, the problem had nothing to do with the cards, but the lack of power getting to them. I measured the voltage from my power supply, and was only getting 11.88 volts! So I swapped all of my stuff (cards and my recapped SE/30 board) into another SE/30 body that had a good power supply......and all was well again! Except for the fact that I really should be getting around to re-capping some power supplies;)

Here are a few pictures of a healthy amount of voltage being measured from one of my other compact Macs:
Hi @JT737 thanks so much for your thoughts on this. I should have thought to measure voltages and will do this as soon as I have some time this week!

Out of interest, when you had insufficient voltage, were there any signs of life? Did the Mac partially boot to a grey screen with chimes of death like mine does?

Thanks again,



Well-known member
I'd agree it could be a bad PSU. They don't always share the same symptoms. For instance, when mine went, the screen would become wavy and there were random errors thrown out. Luckily you have a Sony, so if it is faulty, new caps should save it.


Well-known member
@mac_enthusiast -Yes, I could still get the computer to boot-just with a few less accessories. I agree with Joynnya101, sometimes a bad PSU can exhibit itself as several different symptoms. Long and short of it, if you do have access to another Mac SE or SE/30, try using the power supply from that one and see what you get!
Finally got around to measuring voltages at the floppy port:

Successful boot (no PDS card): 4.97v, 12.21v

Failed boot with grey screen and chimes of death (Micron inserted): 4.86v, 12.23v

The 4.86 doesn't feel that low? Interestingly, there is no -12v at the floppy port but I am not sure whether or not this is fed through on an SE/30?


Well-known member
I think the card needs either the internal or external harness connected to work correctly. Not sure if you also want to have an actual screen connected or not. I was having the same issue you're describing while moving around cards between machines and didn't hook anything up to the Micron card at all. Plugged in the external connector harness and a monitor and the problem went away.

The initial problem with both cards not working together at the same time is very likely to be related to power issues.
4.86V is on the low side already, having both Diimo and Micron in there is going to drop it even more.
Hi @Bolle, thanks very much for sharing your experiences of the same issue. As it happens, the card I acquired is missing the bracket, cable and external DB-15 connector. This could be making things worse…! Out of interest, do you know if there are any pins on that connector that are “sensor” pins? I presume so, so it knows that a monitor is attached and to use that. Also, is there a pinout of the cable for the Micron to DB-15 external monitor connector? I found the Micron documentation bundle on Archive.org but it doesn’t seem to include that.

I’ll also have a look at the caps in the power supply. I do have another SE/30 Sony PSU that I just recapped, which I could swap in. What’s the latest thinking on ideal PSU voltagewhen not loaded/loaded?

Many thanks,

Sorry to revive my own thread after such a long time - there is a clear issue with the power supply. With the Micron card inserted, I am getting 4.49 volts at the floppy port and a blank screen with no boot. With the Micron card removed, 4.95 volts and it boots...