• Updated 2023-07-12: Hello, Guest! Welcome back, and be sure to check out this follow-up post about our outage a week or so ago.

G4 Rescue Mission


Well-known member
If you are following my thread in the Hacks forum you know I embarked on (and have completed) a project to build a Hackintosh in a G4 Graphite case. In order to finish the project I had to pull some donor machines from eBay, but I made a deal with myself that if I did that I'd restore at least one to working condition in order to justify the sacrifice.

In the event I actually save two and now have two very decent machines, although both are a bit 'custom' inside.

So wind back a couple of months, I bought a cheap G4/400 Sawtooth from eBay to act as a donor for some missing parts from the empty modded G4 case I had. Sadly it took a whack in transit and suffered a damaged (who am I kidding, destroyed) from top handle. Still, I'd pledged to get one running and I decided to drop for a decent GigaDesigns G4/1.4GHz upgrade card. It came, I tested it, the Sawtooth didn't work with it and I was sad, because it cost some £££ and I thought I'd killed something. The 1.4GHz CPU was put carefully in a box

At this point I had the inner workings of a G4 but lacked a few bits so I continued combing eBay. I tripped over a seller dumping a bunch of G4s in various states of disrepair, missing things like PSUs, bezels etc. I decided I'd put a lowball bid on a couple that were sans PSU and some parts, one was a graphite (later found to be a GigE) and one was a Sawtooth that was advertised as a 'Dual CPU' but was actually a single 733 Education model. I didn't think I'd end up bagging them as I have found in the past people scour eBay for scrap computers, especially Macs or high-end HP/Dell/Lenovo/Suns/IBMs etc and part them out for profit. I was wrong, and won them both. I didn't really want the Quicksilver, as it wasn't the chassis type I was doing the mod on but, long story short, I ended up taking both.

What ensued was a lot of research about bidding ATX PSUs for PowerMac G4s. I determined a few things, firstly that it was possible, secondly that anything with ADC video was likely to be tricky because of the need to supply a 28/25V line, and that as I had them and didn't really care what happened to the functional bits I'd give it a go anyway.  They eventually arrived and I ID'd them approx. I was immediately able to see a few things. The graphite was a different board to the Sawtooth ~I already had, it had a large, heatsink'd chip on the board at pad U900 that wasn't in the Sawtooth. I also realised it had ADC. The Quicksilver was quickly identified as a single CPU and the backplate on the chassis specified it as '733', so I knew it was pretty poverty-spec. Still, I decided, given the knowledge I'd gained, that I'd give something a shot.

So I bought a couple of 24-pin-24-pin ATX adapter cables, and dug out a HDD Molex to EPS adapter (I didn't have any EPS extender leads at the time). After following the diagrams from Apple's Service Manaual and comparing them to a ATX diagram, I was able to lash up a harness for and ATX PSU to supposedly power the Sawtooth. So I rather intrepidly plugged my adapters into the Quicksilver and pressed the power button... nothing happened... because I didn't turn the ATX supply on, but then I did and after trying again it sprung into life, presenting me with a ? Folder screen. Unbridled Joy!! I quickly dug out a Tiger install DVD and ran into my first problem, the QS had neither a DVD drive nor an optical/ZIP carrier in it. Luckily I had a FireWire enclosure (fitted with ex. Mac Pro SuperDrive) that I got for my G4 Cube (owing to the internal DVD drive eject mech being shot). Attaching that it found the DVD, booted and... Locked up. I was crestfallen. I'd got close but no dice. I decided to set it aside and try the GigE. That... got to the 'Choose your Language' dialog in the Tiger installer... there crashed. It was late, neither worked, and I suspected my handiwork wasn't up to snuff, so I left them.

The next day I had a brainwave. Tiger had a minimum RAM specification and I was sure it was more than 128MB. I checked and both machines had single 128MB DIMMS in. It transpired the one in the QS was also faulty as it started not chiming on boot time. I pulled out the QS's RAM and replaced it with 2 PC133 256MBs. The Tiger DVD booted! Great! Time to add a HDD. I slung in a 20GB IDE drive that I had on hand and hit snag number 2. The drive wouldn't spin up when the power was on, because the 12V line was being sucked dry by the CPU. So then I decided to use a 2.5" SATA drive via adapter, because it only uses 12V, and it worked just dandy. So at that point I had a working 733 QS. Then it occurred to me that the 1.4GHz upgrade had come out of a QS, according to the seller, so I wondered if it'd work in mine. After a very tentative CPU swap (because I'#d only done it once before and it didn't work) I fired up the QS and... huzzah! I now owned a 1.4GHz QS.

So that got my QS working. All it needs is a DVD/Zip tray (the internal metal bit).

Turning to the GigE I also managed to get it to boot pretty easily by using the Sawtooth PSU and moving the 5V TRKL pin to where it's supposed to have a 28V supply to. Worked no sweat. I found a IDE to SD-card adapter on a 3D printed slip that I'd built for my G4 Cube in a failed attempt to replace the Hard Disk (I succeeded, several prototypes and switching to SATA-IDE later) which I figured would suffice as a boot drive. I kit-bashed it out of 2 machines in the end, using the internal metal case of the Sawtooth as it was Ain much better condition, the GigE board and the best of the two sets of plastics. When trawling eBay I fell over a guy selling. Dual G4/450 Sawtooth CPU boards for cheap (link in eBay Finds) and grabbed one of those, so it now has Dual CPUs. It makes a decent Tiger box as I managed to scrape up 1GB of RAM in 256MB DIMMs for it.

So in making a Hackintosh I have ultimately also saved 2 ACTUAL G4s as a side project. I'll post some more details and pictures in a further post.