• Hello, Guest! Welcome back, and be sure to check out this post for more info about the recent service interruption and migration.

FWB NuBUS Jackhammer Incompatible with Fujitsu 2.3G MO Drive


Well-known member
Have you tried more than one kind of media?

This is really grasping at straws, but I have a really vague recollection of there being some difference in behavior depending on whether the media has 512B per block (block, sector?) or whether it uses 1KB.

Don't the MO drives usually work fine without any special drivers installed? I mean, things like ejectability may be affected, but I remember my experience being, plug them in, boot up and they act like a removable media device.

It may depend on what low level driver one put on the media, i.e. what utility was used to initialize the disk.

Oh, have you tried different utilities to initialize the disk?

I think I have a copy of APS 4.7 around here somewhere...

I know I have a couple of Fujitsu CDs with their software, but I doubt it's later than you have, since they came with 640MB external drives. I really like those 640 external DynaMO drives. The cases are stylish.


Well-known member
The 640M, 1G, and 2.3G disks use 2048B sectors.

They work fine without any drivers, just like most cartridge systems. So long as the disk is inserted when you turn it on, it'll mount automatically. Otherwise you can just use a SCSI mounter of your choice (I use FWB Mounter, it seems to work better than SCSI Probe.)

I have tried probably 2 dozen different formatting utilities trying to get it to work. I got a 640 disk to work (sort of) when formatted with FWB, but it was really, really, really slow. So slow to the point of being unusable, and would eventually crash computer about 1/2 way through copying large amounts of data. However, I could not get FWB to format a 2.3G disk successfully. It would always crash. Drive 7 would work to format it, but I ran into the same issues as with just using the Fujitsu formatter. I thin LIDO worked as well for formatting, but same issue. Disks won't mount while the FWB card is installed.

128M and 230M disks seemed to format and work when formatted with FWB, but slower than if I were using the Fujitsu driver.

Keep in mind, the drive is not connected to the Jackhammer card. They're on the local BUS. So the Jackhammer is somehow interfering with the local BUS.

I think you mentioned that it may be treating it as one logical SCSI BUS? So I wonder if perhaps the Jackhammer card is indeed incompatible with the Fujtisu drive, and because of how it works as one logical BUS, it renders the local BUS incompatible as well.

@trag Do you think if the the SCSI Manager was patched in-ROM that it might make a difference? I tried using the system extension, but it didn't appear to do anything.


Well-known member
What host machine are you testing on, again. SCSI Manager gets complicated because it's built into some stuff.

Quadra AVs and later (everything later is PPC) have SCSI Manager built into their ROM.

I **think** that the JackHammer card has a copy of SCSI Manager in it's on-board ROM.

And there is the loadable extension.

When there's more than one version, sometimes there can be conflicts, but not always. I have no idea how the System manages multiple attempts to load the same code.

But on a PPC machine or Quadra AV, you could attempt to load it up to three times. Once from host ROM, once from the JackHammer card and once if you have the extension installed.

And you only want to load it once.

Are you thinking of patching it into ROM using something like a ROMinator? It might make a difference on machines that don't already have it in ROM.

I encourage the experiment simply because if you can figure out how to patch an extension's functionality into ROM, that would be a great thing to be able to do to all the pre-AV machines with slots. But I don't have any way of knowing if it would solve your issue.

SCSI Manager could be a complete red herring.

I do know we had a brief visit from someone who seemed to have coded for Apple professionally, or similar experience at that level several years back, and in one discussion made it sound easy to patch SCSI Manager into a ROM -- like everyone just naturally knows how to do that.

Of course he didn't stick around long enough to provide detailed instructions. Sigh.


Well-known member
@trag Host machines is a Macintosh IIci.

DougG3 made me a ROM with the Daystar driver patched in. So he knows how, but it didn't feel right to ask him to do it for me. I dunno. I might just be out of luck.

I'm still hoping that the 2.3.6 driver might work, if we can ever track it down.


Well-known member
Maybe turn it on after boot and use a mounter program for the disks?

Otherwise I don't have many suggestions here. MOs are awesome when they work but getting there can be a really frustrating experience. For some reason System 7 does NOT like to play nice with any of the 640MB MOs I try to use regardless of drive (various Fujitsu or Olympus), disk (Maxell, Fujitsu, Mitsubishi, Kyocera, etc), or software (SilverLining, FWB ToolKit, or B's Recorder), but OS 8 and later works fine with them and System 7 is good with any of the 230MB MOs. I haven't tried to use any Gigamos with classic Mac OS, mostly because I figure they'll be a hassle, at least in SCSI form, and also because I only have one SCSI version (1.3GB) and it's internal so that limits its usefulness as a transportable high-capacity storage medium.