• Hello, Guest! Welcome back, and be sure to check out this post for more info about the recent service interruption and migration.

Color Classic power issues

Mu0n

Well-known member
I recently posted a thread over at the conquests section, where I detailed my purchase of a CC1 from Yahoo Auctions Japan, which turned out to be a effectively upgraded to CCII with a LC550 logic board. It featured a cracked case thanks to the shipping and the sting out of the ordeal is greatly lowered by having received a full refund. Here's that thread: https://68kmla.org/bb/index.php?threads/a-color-classic-saga.41108/

The process of making it work in the first few days of receiving went like this:

State A: (plugged: logic, back of the case, hard disk, floppy) Flick the power switch on, press soft power on the keyboard - get a brief led flash, then nothing.

After leaving it plugged in with the switch on + no soft power activation for 6 hours, I got to

State B: (plugged: logic, back of the case, external scsi drive) Powers on normally, emits a very high frequency noise but otherwise works.


Now, several weeks have passed during which I didn't have time to play further with it and I ordered cap kits for both the logic and analog boards, thinking I shoudn't push my luck in the long term without doing proper maintenance. Before tackling the logic board, I was curious to see if I could still repeat the success of its last state, but no, I got:

State C: (plugged: logic, back of the case) No LED flash, just a very soft power up sound in the CRT circuitry presumably, black screen no matter what I do.

After replacing all electrolytic SMD caps with tantalums (I did not mess up the orientation and tripled checked it, I've successfully done a Classic 1 and SE/30 in the past), same State C.

I then proceeded to work on the usual known culprits of the analog board, which can be seen here (X marks the ones that have been swapped with new ones. Merely encircled ones are ones I have on hand if need be the old ones haven't been swapped). I also tested the fuse and I get continuity.

1654809526054.png

There were 2 diodes near the lone 3300 uF 16 V that seemed to have scorched the board a bit (I've seen others with similar issues in that area)
1654809935857.png

However, I removed DL21 out of circuit and tested it with a DMM:
Diode mode:
forward: 727 - increasing towards 1000
reverse: 1

Resistance mode:
forward: 648kOhm
reverse: inf

After putting that machine back, I still get State C. I checked the voltages from the hard disk power connector and I get 0.2 V out of the 5V rail and absolutely nothing from the 12V rail. Someone suggested I try to flick the switch to on without the logic board in and the back case plugged in, which gives me:

State D: (logic out, back case with fan in, hard disk out). I got a power up of the fan for a second, then power down, then power up, then down. After a minute or so, it can stabilize itself to normal operation. Turning it off and on again does not repeat that struggle.

I'm open to swapping optoisolators if need be, I can check more voltages elsewhere, I just need some direction. Maybe a nudge towards replacing those diodes (with exactly what?).
 

Mu0n

Well-known member
I'd like to test known voltages on several transformer output pins (or zones elsewhere) but I need to double check what pins do what first:

1655042225002.png

1655042235640.png
(I'd love to have some semblance of idea about which rating each pin is supposed to give me; fattest traces should be ground, maybe?)
By the time it reaches the hard drive power cable, I get 0V in the 12V rail and a mere 0.2 V in the 5V rail. When the case is closed up, the fan no longer reliably outputs spins to normal cruise speed (you hear it struggling to barely ramp up though).


Next steps that will be attempted (and checking if it works again after each step in order to not muddle the waters and isolate the cause)

1) replace this crusty looking optoisolater near transformer 'B' (and the other fine looking one near transformer 'A', for good measure). A chunk of metal fell off pin 1 when I tried to scrub it with a qtip and IPA 99%.
1655042168047.png


2) touch up -WAY- more solder joints everywhere on the analog board, including connector pins on the neck board

3) replace more caps, especially the chunky fat 400V. I dunno how prone to failing it is, but it's got to be associated with the switching power supply, right?

4) replace the Zener diodes (that were shown as scorching the board around them) with https://www.mouser.ca/ProductDetail/821-BZX85C18R0G (even though the behavior of one of them out of circuit seemed to check out?) 1300mW, 5%, Small Signal

Any advice in what order I should do these steps?
 

techknight

Well-known member
first off the opto-isolator needs replaced. its toast.

After that, your gonna need to do troubleshooting. make sure you are getting standby power output, make sure you are getting a PSON signal coming back from the logic board that turns on the analog board. if its present, see if any of the other voltages come up on either of the two power supplies.
 

Mu0n

Well-known member
So I was able to spend some time today on the analog board:

Replaced DL21 and DL22 with these: 1300mW, 5%, Small Signal Zener Diode
Replaced both optocouplers CNY75GB with these CNY75B

Noticed the sad state of the pins for the edge connector:

1655410861620.png
so I solder wicked all of that out;

1655410870563.png
unfortunately, pin 33's pad was a casualty, but performing several tests, it appeared it was not connected:

1655410879266.png
1655410891880.png

NO CHANGE, I'm still getting state D, but the power seems to go a bit higher and more regularly before it comes back down, as can be heard from the fan.


Things left to do:
-replace large caps that are normally ok, outside of the usual culprits list
-retouch the pins of the neck board
-continuity checks on the logic board's edge connector
-.........insert your brilliant ideas here...........
 
Last edited:

Mu0n

Well-known member
This video was very illuminating and gives me hope of maybe finding a silver bullet to my 'ramping up, ramping down' (timestamp around the area where he explains the switching part):

 

Mu0n

Well-known member
I seemed to have made some partial progress.

I cleaned the CUDA chip some more with alcohol (lc550 board, it's not the egret chip since I don't have a stock CC1 MB).

I heard death chimes for the first time in a loooong while! I experimented with board insertion at slightly different angles. The case has had plenty of cracked tabs along the sides so there's a bit of leeway in how both boards go in. As I tried to tweak its position in between attempts, I got several weird sounds mixed with the death chimes, and then just short crackling noises.

For the past few days, flicking the switch on ALWAYS lights up the LED right away and starts the fan. The screen doesn't energize fully and the keyboard's soft power has no further effect.

I then replaced these caps right before the transformer (the 3 marked by a red X) on the primary side:
1655740734964.png

This seemed to have removed the ramp up, ramp down instability problem and the fan is always rock solid from now on. I also test 11.44 V on the 12 V rail and 4.84 V on the 5 V rail. Still not getting any chance to let the keyboard be the one to soft power start the computer and the screen doesn't come fully still. (I hear the degauss though).
 

Mu0n

Well-known member
Further work done:

-Recap the rest of WHOLE DANG analog board (ie 100% of the console5 kit)

no change

-Clean the CUDA chip (responsible for ADB and soft power)

1655920222280.png

no change

Dismount the analog board, the main computer cage and metal shield to see if some piece of the snap in the case was stuck somewhere, or if I could understand if the shearing that happened during shipping makes contacts between boards precarious and reassemble everything

no change

I took some footage of how it behaves:
Attempt 1: no keyboard plugged in. LED lights up right away anyway. Fan turns on. Rock Solid 5V. Screen degausses faintly but doesn't come on.
Attempt 2: same exact thing. Pushing the keyboard power button adds nothing to the sequence.

 

Mu0n

Well-known member
Ok, I used this pinout (ADB socket on the back of the logic board)
1655991982171.png


soldered wires directly on the Apple CUDA 341S0788.

pin14 = GND (could have used so many other points but whatever)
pin25 = PS_ON pin.

1655991989743.png


1655991998050.png

Continuity to either of those went correctly on the socket at the back.


NEW BEHAVIOR EXHIBITED
with the LC550 logic board inserted in, I now no longer get an automatic LED on + fan on + black screen + unresponsive keyboard soft power

I get this instead:
LED off, fan off, and here are the voltages I get between these 2 pins:

No keyboard press: (0.91 V)
1655992007327.png



Soft power keyboard press: (0.38 V)
1655992022744.png



is it me or the standby voltage should be much higher than 0.92 V?
 

CC_333

Well-known member
I don't think it's you. If I'm not mistaken, standby voltage should be +5v. Something's definitely not right if you're only getting 0.92v.

Something's either wrong with the standby power circuitry on the analog/power board, or maybe there's a broken trace somewhere on the logic board that you've somehow missed, perhaps because it's hidden under a capacitor or IC.

DISCLAIMER: I'm not super well versed in how the LC 550 board works specifically, but what I do know is fairly universal across most 68k Macs (5V standby power), so should logically apply here.

c
 

Mu0n

Well-known member
I'm wondering if this is a possibility if I get desperate, can a LCIII's chip be used as a swap in for the LC550's? It's the closest mac I have to it in terms of technology and it's in pretty bad battery bombed recovery shape as it is anyway

1656080181056.png
 
Top