• Hello, Guest! Welcome back, and be sure to check out this post for more info about the recent service interruption and migration.

Another SCSI2SD mystery (the SE/30 that wouldn't)


New member
Hi All,

I've had the pleasure of owning an SE/30 for a couple years now, and like so many others the HDD gave up the ghost, and like many others, I opted for a V5.1 SCSI2SD adapter.  It took a while, eventually I opted for a patched 7.5.3 boot disk, but no matter how I adjusted the configuration of the adapter in the SD Utility, no luck.  Pining over this fact later I was struck with how stupid it was that I kept assembling and disassembling the SE/30 to access the SCSI2SD adapter, why not use my Quadra 800 which is nice, roomy, and so easy to disassemble? Here's where it gets weird. 

The patched software instantly recognized the SCSI2SD drive, carried out a low level format, I even partitioned it with no problem.  I then loaded System 7.5.3 and was ecstatic thinking "YES! now I just re-install it in the SE/30 and we're good!" only we weren't, I was back at square one with a blinking disk with a question mark icon.  At this point I remembered I had the motherboard from a salvaged SE, and for my own curiosity I swapped the SE/30 for the SE, and attempted to boot off the SCSI2SD adapter.  Worked without incident. 

I did search the forum archives, but while I agree the naming scheme is something to revisit (though the fact that it registered for the SE makes me think this is a rabbit hole worth avoiding) I'm of the mind that there's something not right on the SE/30's motherboard. which is why I've started a new thread as a new member, normally a taboo for which I preemptively apologize. 

the SE/30 motherboard has never been recapped, I pulled the leaking CMOS battery long ago, and visual inspection tells me, yep, it's a motherboard (no obvious leaking caps which just means no obvious leaks.)  I'd love to believe this was a common issue, but I suspect my multimeter and I are going to become very familiar with the board, I'm just hoping someone might have some insight on where to start (other than re-capping, while I'd like to do that myself, my past attempts with FM radios have shown while I can solder, the results leave much to be desired.) Having spent four hours a night daily for the last week, I'm close to banging my head against the wall.  It was fun however working between my MBP, a Hackintosh with Snow Leopard that played better with my USB Floppy adapter, the Quadra and the SE/30 at once. 

Screen Shot 2018-09-06 at 8.45.46 PM.png



Well-known member
Today, any SE/30 must have new caps to work flawlessly, so it's probably the first step to go.

Don't think your problem can be related with caps directly, but goo escaping from the capacitor can go everywhere and do strange things.



New member
Hi Bibilit;

I agree on the capacitors 100%. Much on my end was learned about my own shortcomings on recapping with a 1972 Heathkit AR1500 stereo receiver so I’m hoping the forum is home to at least a couple gurus on either advice or professional recapping services. 

I also think the age of the board and the environment it resided in (think early 80s smoke filled bar room arcade area) means the entire board is due for a careful contact cleaner bath. It just frustrates me since it was 40mb Hdd bliss for years then ‘no! I hate you! I only like disk tools 1! :-E!’ 



Well-known member
Sounds like just what I went through a few weeks back.  Bought an SE/30 on eBay, previous owner said the HD was fine (and I believe him) but when I got it, it worked only intermittently then eventually not at all.  Figured the HD was toast, but put in a SCSI2SD and still ... blinking question mark.  The board had been recapped but looks dirty so I washed it, didn't help.  Finally had to check all the traces coming out of the SCSI chip and sure enough there was a bad one (I think a via through the board near some caps had corroded, maybe before the board was recapped).  Soldered a jumper wire into the right place and now it works perfectly.

So yes, assuming everything else works (does it boot fine from floppy?) I'd guess you may have bad traces coming out of the SCSI chip.  I think you're right that you and your multimeter and some schematics may be very good friends soon.  :)  If you decide to go that route, there are some handy schematics here on the forums including this one https://68kmla.org/forums/index.php?/topic/24126-another-mac-se30-scsi-problem/ which I found most helpful.  Let me know if you can't decipher and of the handwriting and I can clarify and point out a few more places the traces should show connectivity to, having just gone through it.  Good luck!  To quote my wife, "it's more fun when it doesn't work the first time"!