Jump to content

Killer Floppy Disk - IIsi now with a dead drive. Any suggestions?


Recommended Posts

Hiya

 

Short version:

So it looks like a floppy disk has killed two of my drives (auto injects, one on a IIsi, the other on an LCII), as both were working with other disks moments before trying the problem one. It sounds like the drive head is moving around but there is no spinning. Is this likely to be fixable?

 

Long version:

Recently acquired an old hand scanner, a Caere Typist. This thing came with two floppy disks with software and two copies of them. I was mucking around with my IIsi with a couple of other disks getting some other applications over to it and then set about imageing the copies on a Pismo with disk copy and a USB floppy drive. When it came to image the originals, the USB floppy wasn't having any of it which typically isn't a problem as I dont think it reads 800k disks anyway.

 

So I popped it into the IIsi to image it on there. It mounted, and then attempted to image it. What followed was a peculier squeaking noise from the drive before a message saying imageing had failed. The disk then failed to mount, as did every other disk I tried in there after. It sounded like the heads were moving but I couldn't hear any rotation noises. I've never had a floppy that looked fine visually (and span when i twiddled it) kill a drive like this, so I assumed the drive kaput by itself. So, I made the silly decision to try imageing it on the LCII (after installing somthing else with another disk, so I know that drive was fine to begin with too). The same thing happened.

 

It seems to have only effected these older drives as while the USB one wouldn't read the disks, it was fine with others afterwards. I guess maybe the imageing process also had a part in it as they mounted fine before it attempted that.

 

Does anyone have any ideas as to what happened, and how I could go about fixing them? I've taken one apart and gave it a light clean with some isopropal and compressed air but that didn't help

 

Cheers

Link to post
Share on other sites

Ooof.  I've lost a drive to a bad disk when the coating came off the disk itself and destroyed the head.

 

You can try cleaning the heads with some alcohol and a q-tip.  Hopefully it didn't damage the heads.

Link to post
Share on other sites

Had a bit more of an explore and it does appear that they were spinning, but it did sound slower, do these things need to be running fast enough to be readable? Since disassembly and cleaning however, one now isn't working at all now sans the eject, perhaps I put it back together wrong, will need another look when I have time.

 

So if this is a head issue now... I've given them a going-over with isopropal and it's still not having any of it. I've also had a closer look at the disk infront of a light and noticed that it most certainly wasn't the cleanest... no scratchy looking debris but there was blotches.

 

Is there anything else I can try?

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
×
×
  • Create New...