Jump to content

How I resolved my IIci soft power problems (half bong and instant shutdown when switched on)


Recommended Posts

I'm a long-time lurker, and all of your posts have helped me greatly. As a first post, I wanted to share my resolution to what appears to be a common problem, as both the resolution and my interim workaround are different from what I'd seen in other posts.

 

My IIci suffered from a seemingly common problem: it would not stay on. I would press the power button on the back, it would begin to boot for a split-second, emit part of the happy Mac bong, and then die. I have seen several recommended steps to resolve this problem in various posts: 1) replace the SMD capacitors and clean the board (standard advice for Macs of this vintage), 2) replace the big axial capacitors, 3) remove the three 74-series logic chips in the startup circuit, clean under them, and replace them, 4) replace the four SOT-23 packages Q3, D3, D4, and D5. I did all of these things, and also replaced Q4 and D6, replacing everything with new parts from DigiKey/Aliexpress. I actually wound up replacing every single component downstream of the switch in the attached diagram, except for the resistors. I also tested the PSU out of circuit with a power resistor, and it appeared to be working.

 

The standard troubleshooting probably did some good: there was a lot of gunk under the 74-series chips, and D3-D5 exhibited some continuity in both directions in circuit before being replaced. (After replacement, all showed open circuit in the expected direction, and the removed diodes behaved normally out of circuit, so I conclude that there was an electrolyte short under the diode packages.) However, the instant shutdown problem remained!

 

Because the PSU appeared OK, my operative theory was that there was something wrong with the power-off portion of the power circuit. In the attached diagram, the startup and shutdown portions of the circuit are totally separate: the PS On/Off line is connected in the middle of a voltage divider between Q4 and Q3: the top portion is responsible for power on and the bottom portion for power off. I don't have a deep understanding of the system, but at a cartoon level: the power-on circuit ANDs +5 continuous with the power switch. When the switch is depressed, this provides 5V to the base of Q4, switching it on, and connecting +5 continuous to PS On/Off. This turns on the PSU, activating its normal +5 rail, which feeds through D6 into PS On/Off, keeping the machine on. The power-off circuit is a bit of a Rube Goldberg machine, but essentially: when the machine is to turn off, it brings the base of Q3 high, switching it on and connecting its collector to ground. Because there is a smaller resistor on the Q3 side of the PS On/Off line, it is pulled closer to ground than 5V (which is on the other side of the divider), turning off the PSU. This turns off the switched 5V rail, so the computer stays off.

 

Because I was stumped, I came up with the following idea for a workaround: just remove Q3, thereby disabling the shutdown circuit. I tested this, and it works. The computer turns on (usually by itself) when you plug it into mains, and stays on until you unplug it. This turned an unusable computer into one that otherwise worked fine (testing voltages through the floppy port revealed that the PSU was giving stable, to-spec voltages on all rails). I wanted to recommend this resolution to people facing the instant-shutdown problem that they can't resolve. It can also be used to determine whether the shutdown is due to PSU malfunction or a problem with the soft power circuit itself.

 

In any event, I finally solved the problem for good: it turns out there was damage WITHIN the via connecting pin 1 (reset) of UB13 and R112/UE9. This went undetected when I toned out traces, because the via showed continuity with pin 1 of UB13, and it showed continuity with pin 60 of UE9 (and even did so while keeping one multimeter probe stationary in the via and just moving the other). However, due to some microscopic damage to the via: they were not connected to each other: measuring resistance between the two pins directly (which I neglected to do when checking for broken traces), showed Megohm resistance, and similarly with R112. I realized there was a break in the via (at the location marked in yellow in the diagram and in the picture). Therefore, the reset pin was not pulled up to 5V, and was not controllable by the computer: its voltage was floating. Repairing the via by removing solder mask from both ends of the via, inserting a piece of component lead into the via, and soldering it on both sides of the board fixed the break. I then reinstalled Q3, and the soft power now works perfectly. The computer stays off when first plugged in. Pressing power once turns the computer on, it bongs happily and stays on indefinitely. Pressing the power button again turns of the computer, as it should.

 

Hope this information helps someone else.

iici startup diagram.gif

iici_startup.jpg

Link to post
Share on other sites
  • 68kMLA Supporter

Well done.

The break around that via is very common. I already had a few boards with the exact same trace broken.

If the pullup resistor is still connected the Mac will turn on but won’t turn off on its own from software. If it’s disconnected like in your case you’ll get just the behavior you observed.

Link to post
Share on other sites

Thank you both.

 

Bolle, that is interesting that you have had that same problem multiple times; obviously a common problem and yet I don't think there was any info on the internet yet regarding it. I was also just reading a thread about the Mac II where a number of people mentioned having problems with one particular trace. It sounds like machines of this vintage have so many very specific "hotspot" problems that it would be good to get this information into a troubleshooting wiki of some sort (or maybe into the model-specific pages on the 68kmla wiki).

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
×
×
  • Create New...