Jump to content

Recapped Portable still not working

Recommended Posts

Hi everyone. I have just joined up to this great forum to get some advice on fixing my Portable (non backlit). I also have a troublesome SE/30 but I'll do another post about that later.


So my portable was dead so I have re-capped the logic board to try to get it going again. Now it will chime as if its about to boot, but then a second later I get the death chime and sad mac appear. I have tried it with no hard drive, floppy drive, memory card and even the display unplugged and it's sill the same, so has to be the logic board.


The error code I get is:





Another question I have is regarding the 9V backup battery. Should there be a resistor to drop the voltage down to 6V? Someone has previously replaced the battery connector so not sure if its correct or not now. I didn't put a battery on it just in case, but its probably had 9V on it in the past.

Link to post
Share on other sites
  • 68kMLA Supporter


$0A00 is listed as being an F-Line exception from the 68000.  I can't find any other reference for $0A in sad mac codes.



The CPU is receiving an instruction that should be executed by an FPU, which the mac portable doesn't have.  But that's not the whole problem, because normally a system without FPU patches out the address of the F-Line handler to point at the software FPU.  Even without a hardware FPU, your mac can do floating point math through the software emulation.


Seems possible something is wrong with your portable's ROM, or its connection to the CPU.  The non-backlit portable has schematics available so you could use a meter to trace out the address and data lines to the CPU.  I'm guessing you have tried booting with no RAM card installed?



The 9v battery should be connected through a few diodes (two or three in series?), not a resistor.  The diodes are there to drop the output voltage down to something closer to 7.5, which is power adapter voltage.  They prevent the 9v battery from being charged by either the main battery or the power adapter.  As for 9 volts getting through, that's not exactly great and I don't know what kind of problems it would cause.  If the power regulator was unable to drop the 9 volts down to a proper 5 volts then chips could be damaged.


Why don't you try measuring the voltage on the battery connection cable?  Unplug from the motherboard, stick a 9v battery on it, and see what voltage shows up at the connector.  Then remove the 9v battery before plugging that back into the motherboard.


Also check that the ROMs are getting power when you turn the system on.


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...