Jump to content

Sad Mac on Classic

Recommended Posts

  • 68kMLA Supporter

Ever since I've had the analog board in my 1991 Macintosh Classic recapped, it's been running great. Until tonight, that is.


Earlier this evening I was playing around with my FloppyEmu when the Mac gave me a "Sad Mac" error after having to restart the machine. (Sometimes I have to do a hard restart of the machine to change the FloppyEmu modes.) Thankfully, after another hard restart the machine started fine and continued to work.


I tried to start it up again and now it won't boot at all... it just displays the Sad Mac. Can anyone give any insight into what is causing it and how I can fix it? It says "00000005 00400040" below the Sad Mac, and some of the video is garbled. Pressing the reset button does nothing but momentarily add additional garbled video.


There is no additional memory installed; the machine is at its "stock configuration" of 2 MB. (1 MB on logic board, 1 MB on memory expansion daughter card.) It does this with the FloppyEmu connected and disconnected.


Any advice would be greatly appreciated.



Link to post
Share on other sites

The RAM External addressing test failed. The Z field indicates a failed address line.

Could be a broken adress line.

Not sure, but can be two adress lines:

00000001 A0; 00000002 A1; 00000004 A3; 000000008 A4; 00000010 A5 and so on

00000040 could be A8

00400000 could be A23

I do not know, if this is the right interpretation but it could be.

Link to post
Share on other sites
  • 68kMLA Supporter

I found the error code listing page last night shortly after posting this. (I've also posted about this on a FB group and got lots of responses.) Unfortunately, I came to the same conclusion - something's wrong with the memory. :cry:


Tonight I'm going to remove the memory expansion card to see if that makes a difference. If so, at least I'll be able to use the machine (albeit only with 1 MB) until I can get it repaired. If not, well :sadmac::simasimac::scrambled:. Guess I'll have to send the logic board off again for further repair and troubleshooting as locating and replacing bad memory chips and other parts is beyond my skillset.


Up to this point, the machine has largely worked fine. However, there may have been some subtle hints to a failing memory chip all along. MacMan would run fine on my SE but always refused to run on my Classic due to a memory problem. While playing Glider 4.0, some assets (such as the Macintosh Plus in the first room) had some strange graphics glitches. In the upper "waves" of Crystal Quest, the video would have some really odd glitches - often inverting the background and acting strange. Even the Sad Mac appears to have some problems. Could it be, as someone on the FB group pointed out, that the failing memory also drives the video?


Both Crystal Quest and Glider 4.0 acted up while I was shooting a video, so I'll try to compile that footage and post it here for further opinions.


I'm disappointed that the Classic hasn't been very stable. It's the machine I've put the most work (and money and love) into - as the logic board was recapped back in May and the analog board was recapped in October. Meanwhile, my 1988 Macintosh SE - which I haven't touched in terms of work - still works fine (knock on wood.) But I guess sometimes that's how working with vintage items go. It's like working with vintage cars - one day it may work fine, the next day it might not. You may replace the common trouble points and then have something totally unexpected go wrong.

Link to post
Share on other sites
  • 68kMLA Supporter

Sorry for the triple post. I removed the memory expansion card, plugged in the machine, turned it on, and... it turned on! Chimed and proceeded to boot into 6.0.7, as usual.


For further testing, I placed the memory expansion card back into the machine - making sure it was firmly in the socket. Turned the machine on and... chime! "Welcome to Macintosh" and proceeded to boot into 6.0.7. The "About This Mac" window shows 2,048k of total memory.


Perhaps I got lucky and all of this concern was caused by a loose memory expansion card? With all of that said... should I be concerned about the strange graphics glitches in the games (video linked in above post)? I haven't tried those games on my SE, so I don't know if those games are actually slightly damaged (they were all on floppies) or if there is a problem I should be more concerned about.

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...