Jump to content

Memory expansion on Macintosh Classic


Recommended Posts

Hi, 

 

I just recap a Macintosh Classic I bought (didn't try before recapping)

The motherboard is in good condition before (and after) recapping. 

When memory expansion module is installed, I got a 00000005 sad mac error code. Without the expansion module, the unit boot fine (but can't finish the boot because system 7 needs more ram) . I tried swapping with a known working module without any luck. 

So, I guess the problem must be located on the motherboard. 

Where can I look first ?

Thanks,

Link to post
Share on other sites

Huh, strangely enough I'm having a similar but not identical problem – recapped my Classic's AB (save for the really large power filter caps), have a known good LB. When the memory expansion is inserted, I get a blank screen (as if someone had removed the ROM), and then over time garbage on the screen. I wonder if the problem's really with the AB? I'll be checking to see whether I've installed the caps right on mine, checking voltages, etc.

Link to post
Share on other sites

Second on checking voltages; I'm guessing you tried the original "faulty" expansion card in another Classic as well? I suppose it is entirely possible that the original card is indeed bad, but you also very likely have another underlying issue on the logic board or analog board.

 

But yeah, check the voltages; low voltages can cause all kinds of weird boot issues. I ran into all kinds of funky behavior with my (now dead) Classic II; come to find out, the +5v rail was too low for the logic board to work consistently.

Link to post
Share on other sites

I found that mine was really picky about the RAM used and I went through several sticks that did not work or sort-of worked and gave symptoms, similar to the ones that were noted above.  I too questioned whether or not there was an issue with the expansion card, until I found the right ones.  I don't have any good examples of what doesn't work (I didn't keep track), but to finally upgrade mine, I used known, working, 1MB SIMMs that I pulled from an SE/30.  Oh, and from the apple documentation, you cannot use 2 chip SIMMs.  My MB has been recapped, as well.

Edited by Juror22
Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
×
×
  • Create New...