Jump to content

Macintosh SE FDHD - 820-0250-A Logic Board schematics

Recommended Posts

Hi to everyone!


I am new to the forum, and need some help with my Macintosh SE FDHD.

I just refurbished and fixed one Macintosh Classic and it works perfectly except SCSI HDD (which sometimes requires side kick to start spinning), for which I already purchased SCSI2SD on eBay and can't wait for it to arrive.


Anyway, I started refurbishment of mentioned Macintosh SE FDHD which was in absolutely terrible condition due to battery leakage (more like battery explosion, as it looked like from inside), everything was oxidized ... totally dead. I washed every part of it, besides HDD and floppy, as I did with Mac Classic and I managed to recap everything (except HDD and floppy drive ... really not deeded) and I fixed analog board (few transistors and diodes were shorted). I had to swap RAM with new RAM sicks (now it has 4MB), but when I plug it in and turn the switch ON, HDD starts to spin, but screen is totally black.


OK, I did not put any battery back to the mother board (I will ... these days), but this should not be the reason why the screen is black, right?

I know that there must be some signal generated by that big VLSI chip, but I cannot probe it with the scope because I do not know where to start since the schematics for Macintosh SE is nowhere to be found on the Internet. Of course I can look for datasheets of the ICs, but it will take forever.


To be more specific the motherboard model is 820-0250-A (1988). I found some schematics for SE/30 but not for SE FDHD.


Does anyone has schematics for motherboard model is 820-0250-A for SE FDHD, or maybe knows where to find it?


If you do, please share.


Link to post
Share on other sites

Sent you a PM.


The battery has no effect on booting, it only holds some basic variables like the time and for some reason the mouse speed setting among others. In fact I run my FDHD with no battery just in case I forget to remove it when storing it away.


EDIT: I should clarify the battery itself doesn't remember these things LOL

Edited by ignatio
i'm an idiot
Link to post
Share on other sites

Hi ignatio,


Thank you for the tip about the battery. I thought that this is the case, because that is the only logical thing. I was just wandering if it might not be the case because I found somewhere in the swamp of manuals I managed to download that the battery "should" be inserted on the motherboard. And there was one Youtube video in which someone booted Mac after inserting the battery (could be Adrian Black ... can't remember any more who was it exactly, nor what Mac was it exactly).


Also about the battery, it can't remember these things, then it get jealous and explodes of jealousy which destroys these great machines LOL.


Saw the PM, thanks, already got these ... unfortunately no plain SE schematics there, only SE/30 (quite different from plain SE). But I never give up, I will find the problem wherever it is, having hope that all custom ICs are OK.

Link to post
Share on other sites

Hi, yes, ignatio sent the same. Thank you both.

I do already have these schematics. I was just hoping that someone has a complete one.

I will try to use this one and check some routes on PCB, hopefully it will be the right one.


Seems to me that P4 connector is missing ("hard to read image"), which is a missing link for detecting where the CRT signals coming from. Although, P4 is on the analog board schematics. Also one of the rails is quite low on voltage, around 4.37V (might be one of non DC signals). Digital 5V rail is on 4.75V, and 12V rail is on 13.0V ... a bit high. I might swap PSU with ATX board from PC PSU, it might be more reliable with voltage levels. I have to inspect everything in more details with the scope first.


As I manage to do some progress, if any, I will post my progress.

Link to post
Share on other sites
  • 4 weeks later...

Finally I managed to do some probing with the scope. Unfortunately the "Gate array" IC is dead, it does not provide a clock signal to the CPU and it is not showing any signs of life.

But luckilly I just installed IDE2SD to the Macintosh Classic and it works great.

Thank you guys for trying to help.

Link to post
Share on other sites
10 hours ago, cheesestraws said:

There's some work being done on reverse-engineering the gate array stuff on the SE in another thread under "hacks and development"; might be worth keeping an eye on that.

Thank you cheesestraws, I will take a look at it. I need to check if it is worth time and money. Also, I would like to build it by myself if I can do it im my workshop.


10 hours ago, LaPorta said:

Which IC is that? I have some crummy SE boards, I could probably get a chip for you.


Hi LaPorta,


I will send you photo of the IC, maybe you have it. Althou, I have Eurpean version of the Mac SE FDHD, and I do not know if I can just swap it. But if the P/N is the same that should work.


Link to post
Share on other sites
12 hours ago, LaPorta said:

Which IC is that? I have some crummy SE boards, I could probably get a chip for you.

Hi, I'm back with the immage of the IC.


Or, even better, maybe you could sell me the whole board? Because the battery damage is substantial (had to put new RAM sticks, the old ones were unusable) and I don't know if some other part is potentially damaged. I did try to wash the board twice and did resocketing, recapping, removed as much rust and battery residue as possible, ... but still, one can never know what is "behind the curtain".20201109_113657.thumb.jpg.dfdf536a5f2d2ab92036d4181306a85f.jpg

Link to post
Share on other sites

Just for the sake of sharing experience I will post more images here than needs to be post.


When I opened the Mac I found battery on the opposite side of the board sicked to the front plastics near the speaker as on the image below (this one is taken from the video I was preparing):



It seems that after the battery exploded it made an exceptionally lot more damage on the areas marked on the image below:



And a lot of damage on RAM, as the image below shows:



So I bought 4 new sticks of 1MB of RAM.

After I cleaned everything as much as possible and did what I mentioned before in this topic, now it looks like this:


But the oxidation is still present on many parts and places all over the board, I couldn't take it of with any of the chemicals I tried. And I did not want to damage the board trying any more.

At the moment I am thinking that the damage made on the socket of that VGC chip might be the problem. I think I should give it one more try by checking conductivity of every pin from IC to the board before I ask you again for the price for the board, if you have it.

Link to post
Share on other sites
  • 68kMLA Supporter

That is helpful. My SE looked similar, although there was only one rust spot, not two like yours. I had a very tough time getting it to work, and eventually found out that there was a corroded via underneath the SCC chip that needed repair. I was unable to desolder the chip, so I had to hack it out and get a replacement. I pretty much had to look at a radius of where the goop was before I cleaned  to track where it might still be lurking. My thread was here if you'd like to look for reference:




EDIT: I did not see your request for the board until now. I am keeping it as a spare parts board in case I need anything in the future, or I may try and repair it. It is not currently functional, and I am not sure what is wrong with it. I may still have extra individual chips, though.

Edited by LaPorta
Link to post
Share on other sites

I was just reading your thread "SE FDHD Restoration" you posted above. Is looks much, much, worse on the area around the battery then my case. But this is very useful, thanks!


When I bought it, a guy who sold it to me said that Mac was working after he stuffed it somewhere in the attic. I can only assume that this might be true and that the corrosion is only a consequence of battery damage. I did not try to turn it on before I opened it and made an inspection. When I saw the extent of the damage, I first repaired analog board and after that I did recapping, washing and fixing of the logic board, I bought and swapped RAM sticks with four new 1MB and removed RAM jumper (as per instructions in manual). Now there should be 4MB instead of 2.5MB RAM inside.

After that I try to turn it on for the firs time. So I hope there was no possibility for any shorts. And, also, the the voltages are within expected ranges now.


Based on what I saw in your thread, I think I have to desolder that VGC IC and maybe some others and check the state of the board underneath, put new sockets inside and then try it. Maybe even slightly grind (clean) pins of the VGC IC.


It will take some time to get new socket for VGC.


Thank you for helping and sharing ideas.

Link to post
Share on other sites

Seems like I was lucky today. After tracing signals with the scope and inspecting everything with magnifying glass for several hours I was lucky to notice that VGC IC pins and it's socket had micro gaps between. So I took it out and i cleanned IC pins/legs and pushed them towards outside of the IC, and also I pushed contact on the socket towards inside.

After that I put everything back and heard a magic "BONG !".

And to my surprise ... it works ... again ... TADAAAAA!!!





And I finnal setup ... time to dissasemble it and wash the housing thoroughly.



Just beautiful ... time to buy another SCSI2IDE.

Link to post
Share on other sites

Nice!  Glad you were able to solve the problem by cleaning and tightening up the BBU socket connection.  I've been looking into re-implementing its functions and made notes about it on the reverse engineering thread that cheesestraws mentioned.  The BBU itself isn't a complicated chip, it just has a lot of I/O pins and runs a 5 volts, which is what makes getting a drop-in replacement FPGA tricky.  So yeah, always good if you can keep using the original BBU chips.

Link to post
Share on other sites

I am always interested in that kind of development. I will take a look how you are proceeding with the development ... maybe I can help with something. The only problem is the time ... work/family/hobby balance and other retro equipment I managed to pile up in last two years, which needs to be put back in working order and thoroughly cleaned.

Link to post
Share on other sites
  • 3 weeks later...

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...