Jump to content

Color Classic Startup Troubleshooting

Recommended Posts

Okay, experts, here's what I've got.


CC without the mobo installed powers up.  Fans spins, etc.

Insert the mobo, and no joy.

Left it plugged into power overnight, still no joy.

Removed the PRAM battery, still no joy.


Inspected the mobo, but I don't see any evidence of damage, cap leakage, etc.  Leads to the connector are bright and shiny.


At this point, my main suspects are the ADB ports.  Any thoughts?



Link to post
Share on other sites

One more piece of information that may help: the system failed "overnight."  Literally.


The evening prior I had been working on the machine, got the system loaded on a SCSI2SD, etc.  Shut down.  The next morning -- nothing.


What would cause this kind of abrupt failure?



Link to post
Share on other sites

Given the state of the board (see below), I don't think it's a cap or goo issue, but then I may not know what it is I am looking for.  Am I missing something obvious?


In the meantime, I'll do a search for troubleshooting the egret chip.






Link to post
Share on other sites
8 hours ago, Daniël Oosterhuis said:

The third picture really shows that this board needs a recap, as well as a thorough cleaning. The solder and solder pads around the caps and other components have some heavy corossion from years of capacitor leakage.

Well, I did admit that I didn't know what I was looking for!  :)  Now I know.


Any recommendations for US-based recapping services?



Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...