Jump to content

Mac Classic - Assistance needed

Recommended Posts

Hi All, and thanks for having me here.


It seems I'm yet another person with a Mac Classic that is dead.


It was working fine up to about 6 months ago and would happily boot from its internal hard disk. I put it to one side as I had other projects on the go, as I'm mainly to be found on ST forums as a mod and a repairer, but despite their similarities, my knowledge of the Mac Classic is limited.


I have done a lot of research though, and spent a lot of time trying to get a handle on this problem, which is this screen at boot time:




No bong or sad Mac, just the checkerboard.


So far this is what I've done.


1. Removed the 7 capacitors that are known to leak on the logic board, and replaced with tantalum equivalents. Note the picture of the mobo shows C5 and C9 missing, these were taken out to troubleshoot a non-existent short, but have been subsequently refitted.
2. Cleaned the area around the caps with IPA and thoroughly washed the logic board in soapy water and dried for 48 Hours.
3. Replaced the leaking PSU capacitors on the analog board.
4. Possibly killed the ROM. It has a 42 pin socket, and for 40 pin ROMs should be plugged in starting at pin 2. I mistakenly plugged into pin 1 after cleaning the pins on the ROM, and it got rather warm. :(


I should say that despite the leaky caps on the analog board, none appears to have got down to the logic board, and neither has the battery leaked. A very small amount of electrolyte was present around the 7 electrolytics, but no corrosion was visible and it has been thoroughly cleaned.


Here is the logic board:




Whilst I suspect the ROM because of my hamfistedness, I'm not sure it's bad, as I tried a ROM emulator today, both with normal and byteswapped images just in case, but I get the same image on screen. I also get the same image on screen with no ROM installed, so I think this is something more fundamental than the ROM. Also, the /CE signal at the ROM is high, suggesting it's not active. I am wondering if RAM is the problem.


I'd even be inclined to say that it isn't even getting to the stage where the ROM is accessed. CPU has a clock of just under 8Mhz (7.834Mhz to be exact) and the /HALT & /RESET lines are high. Checking online the CLK speed should be 7.8336Mhz, so that's 100% fine.


I've been over the PCB with my microscope, and can't see any shorts or corrosion and I don't see any corrosion on the underside either.


I should also note that after changing the PSU caps on the analog board, voltages were low under load, so 4.77v and 11.6v respectively, so I have tweaked and now get a stable 5v and 12.2v. The HDD spins up at power on too.


Having done everything suggested that I can find on the web, I'm a bit stuck as to what's next. The only things I haven't yet done are to re-flow (re-solder!) the power lead at the analog board and change the optocoupler on the analog board, and I have some of those on the way, but other than that, I'm at a bit of a loss.


If there are any other possibilities and suggestions out there, I'd be glad to hear them as I want to get this machine back up and running. The trouble is, unlike with the STs, where I have experience, and diagnostic tools (Plus I own a stack of them), I know very little about the Mac Classic, other than the schematics I have. 


Thanks in advance!

Link to post
Share on other sites
8 hours ago, erichelgeson said:

If you haven't tried a known good set of ram I'd do that, my se/30 showed this with bad ram. Seems like you've tested almost everything else!

Thanks for your reply!


The problem I have is that some of the RAM (8chips) are soldered onto the logic board. I probably should have mentioned that I have tried with the RAM daughterboard removed and I don't get the checkerboard, just fine horizontal lines.


I can rework the RAM if required, I just want to be damn sure it's that before breaking out the hot air gun and buying chips. Based on the RAM chips I think it is 1024KB of onboard RAM. 


I think I'd better break out the logic analyser and scope, see what the RAM and address/data lines are doing too. I just need to figure out a way to get it easily accessible as the power lead from the analog board is short, so getting to where I need is hard, even with the logic board out of the machine.

Link to post
Share on other sites
17 hours ago, erichelgeson said:

Can you show a picture of that? I hope you don't have to go down the on board ram path!

Yes, afraid it isn't great due to the sync with the camera,but you can see the difference, especially when zoomed in. I'm really hoping it isn't the onboard RAM. I am also posting on the forum I moderate on, got some good suggestions just come in over here: https://www.exxoshost.co.uk/forum/viewtopic.php?f=18&t=3187&sid=f46145394e7703f29ea86e33807b48e1#top so I will look into those too.




Hopefully my other parts will be in soon too and I can get the optocoupler replaced as well.

Edited by Roninfourseven
Link to post
Share on other sites

I would think, that it is a problem with the rom. If you get no chime, then the access to the rom failed. 

If you have access to a eprom burner you can burn a new rom. Rom copies can be found in the internet. 

I own some classics but none had problem with the ram on the logic board.

Link to post
Share on other sites

@dochilli funnily enough I have just done that and will try it out later :)


I'm using a 27C400, which is 512K, so I presume that will be suitable? The image wrote no problems, though I don't know if it needs to be byteswapped or not, but the ROMs I have are erasable so not an issue if they need to be.


Might explain why I see the same with or without the ROM installed. Also got new optocouplers, so I may well replace that because I can.

Edited by Roninfourseven
Link to post
Share on other sites

So I have a couple of 27C400's and they program fine with an image I located on the web for a Classic, and I also have a 27C400 ROM emulator which can hold multiple images, and no different.


I measured the 5v and 12v rails at the floppy port and it was fine. I also removed and refitted the power socket and found a lot of cap gunge underneath, so that was cleaned up.

What was disturbing though is that after refitting the socket (Oriented correctly BTW) when I powered on the CPU was getting very hot quite quickly, so I switched off in a hurry. The socket is off again and having picked through the schematics I now have the pinout so I need to check over the power rails for potential problems like shorts. Other chips were cool.


It's a bloody frustrating little machine, and for everything to be SMT bar the ROM, not going to be easy to troubleshoot.


I need to try and run it under a load and double check the PSU outputs, but I'm really concerned that it's dead properly now.

Link to post
Share on other sites

Ok, so I've pulled the CPU and with power on, nothing else get's hot, so maybe CPU and ROM are dead. Checking the voltages on the power connector (Now re-soldered), I get what I expect, 5v, 12v and -12v.

Wondering if the CPU and ROM had some sort of pact to die together!! I certainly can't read the ROM for sure,even with my new 27C400 adaptor for the TL866. I can certainly write 27C400 EPROMS and read them back, though the original ROM is a mask rom from what I can tell, so that may be part of the problem.

Voltages across the RAM seem good too and I can't find any shorts at the power plug, so that all looks fine. Ordered an SMT PLCC socket so I can pull the chip again easily if I need to.

I also checked the GND and power pins in the CPU area and they are all fine with no shorts, and the CPU, had it been fitted, would have been getting 5v at both VCC locations. Nothing else around the connection array seems to have a short either.

I guess we'll see what's what when I can get the CPU back in.

Link to post
Share on other sites
12 hours ago, dochilli said:

I have one or two dead classic boards (maxcell bomb). Where do you live (I am from germany)? Perhaps I can send you a rom or the whole board for spare.


That would be incredibly kind, though I am in the UK so I'm not sure how we could work it? I would of course be happy to cover the postage, would you want anything for the board?

Link to post
Share on other sites
10 hours ago, dochilli said:

Actually I am not at home. I could send the board after the 17. august. I have to look at the boards to see which will be the best for you.

You can send your adress as a PM to me. I do not want any money for the board or for shipment.


That is amazing, thank you so much. I will PM my address over, and am waiting parts for the next repair anyway, and won't be able to look at it this weekend, so things are going slowly anyway. I just realised that by Maxel bomb you mean battery leakage!! Luckily I don't have that problem, but spare parts are most welcome, thanks.

Link to post
Share on other sites
  • 2 weeks later...
12 hours ago, techknight said:

Your missing 2 out of your 4 caps though. I did notice that right away. 

I'm not that dumb!


They aren't missing, just not fitted in that picture as I was testing for shorts. It looked like C5 and C9 positive sides were connected to GND, however looking at the circuit in that section, that is correct. They are connected to a -5v regulator, so the negative side of the cap  is connected to -5v and the positive side is actually connected to GND. Electronically correct, but when you're testing for shorts it does give what looks like a short.


Getting schematics helped massively in understanding why it wasn't actually a short.


Both caps are reinstalled and I'm in the process of fitting a PLCC socket for the CPU.

Edited by Roninfourseven
Link to post
Share on other sites

@dochilli Thanks so much, your 'care package' arrived today, it shows how bad the Maxell bomb can be!! My board luckily didn't have that, but clearly there is other stuff wrong.


I have the old CPU off my board and a socket to install in it's place, plus a spare CPU (One from an Atari STE, one on the board you sent) to work with, plus I have my microscope properly set up now, so I can get to work on the next phase. The ROM on board will be a great help to as I'm pretty sure mine is toast.


Fingers crossed I can get it back up to speed and then onto the next thing, my beeping Amstrad ALT386!!

Edited by Roninfourseven
Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...