Jump to content

Apple USB Mouse (M4848 - “hockey puck”) problems

Recommended Posts



After about a decade of being packed away in its original box, I decided to get out my tangerine iMac DV so my four-year-old daughter could have a computer of her own.


This iMac DV was my daily computer from about 2000-2003, after which it received only occasional use until about 2010, when I boxed it up and put it away. In the later 2000s, the original puck mouse (let’s call it “Puck 1”) had become increasingly flaky: The pointer would stop responding. When I unpacked the iMac DV last month, Puck 1 was completely unresponsive, both with the iMac as well as more modern Macs I have. No amount of unplugging/replugging or cable jiggling resulted in any response. I took Puck 1 apart but couldn’t find anything obviously wrong like a severed connection or a leaking capacitor (not that I’d really know what to look for).


A USB Mighty Mouse that I had laying around did work with the iMac, however.


Wanting to maintain the iMac’s aesthetics, I bought another puck mouse (Puck 2) through eBay and swapped its graphite accent panels for the tangerine ones from Puck 1. When I first connected Puck 2 to my iMac, the pointer moved smoothly, but the button was unresponsive. After some amount of swapping ports, jiggling cables, and trying to blow out connectors, the button situation was reversed: The pointer was still responsive, but now the computer was acting as if the button was being held down constantly. Since Puck 2 was unusable, I gave up and set it aside. A week or two later, I decided to give Puck 2 another try, and to my surprise, it worked. Everything seemed fine at first, although the pointer seemed to become unresponsive intermittently—sometimes for less than a second, sometimes for longer periods. Like its predecessor, Puck 2 gradually became more and more unresponsive to the point where, now, it’s virtually dead.


Since the problems with both puck mice at least began as being intermittent and could (seemingly) be affected by jiggling the cable, I’m inclined to believe that the issue is a break in the cord, a loose connection, or something like that. 


Are these M4848 mice known for being failure-prone—and are there any known fixes? Are any of them more reliable than others (for example the early Bondi blue models vs. the later candy colored ones)? I haven’t been able to find many similar reports from other users, and searching variations of “imac mouse failure” just brings up the bandwagon of clickbait articles dumping on the mouse for its ergonomics. These mice aren’t terribly expensive on eBay, so I could buy Puck 3, but I don’t want to keep buying one flaky replacement after another.


Ironically, the next closest alternative for a “stock” looking mouse would be the first generation Apple Pro Mouse (with the black body and braided sliver cord—as those were sold with the later iMac DVs), but I have run into a number of reports of those failing, so maybe I’d be trading bad for worse if I tried one of those instead.


Thanks in advance for any experiences or advice you can share!

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...