Jump to content

MacII Ci won't power up. After mod won't stay on... RasterOPs/24 problem and more.

Recommended Posts

Hi guys,

I will try to be as clear as I can and mix up two situations without cluttering the forums with two threads as one should be enough.

But I can be lengthy... 


Lets have a bit of background, about 1.5 to 2 years ago I got this MacII ci with RGB monitor and a RasterOps/24. The RasterOps/24 I was only able to see in action once, on the first time I powered it on, as the system hanged and after a reset it prevented the computer to boot properly, but let's let the RasterOps for another day and another post.


I didn't used it for about a year and as we are on quarantine, I decided to check the RasterOps, and all my problems arose. 

So, as far as I can remember, the system powered up normally then when I got it. But I saw some cap leakage on the board and recapped it, even the electrolytic capacitor - and this could be my big mistake. I have enough knowledge about recapping smd capacitors. Done in my other classic macs, amigas and so on. But I don't know why I decided to replace the electrolytic axial ones. 

And I don't remember if, it was just after the recap, or some time later, it started not to power up. 


Probably I asked here or on a Facebook group what to do and did the mod in the pictures, it worked with no problem until yesterday.


What happened yesterday: I powered the system on and used a cable I have here which works with a lot of my macs. I used the internal video output. This cable connects the DB15 to RGB (HD15) and my LG monitor supports 15KHz or 31 and recently used my Quadra950 and the G3 beige. I know the Macs video connector despite of being DB15 have different pinouts and signals, but I gave a shot. I was able to hear de startup sound the harddrive booting the system but no image at all.


I powered it off and installed the RasterOPs, used the same cable in it and for my surprise the computer booted to the system. But the mouse was not moving. The clicks were working and keyboard responding (but wasn't able to power off by keyboard). This mouse thing drove me to take wrong conclusions, and I thought I had an ADB problem on the board. Later then I discovered the problem was the RasterOps/24, I locks the mouse movement.


This mouse problem led me to think the problem was related to the softpower as the StartUp Circuit schematic I have, mentions ADB. And I took a look on the recap I did and saw C17 (one of the axials) could be better. I replaced it.
Meanwhile the RIFA cap on the PSU blew. I removed it and the PSU is working again, but was I ordered today new ones, I am using the MacII Cx PSU I have handy here.


I decided to remove the RasterOps and connected the MacII to the RGB monitor it came with. Now the system was not powering up, the power led flashed two or three times and some noise on the speaker but no power. And some moments later, it was booting again without changing anything. I was relieved. 


I turned around to grab the hard drive and reassemble it and noticed it powered off. Turned it on again, booted to the ?? icon and stayed there for some seconds, powered off. Tried again and the same led flash and sounds on the speaker happened. Then it powered for some seconds and powered off. Powered it on again and lasted longer but powered off again. Sometimes I can get to the system but sometimes it wont last seconds.

Both PSUs are working fine on the MacII Cx so I think there is now something really wrong with the startup circuit of this MacII Ci.


I will revise the post to check if I forgot something but now I need some advice where to look to solve this problem. I only replaced C17 yesterday. And during the time I didn't figured out the RasterOps was holding the mouse movement, the system stayed on for long time.

Thanks in advance.




Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...