Jump to content

Performa 476 Restoration


Recommended Posts

  • 68kMLA Supporter

I picked up a floppy enclosure, LCII, and Performa 476 on Craigslist! In this thread, I'll focus on the restoration of the Performa 476.

 

IMG_20200310_183300.thumb.jpg.50c4105d6c6178bf8db327e776de8236.jpg

 

At first glance, it doesn't look it, but this thing is pretty dirty!

 

IMG_0454.thumb.jpg.f2910fc27a9f225d6d2502056f98435a.jpg

 

And of course, someone wrote "GOOD" on it with a Sharpie. It was good until you did that!

 

IMG_0455.thumb.jpg.578143b1233dc80a562372d7a1e7ef57.jpg

 

I managed to get everything apart without breaking any clips. My hope is to put it back together once, so I don't risk breaking anything more than I have to. It does appear to have the original 230 MB hard drive.

 

IMG_0458.thumb.jpg.36e7ec485a21732f9930a5940382f6be.jpg

 

First, I want to Retrobrite the case. This will be tricky for a few reasons:

 

1. It's not sunny right now.

2. I'm completely out of liquid hyrdrogen peroxide... and because of Coronavirus, I want to stay home. I'm not sure that the beauty supply store would have what I need anyway, given the current situation. I do have 40 volume cream... I'll have to work with that.

 

I needed to get the Apple badge out (retrobrite can cause it to fade), so I drilled a tiny hole in the metal shielding to push the badge out from the back. No shot of the hole here, but here's where I made the mark.

 

IMG_0459.thumb.jpg.da3b1b66bb69d84e9645c010d6fb7f2c.jpg

 

Time for cleaning! As usual: a toothbrush and dish soap are my weapons of choice.

 

IMG_20200322_180827.thumb.jpg.347bbf248b81604d644ae25a5168ce37.jpg

 

I went as far as I could with the soap before switching to alcohol to work on that Sharpie "GOOD".

 

IMG_0463.thumb.jpg.6cb93169a37d4bc1f11d737aa9b664c3.jpg

 

And this is where I ran into problems. Normally, I'd grab some baking soda... but guess what we're out of? No problem, I'll go to the store and... nope, can't do that either. I ended up waiting a couple of days before one of our neighbors made a run to the store and asked if we needed anything. They left baking soda in a brown paper bag on our doorstep.

IMG_0464.thumb.jpg.10eec33b6dfa55cd63650c8d1b64d47c.jpg

 

Baking soda and a wet paper towel does remove a tiny, tiny bit of texture... but it works great for black marks and Sharpies. All clean now!

 

IMG_0465.thumb.jpg.b93725a66a51f94814664404adc1ed9b.jpg

 

As you can see, the bottom is pretty good, but the sides and top have varying degrees of yellowing. I decided to focus on the bottom first, so I could test retrobrite methods and get the machine back together sooner, as the top isn't specifically needed for assembly.

No pictures of this part, but I first decided to do my indoor retrobrite method: a CFL UV "lizard" lamp in a cardboard box lined with tin foil, hydrogen peroxide cream, and plastic wrap. I did one 4-hour treatment, but abandoned the idea going forward for a couple of reasons:

 

1. We're running low on plastic wrap, and again, I can't go out to get more

2. I'm running a bit low on hydrogen peroxide cream

3. This can cause streaking if you're not careful... and I don't want to risk it

 

So I decided to change plans. I filled a container with hot water and added a fish tank heater that should be able to maintain 92°F. Initial temp was about 110°F. Then, I added 1.5 cups of hydrogen peroxide cream, and mixed it in with a large whisk from the kitchen. Here you can see the water without the peroxide (it looks somewhat cloudy now, but you can see through it, sorta).

On the container is a plastic lid (to avoid electrocution), and above that, the CFL UV lizard lamp.

 

IMG_20200325_082853.thumb.jpg.98092b3f9e63a9b31015c30c5b052f57.jpg
 

After 2 hours, I don't see a difference, but this method is probably very "low and slow". I might move it out into the sun if we get any today.

 

Next, we'll recap the logic board! More on that soon.

Link to post
Share on other sites
  • 68kMLA Supporter

Time to recap the logic board! Of all of the logic boards I've recapped, this is one of the cleanest.

 

IMG_20200324_215633.thumb.jpg.fdccec6f5a41d7c7373b2e66c6fb6c24.jpg

 

First, I removed this thing:

 

IMG_20200324_215716.thumb.jpg.cd6393f07bacc189e5b00fe9ce00538e.jpg

 

For the 5th time, I used the "twist" method. So far, I've only lifted one pad doing that so far. On this board, things went perfectly.

 

When I disconnected the hard drive power, it pulled out one of the "pins". On closer inspection, I realized that the Molex connector was completely gone, and someone had soldered something in place to work as pins. What a mess. 

 

IMG_0469.thumb.jpg.d9916a0edb3475180516b1b77147831c.jpg

 

I think the replacement I need is this part. I'll order one along with a set of capacitors for the power supply shortly.

 

After twisting all of the old caps off, I fired up my soldering iron and heated up the pads, knocking the leftover legs off one at a time. After that, I went over each pad with desoldering braid to clean it up. They cleaned up very easily. Usually, I have to apply flux and burn through a bunch of corrosion but that wasn't the case here. After desoldering braid, I clean all of the pads with cotton swabs and isopropyl alcohol.

 

Here you can see most of the caps removed, but I haven't cleaned up the pads yet. Image above with the power connector shows cleaned pads.

 

IMG_0467.thumb.jpg.b32cb094b737b1f655627079eb5a319e.jpg

 

Next, it was time to solder on caps. Here are prefilled Digikey shopping carts with the capacitors that I used:

 

Quadra 605/Performa 475/Performa 476 Logic Board Capacitors: https://www.digikey.com/short/zjhq02

Astec Power Supply Capacitors: https://www.digikey.com/short/zjhq1d

 

As usual, my process is to heavily tin one pad, heat the pad, slide the new capacitor into place, and remove heat (and then tweezers) when I'm satisfied with placement. Then, after double-checking polarity, I solder down the other side. Here are the results:

 

IMG_0471.thumb.jpg.d4963ee6526e9ade54e9aa0f1f48f486.jpg

 

One thing I like about these specific caps is that they look almost factory. You can barely tell that they were installed later. C19 is an example of a factory cap.

 

IMG_0470.thumb.jpg.fb2ee92a1c0556bf8bd20f82c9a27269.jpg

 

Before I end this update, I made a bit more progress with the RetroBrite. After most of the day sitting indoors maintaining about 100°F, I moved the container outside, where ambient temp was 50°F. In sunlight, it would easily maintain 100°F, but if there was cloud cover for a significant amount of time, it would dip to 85°F. I think the $13 fish tank heater did a pretty good job! I think this is a viable solution for RetroBrite on cold but sunny days.

 

IMG_20200325_143855-1.thumb.jpg.9893a970f40c7e272cfd900b149fa174.jpg

 

IMG_20200325_185356.thumb.jpg.3d5cad187a34c7f2b4f905390c44db80.jpg

 

After most of the day indoors under the UV lamp, and about 2 hours of hit and miss sunlight outside, I pulled the bottom out and rinsed it. It's about 95 percent done, which is where I think I will stop; I expect diminishing returns since my hydrogen peroxide is pretty thin and also cloudy since it's cream mixed with water.

I decided to bring the container back inside (ambient temp 68°F in the house), put in the top half of the case, and leave it under the UV lamp all night.

 

I'll report back tomorrow!

 

Link to post
Share on other sites
  • 68kMLA Supporter

After leaving the bottom half of the case under the UV lamp all night, I decided that it was done. Time to switch to Retrobrite for the top. I started out with it outside:

 

IMG_20200326_115620.thumb.jpg.e6a6dc4a529e0e3b4c386cf8918d4a72.jpg

 

Cloud cover was hit-and-miss, so I ended up leaving it under the UV lamp inside all night. After a full night, I was very sad to find that the metal shield inside had started to rust. I'd been warned about this here on the forums before but had forgotten. I didn't get a photo of the rust, but you can see a bit of it when I used flush cutters to remove the shield.

 

IMG_20200326_164727.thumb.jpg.8575307f6b739092c602f0380166f9be.jpg

 

Anywhere that the plastic touched metal was the first to rust.

 

IMG_20200326_164920.thumb.jpg.5d0d868be9bba5524959a0a9f5a1c8c9.jpg

 

To address the rust, I soaked the whole thing in vinegar in a cookie sheet for a few hours (turning it on each side to get everything submerged for awhile), before scrubbing the rust with a toothbrush. Then I rinsed with water and left it in front of the gas fireplace to dry.

 

I'm glad I learned my lesson on this Performa 476... this is a bit of a "test run" before I restore the LCII, which is slightly more important to me than the Performa, because it seems like the quintessential "pizza box" Mac to me.

 

IMG_20200326_222706.thumb.jpg.71d8c758cb8473dbbd5150b7dd0f8584.jpg

 

But how about the Retrobrite? Compared to the LCII, this looks perfect! The reality is that it's not - there are a few spots that have a tiny bit of yellow, but I think I'm going to stop while I'm ahead. It looks uneven in this photo, because it's still slightly damp, but don't worry, it looks pretty consistent in color when it's dry.

 

IMG_20200326_211401.thumb.jpg.fed575267d76ea10a868d094c3b2850e.jpg

 

Here it is next to the LCII again:

 

IMG_0472.thumb.jpg.f96cf05d6fd680a60e659e162d6e8757.jpg

 

 

The red band on the badge is a bit faded. When I bought it, I could tell that it was in direct sunlight whenever the seller's garage was open. I wonder if anyone will ever make reproduction badges?

 

Sadly, the "GOOD" is still visible. Ugh.

 

IMG_0475.thumb.jpg.9f4189f05dfa4698629d48d9ef0d3735.jpg

 

I thought this was as far as I'd get for the weekend, but look what arrived! I'm always shocked at how fast Digikey gets parts to me for $4.99 in shipping.

 

IMG_0476.thumb.jpg.02fb9ea6443188d9c33c9a0adf9961cd.jpg

 

I don't have any photos, but I cleaned up the shield and reinstalled it. It seemed to snap back into place, and didn't need any hot glue on the old plastic posts that I clipped off with the flush cutters.

 

I didn't show this earlier, but when I took it apart, I found this awful "fix" for the hard drive power connector. The connector broke at some point, so someone soldered in these awful "pins" to fix it. Gross! Part of my Digikey order was a new connector to replace this. Figuring out which connector to buy was MUCH more difficult than soldering the new one in, which I'll show you now.

 

IMG_0457.thumb.jpg.f31300c0ace3acf38f6aa5b71a9f1ec6.jpg

 

Testing to make sure I have the connector oriented correctly. The anchors on each side only go in one way, but I wanted to be sure it was all correct before soldering it down.

 

IMG_0482.thumb.jpg.3eb90ed704d359404fb0c61b59887c93.jpg

 

Next I desoldered the old "pins", and cleaned the holes out with desoldering braid. Also, check out those gorgeous capacitors! :p

 

IMG_0483.thumb.jpg.b425a6ea84f87efc0d2c1f4a76386195.jpg

 

And there's the new connector installed! That looks so much better. Even though I'll probably end up putting a bus-powered SCSI2SD in this at some point, I couldn't stand it not being "right". I also didn't want to have to remove the logic board again either for fear of breaking the plastics. And besides, that hard drive might still work!

 

IMG_0484.thumb.jpg.cdfc7752885c89d88454db894ad5ba04.jpg

 

And here it is, right now. Tonight, I'll clean the floppy drive out and recap the power supply (new caps came in that box from Digikey). I probably can't test it, as I don't have a VGA display other than my 2009-era Sharp Aquos TV, which is a bit picky about input resolutions and refresh rates. @sclements is sending me a VGA monitor, but I'll probably have to wait until it arrives to see if this thing works.

 

IMG_0485.thumb.jpg.0157cdb56eced29672c613e5eaa79023.jpg

Edited by PotatoFi
Link to post
Share on other sites
  • 68kMLA Supporter

Great work so far, keep it up!! You can't beat a pizza box Mac :)

 

I have an LC II and a LC 475 that both need the same treatment. I have a gap coming up between jobs soon so I hope to start tackling some of these projects soon.

Link to post
Share on other sites
  • 68kMLA Supporter

Last night there were two more things to tackle: the power supply and the floppy drive. First, the power supply. To keep track of screws, I write a tiny number next to each screw hole with a Sharpie to keep track of where they all go.

 

IMG_0486.thumb.jpg.32222cf69bb744e18310a09626342385.jpg

 

Uh-oh. It immediately became apparent that this Astec PSU is not the same as the Astec PSU that I recapped for @sclements last week. I ordered an identical set of caps... and they might not work here.

 

IMG_0487-1.thumb.jpg.52047fff0edc2ba65d3ab82be3ac7691.jpg

 

Yeah, nope, they're not the same. I used my iPad Pro + Pencil to take note of what each caps specifications are, including diameter, height, and lead spacing.

 

IMG_0487.thumb.jpg.2d75c6ea0493ccf0c28d75e52ef14e39.jpg

 

A few of the capacitors ended up working, including the big chokercap(tm), so I replaced what I could and left the rest. The good news is that there was no bulginess or cap juice anywhere. The new caps don't have red Sharpie marks on the tops.

 

IMG_0492.thumb.jpg.92e8491566a913aef7a5a1a46ccbf758.jpg

 

Next, the floppy drive.

 

IMG_0493.thumb.jpg.822a7f93c22a97eb14f1b39a4a97d119.jpg

 

A screwdriver released the little clips on the sides.

 

IMG_0494.thumb.jpg.aa273d813f0c0723a965c7454beac7cb.jpg

 

What the heck is this?! Ugh, more SMD electrolytic caps. If the drive ever stops working, I know where I'll look first. While it looks pretty corroded, I hit it with some alcohol and it looks the same. I think it's fine.

 

IMG_0495.thumb.jpg.f86b33ac6ce2429da9266a382ecb44e8.jpg

 

I'm very unfamiliar with these drives, so I decided to not tear it down. I hit it with some compressed air, and cleaned it a bit with cotton swabs and alcohol where I could. I cleaned the gunk off the leadscrew for the read/write head, and added a drop of Dupont Silicon Lubricant, and reassembled it.

 

IMG_0496.thumb.jpg.aa851e2261a1dd43f9f1f59057da0ca6.jpg

 

And here it is, completely reassembled and ready to fire up!

 

IMG_0497.thumb.jpg.c3a2ce9adf199b3e91d24ca60dd0fff7.jpg

 

Now remember that I don't have a proper monitor for it, so I have to use my 2009-era Sharp Aquos LCD TV. It's very picky about input resolutions and refresh rates, so if it doesn't output 640x480, it probably won't work. I plugged everything in, fired it up and...

 

After a chime, nothing. No video.

 

No idea what could be wrong. I messed with the TV for about 15 minutes, because it wasn't showing any input signal at all (not even a warning about an incompatible signal), when suddenly it dawned on me...

 

I'd forgotten the PRAM battery.

 

My buddy @sclements will laugh, because earlier that day, he'd tried to boot up his Quadra 605 and had no video. When he checked the PRAM battery voltage, it was flat. A fresh battery immediately fixed the problem. And here I was, only about 6 hours later with the same problem, and I couldn't figure it out. A fresh PRAM battery, and then:

 

IMG_20200329_132209.thumb.jpg.8cb774a008c1f0f576db326c776b19e5.jpg

 

It works! So... that's it, this machine is basically done! Currently, it has System 7.5.3, 20 MB of RAM, and the original 230mb hard drive, which seems to be working fine. It looks like the last time it was touched was around 1999. There's a few spreadsheets, and someone's W-2 (complete with social security numbers, yikes). It was fun to poke around a bit to see where the machine came from - looks like it was used in some kind of healthcare business in a nearby city. I'm surprised that the hard drive exited that environment intact. I'm glad it did for the sake of preservation, but I think I'd like to completely wipe it and install a fresh operating system.

 

Future upgrades would be more RAM, and perhaps an Ethernet card. I think the hard drive is new enough that it might actually last awhile, so I'll hold off on a SCSI2SD.

 

So, the big question. Which OS should I install? Keep in mind that I have a System 6 machine in my collection (Macintosh Plus), a System 7.0 machine (Macintosh SE FDHD), a Classic II, an SE/30, and a PowerBook 170... so I'm leaning towards making this my "System 8.1" machine. Any thoughts?

Link to post
Share on other sites

I suppose it depends on if you want to use it for anything in particular, or if you just want to have a System 8.1 machine. I had 8.1 on a Centris 650 back in the day (can’t remember how much RAM it had), and it was... fine. It definitely wasn’t fast. I’m planning on putting 7.5.5 (probably) on my current Centris 650 whenever I get around to reloading it.

Link to post
Share on other sites
  • 2 weeks later...
  • 68kMLA Supporter

Quick follow-up: I had the machine running when we experienced an earthquake. We grabbed the kids and ran outside, while the machine and four 3D printers in my office kept running. A few minutes after the earthquake stopped, we were back inside, and settling down, the hard drive started making a horrible horrible noise! Sounds like R/W heads skating on the platters. Not sure if it was simply from a couple of hours of use, or if the earthquake got it, but now I need a SCSI2SD for this machine. :lol:

Link to post
Share on other sites
  • 68kMLA Supporter
1 hour ago, Paulie said:

At least you're all safe. And to be fair, it was always a case of when, not if, the SCSI disk would fail, so the earthquake has just helped the process along a bit.

Yes and yes!

Edited by PotatoFi
Link to post
Share on other sites
  • 1 year later...
  • 68kMLA Supporter

After just over one year, I've decided that it's time to get this project finished up! The catalyst was the availability of these 512k VRAM SIMMs, which are new PCB's with new-old-stock chips. I purchased two 512k SIMMs for $29 each, intending to install them in the LC476.

 

IMG_2278.thumb.jpg.7f24bb32cf697a4b5210ee0a37ca9f98.jpg

 

I think they look totally awesome. I love the silkscreen on them!

 

IMG_2279.thumb.jpg.96402aa3b045bd5aab148db9bcfd0bb6.jpg

 

I dusted off the Performa 476, and got them installed. I now have two spare 256k 68-pin VRAM SIMMs - I hope to install one of them in my LCII to bump it to 768k of VRAM.

 

IMG_2281.thumb.jpg.31f4a447cab0ab084a9002f66d85f662.jpg

 

I also decided to install my SCSI2SD. I recently pulled this one from my Classic II, which lives on the shelf as a backdrop for webinars and meetings. The Classic II now has a BlueSCSI. The way I see it, the BlueSCSI is perfect for 68000-68030 machines, whereas this 68LC040 might have compatibility problems, and the BlueSCSI could be a performance bottleneck maybe? So I decided to use the SCSI2SD in this machine with one of my 3D-printed SCSI2SD brackets.

 

IMG_2280.thumb.jpg.505a867bfea21f54a1e23e59fa071df6.jpg

 

I have one more goodie to installed: a Farallon Ethermac LC! I picked this up for 20 or 30 dollars on eBay awhile back with this machine in mind. As far as I can tell, this card has never been used.


IMG_2282.thumb.jpg.569e3666ef26aba101d62f360ee702a2.jpg

Note the plastic wrap on the disk - it had never been opened!

 

IMG_2283.thumb.jpg.fc3ce6ab6477cb5303ad38dca302f6b1.jpg

 

With the VRAM SIMMs, SCSI2SD, and Etherent card installed, it was time to set the machine up and get everything installed. First, I plugged in my trusty RaSCSI. This little device makes it super simple to mount ISO images, mount hard disk images, and even download files (and automatically wrap them in a mountable .ISO). Killer for setting up a "new" vintage Mac!

 

IMG_2286.thumb.jpg.a6e5b2da3c49d7b9a94d845fa2862d77.jpg

 

Getting it to boot was a bit of a challenge. The SCSI2SD from the Classic II had System 7.1 on it, which won't boot on this machine (it requires 7.1P3 or newer).

 

IMG_2285.thumb.jpg.7b4b28367a9b63d36741cabad4263a3d.jpg

 

I keep a polycarbonate MacBook with Leopard around, because it supports HFS. Basically all this machine does is visit Macintosh Garden and write floppies for me. I found a 7.5 System Tools image (sorry, I didn't take note of where on Macintosh Garden), and wrote it to a floppy disk with dd.

 

IMG_2287.thumb.jpg.a2d0ec9c4c0e1b89db184d3cc4d66d28.jpg

 

With the System 7.5 System Tools floppy, I was able to boot the machine. Then, I mounted my System 7.5.3 CD-ROM .ISO with my RaSCSI. I would have just booted from this in the first place, but right now, the RaSCSI doesn't perfectly emulate an Apple CD-ROM drive, so I don't think it can boot up bootable ISO's (at least, not yet). I was able to run the installer from the floppy, just fine.

 

IMG_2298.thumb.jpg.c0aded2534eae456b3a1816454271d3c.jpg

 

Success! Yikes, 7.5.3 eats up a lot of RAM.

 

Next, it was time to install drivers. I actually have two of these disks, and I thought they were both still sealed. My plan was to open one, and leave the other sealed. Sadly, I forgot that the other one had been opened - after opening this one up, I realized my mistake. Bummer.
 

IMG_2300.thumb.jpg.49f878058aca7c3bff536a7d0900d6a1.jpg

 

After installing the Ethernet drivers, I grabbed my NCSA Telnet diskette..

 

IMG_2301.thumb.jpg.1abc7ca572271eed8a94a464cc6fcdce.jpg

 

After plugging in my DNS server and desired IP address in MacTCP (since it doesn't do DHCP), I fired up NCSA Telnet and used "telehack.com 23", and...

 

IMG_2305.thumb.jpg.b197aece4eb8caebaa86665e292b8f5d.jpg

 

Success! How about web browsing? After trying several versions of Netscape to find a .SIT file that I could successfully unarchive...

 

IMG_2309.thumb.jpg.2dd901b3e083bf51de8479df8b1d4a29.jpg

 

I also took the opportunity to try out Action Retro's Frogfind. I am absolutely blown away. It actually makes the internet usable on a machine of this vintage. I browsed around Wikipedia, and even checked out my own blog! Nice!

 

I finished up the evening by installing After Dark, and watching some toasters migrate back north for the summer. Next up, I think I'll try out a higher-resolution display to see what that 1mb of VRAM gets me, and maybe play some SimCity 2000!

 

 

 

Link to post
Share on other sites
  • 68kMLA Supporter
On 5/2/2021 at 7:54 AM, MrFahrenheit said:

Your memory usage is due to the machine being in 24 bit addressing mode. Open the Memory control panel and enable 32 bit addressing. 

 

After taking that photo, I turned on 32-bit addressing (not really knowing why). Is it simply because with 20 mb of RAM, 24-bit addressing leaves 4 mb of RAM on the table?

 

12 minutes ago, LaPorta said:

Very, very nice documentation. Your methodical prep and execution was great!

 

Thank you! I hope these threads encourage others to do their own restorations.

Link to post
Share on other sites
  • 68kMLA Supporter
10 minutes ago, PotatoFi said:

After taking that photo, I turned on 32-bit addressing (not really knowing why). Is it simply because with 20 mb of RAM, 24-bit addressing leaves 4 mb of RAM on the table?

 

24-bit addressing can only address 8MB RAM, the rest of the address space is reserved for other things.  If you have 32-bit addressing off but more memory than 24-bit addressing can address, it turns up in About This Macintosh as in use by the system, presumably to remind you you've got it but you can't use it.

 

If you're going to run this without a PRAM battery in, I wrote an extension called Force32 which always makes sure 32-bit addressing is turned on.  It's here:

 

 

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
×
×
  • Create New...