Jump to content

SE/30 Restoration Fun


Recommended Posts

Finally got my hands on a (some what) affordable SE/30, perfect recapping project for the Christmas break. 

 

The Ebay listing said it's been upgraded to have an ethernet card, 20mb of ram and a 252MB hdd.

 

Got some pretty bad screen flicker, the floppy won't read or eject, no chime and it looks like the HDD is dead... I got it to boot once, but not since. I did get a bomb on boot once saying there wasn't enough memory but mostly I'm just getting a flashing question mark.  

 

Anyhow I thought I'd document my journey getting it up to scratch. 

 

First things first, the externals:

imageproxy.php?img=&key=fcb9af74e9143c1b

2BE2612A-2ACA-4341-AEAE-9B78D1B3D7A5.thumb.JPG.226690e7e652a7ba6bab0ee8b99120e2.JPG

 

The company that did the ram upgrade... looks like they still exist: http://xyber.com.au/

 

IMG_4023.thumb.jpg.e863e477a9f6a77de2141b7ac3e0ce33.jpg

 

The back with the ethernet card:

 

IMG_1952.thumb.jpg.50ee6f8447c479eb780645427a8abb05.jpg

 

 

The horizontal flicker with burn in:

IMG_4767.jpg

 

Weird thing, it booted to my SCSI2SD fine, but when I shut it down and came back to it about 5 minutes later the same screen was there (wasn't at all responsive):

 

 IMG_4652.thumb.jpg.2962c09e893bbee8da5de30fcbed4118.jpg

 

The ethernet adapter:

 

IMG_1572.thumb.jpg.fdeba3109a3da58e61d667008750deec.jpg

 

The logic board, with no sign of leaks which is a good sign.

 

IMG_0226.thumb.jpg.dea3c3b6e0cae6860824252ed66f5611.jpg

 

Does anyone have any suggestions on what I should do first? 

Link to post
Share on other sites
  • Replies 53
  • Created
  • Last Reply

Top Posters In This Topic

The flicker is caused either by a failing UE8. I had a similar looking issue on one of my SE/30 boards and it was caused by a bad trace to one of the VRAM address muxes, so that's a possibility as well.

I would start with a recap and good cleaning and see where that brings you.

If the issues persist tehre are two options. You can either start by checking all traces around the video circuit (especially to/from UE8 and UA8-UD8) or removing UA8-UE8 to check if the ICs itself are functioning properly. (or just go straight for replacements)

I tend to check the ICs first but that's only because it takes less time to desolder them, check them in an IC tester and solder them back on than to buzz every single trace.

 

It looks like someone did at least clean this board to some extent before. It does not show any obvious cap leakage but you can clearly see corrosion and dull solder around UD8, UE8, UF8 and even UG8.

Edited by Bolle
Link to post
Share on other sites
  • 8 months later...

OK update 8 months later (I moved house, changed jobs, covid) - I've recapped the board and now it's sad chiming with horizontal stripes (same issue that @JDW had nearly 10 years ago - https://www.youtube.com/watch?v=mKJszJMRZM4).

 

From what I can tell the issue is most likely faulty bourns filters. Does anyone have any suggestions/input on how to fix this? 

 

 

Link to post
Share on other sites
On 9/5/2020 at 6:37 AM, chu-oh said:

...same issue that @JDW had nearly 10 years ago - https://www.youtube.com/watch?v=mKJszJMRZM4).

I shipped my SE/30 motherboard to @Bolle (in Germany) and in January this year he found it was the VROM.  He shipped the repaired board back to me and I can confirm his fix worked.

Here's what he told me...

 

Hm, the video ROM on your board definitely has flipped bits:

 

ALy5TSr.png

On the left is a valid dump, on the right the contents of the chip that came off your board.

It looks like whenever there is a difference it's subtracted 4 from the actual value.

Looks like there's a bad address input/internal addressing error or a whole cell inside the ROM went bad.

Going to replace the one on your board with a spare from my stock.

Link to post
Share on other sites
  • 3 weeks later...

 

6B04B6DD-310F-4A86-AE5D-144B8D3EFF59.jpeg

 

So I got the board recapped by a pro who tested it and said there were no issues. However once I got it back and plugged it in the flicking issues were still there (see video). 

I'm assuming this is an issue with the CRT or the flyback. Any one got any thoughts?

Edited by chu-oh
Link to post
Share on other sites

I hear a hard drive spinning in your videos.  Power off, disconnect that, then power on.  Does the display look exactly the same?

 

Next, there is a 4-wire cable that connects the CRT to the top left of the Analog Board.  With the power off, check the metal terminals inside that plastic connector to see if there is any crud or corrosion on them.

 

Next, with the power off, remove the Yoke board on the neck of the CRT and see if there is any crud on the pins on the CRT yoke or the mating terminals on the Yoke board connector.

Link to post
Share on other sites

Thanks again @JDW. I tried all of the above with no luck but then I removed and reattached the anode cap which did the trick after adjusting it a bit. Of course I discharged the CRT before doing any of this. 

 

From what I can tell the machine was used for bookkeeping in Mount Isa Queensland at least until 2000, so the machine would have been used in really hot conditions for years on end.

 

Unfortunately this has meant that the anode cap plastic has gotten so hot for so long that it's very dirty and sticky. Any suggestion on cleaning it? Or is it something I should just leave?

Link to post
Share on other sites

Don't clean it off, neither the suction cup or the red paint on the CRT.  Why not?  For the very same reason that red paint is on there in the first place.  A sticky cap will repeal the arcing more than a dry cap, with or without the red paint on the CRT.

Link to post
Share on other sites

Ok I'll leave it be, thanks. 

In other news I've pulled the floppy drive apart, given it a clean, replaced the broken gear and added some lithium grease and it's working fine. So that's another thing fixed.


Only thing I need now is a CRT now hopefully something will pop up on ebay soon. 

Link to post
Share on other sites
8 hours ago, mitchW said:

I would also go and replace capacitor C15 in some near future.

But use a different one, use a foil style cap 3.9uF 100V.

 

It is described on page 159-160 of the Larry Pina's book The Dead Mac Scrolls.

Use a film cap as mentioned in my older post here:

 

I demonstrate that 3.9uF film cap in great detail in my SE/30 Analog Board Recapping Video.

Link to post
Share on other sites

So another issue has popped up - no audio out of speaker except for faint crackling (head phone port works fine).

 

The person who did the recap confirmed the speaker was working when they tested so I'm thinking it's a psu/analog board issue. I've tested with my LCIII speaker which didn't work either so it's not an issue with the speaker.

 

Any thoughts on how I should troubleshoot this? 

Link to post
Share on other sites
8 hours ago, LaPorta said:

Do you have a separate speaker you can hit wire to the terminals and see if it works? It could be the speaker itself (though usually they are rock solid). You can also see if any solder joints at the speaker terminal are cracked or intermittent.


I've tried the LCIII speaker, but I might reflow the speaker header joints just to check.  

Link to post
Share on other sites
8 hours ago, chu-oh said:


I've tried the LCIII speaker, but I might reflow the speaker header joints just to check.  

You should.  Because if the headphone jack audio is fine, as you said, then I don't see how it could be an Analog Board problem.  After desoldering that 2-pin connector, make sure there is no corrosion on those 2 pins on the motherboard or in the mating connector coming from the speaker.  If all that doesn't work, it's more likely a trace on the motherboard is mostly eaten through, as opposed to a bad speaker.

Link to post
Share on other sites

Thanks again JDW. I removed the header and soldered a speaker to the board and I'm getting the same issue.

The person I got to do the recap has offered to have another look so I might just do that, just annoying to have to post interstate.

Link to post
Share on other sites

I was putting the scsi2sd mount that I 3d printed in today and when I turning it on I had no sound again. However I got it to work once by making sure the metal on the logic board near the ports was touching the chassis - but I wasn't able to replicate it again. 

So I'm thinking it's a grounding issue. 

Link to post
Share on other sites

ERGHHH I just broke the CRT:disapprove:

 

I was troubleshooting the audio settings - managed to figure out when the PSU was not screwed in the internal speaker would work. However I was trying to be lazy and squeeze it in without removing the analog board or the yoke. Unfortunately I knocked the yoke and gas escaped. Tried turning it on and lots of very scary looking sparks came out of the yoke. 

The CRT had awful burn in and I was looking for a replacement anyway but I'm still really annoyed at myself. 

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

×
×
  • Create New...