Jump to content

Recommended Posts

 Please bear with me for I have never used an online form before  and wasn’t sure if I’m in the right place to ask help , 

 

 Anyways picked up a MacIntosh Classic 1  for super cheap not knowing if it worked and I am completely in love with this thing only problem is I was having trouble booting it up got it to boot once or twice fix some capacitors  on the motherboard and I went to Boot it up the other day and left it on for a while  (  it usually took about five minutes before it would try to boot )  and nothing was happening I went to turn it on and off again and sparks went flying from the power board let it sit for a while to see if problem occurs again tried again and same thing happened at a complete loss now on what to do any help would be great thanks .

1D502179-C365-40AB-8050-5A9B84737B62.jpeg

615912F9-A691-4364-B613-37CD4E43BDAB.jpeg

Link to post
Share on other sites

Welcome to the forum! I don't really have an answer for you other than your best bet is to not post it in this section, as this is they "Lounge" and mainly just for blabbing about stuff and basically just shooting the breeze kinda thing. That being said, you will have a better chance to post it in the "Compact Mac" section of these forums here. There are a lot of very talented and knowledgable peeps here who are super friendly and willing to offer input to macs in distress. Try that and see where it goes from there. Good luck! 

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
×
×
  • Create New...