Jump to content

Building a Spotify player for my Mac SE/30

Recommended Posts

23 hours ago, nonzero said:

What programming environment and/or compiler did you use?

I use the Retro68 compiler on my Windows 10 machine. I use the Visual Studio IDE.

I also have Basilisk II installed on my PC to test builds.

Link to post
Share on other sites
On 4/26/2019 at 6:33 AM, olePigeon said:

Can I make a small recommendation?  Since it's used for "Spotify," you should use Clarus the Dogcow somewhere.  He has spots. :)  And he can fetch your music. :D

I'll keep that in mind for the next release! The current logo looks like this which is not nearly as interesting:



Link to post
Share on other sites
  • 4 weeks later...
  • 2 months later...

@ants I'm trying to get this set up, however I seem to be hitting a roadblock.  While trying to upgrade my GL-AR300m mini router to a current (18.x) version of OpenWRT (using image openwrt-18.06.4-ar71xx-generic-gl-ar300m-squashfs-sysupgrade.bin) from within the Luci interface, I get the message "The uploaded image file does not contain a supported format. Make sure that you choose the generic image format for your platform."  I have re-downloaded a few times, using both safari and firefox but always get the same error.  Also tried openwrt-18.06.0-ar71xx-generic-gl-ar300m-squashfs-sysupgrade.bin but still get the same message.  Any ideas?

Link to post
Share on other sites

@just.in.time That looks like the same package I used. Do you know if your GL-AR300M is the cheaper version with Nor Flash memory, or the better one with Nand memory? (models are here)


Mine is the cheaper GL-AR300M16-Ext which uses Nor memory. The reason I mention it is because in the OpenWRT packages there is another folder called nand, which I wonder is for devices with Nand memory?




You could perhaps try this file?


Link to post
Share on other sites

@ants Gave that image a try, but still the same error.


Basic Interface (non-advanced settings):

Listed at bottom of screen: Model ar300m NAND (so I think you are right on the nand version, I'll give a few more nand options a try)


Luci Interface:

Here are some details from the system:

Model: GL-AR300M

Firmware: LEDE Reboot 17.01.4 r3560-79f57e422d / LuCI lede-17.01 branch (git-17.290.79498-d3f0685)

System/Software/Configuration/Distribution Feeds: src/gz packages http://www.gl-inet.com/lede/2.27/ar71xx/nand (so again I think you are right about the nand memory)


Details from System Log:

Mon Apr  9 21:17:36 2018 kern.info kernel: [    0.000000] CPU0 revision is: 00019374 (MIPS 24Kc)
Mon Apr  9 21:17:36 2018 kern.info kernel: [    0.000000] SoC: Qualcomm Atheros QCA9533 ver 2 rev 0

Mon Apr  9 21:17:36 2018 kern.info kernel: [    0.117209] MIPS: machine is GL-AR300M

Mon Apr  9 21:17:36 2018 kern.info kernel: [    0.834536] nand: device found, Manufacturer ID: 0xc8, Chip ID: 0xb1
Mon Apr  9 21:17:36 2018 kern.info kernel: [    0.841168] nand: Giga Device GD5F1GQ4U 1G 3.3V 8-bit
Mon Apr  9 21:17:36 2018 kern.info kernel: [    0.846381] nand: 128 MiB, SLC, erase size: 128 KiB, page size: 2048, OOB size: 128

I'll keep digging around in that NAND directory at openwrt's site, maybe one of them will do the trick.  Thank you for the tip on memory type differences.

Link to post
Share on other sites

@just.in.time sorry, if I had of known the packages were different I would have made this clear on my GitHub readme :(


I also found this on the OpenWRT site: https://openwrt.org/unsupported/nand_flash

Note the table at the bottom:




It says must be forced into booting from NOR flash - but the link goes to an empty page! Perhaps there info elsewhere on the web that explains how to boot your device from the NOR flash. Then, I assume the standard system upgrade would work.


Sorry :-/

Link to post
Share on other sites

@ants I was actually just typing up an update when I saw your reply. I found that same OpenWRT page too (https://openwrt.org/unsupported/nand_flash).  No worries, now we know so we can document this so that anyone else that attempts this setup knows which version to purchase. :)


Did some quick research, and it looks like the GL-AR300M NAND memory portion isn't supported for the installation of OpenWRT.  The NAND version does supposedly also have some NOR memory on board, but getting the ar300m/-ext to check there for booting purposes is an exercise (after enough failed boot attempts from nand memory it might attempt booting from nor memory for one boot cycle).  And even then, it's unclear if the onboard software will allow the "nor" version of OpenWRT 18.06.x to be applied.


So based on all this, the "safe" list of GL-AR300M versions are:

GL-AR300M16 (internal antennas, 16m NOR memory only)

GL-AR300M16-Ext (external antennas, 16m NOR memory only) --The version you (@ants) are using


And the two that aren't supported at this point in time (at least, not without some sort of workaround):

GL-AR300M (internal antennas, 128m NAND memory and maybe 16m NOR memory as fallback)

GL-AR300M-Ext (external antennas, 128m NAND memory and maybe 16m NOR memory as fallback)


The product info above I found at https://www.gl-inet.com/products/gl-ar300m/


Link to post
Share on other sites
  • 2 months later...

Oooh this is neat! I'm going to have to look at this and see if I can't adapt it to work with something like the MITM-capable version of Squid I have on my home server instead of depending on that specific openWRT setup.

(Or port the OpenWRT setup to work on mikrotik routers.)

Link to post
Share on other sites
  • 1 year later...

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...