Jump to content

Apple II Europlus types underscore after each character


Recommended Posts

There are no stuck keys. Strange thing is: it doesn’t happen with the following keys:

3 7 W O S G K ; C /

 

When I am in ProDOS List Directory, all keys function well. See picture where I type RRR without underscores. 

 

When en going to AppleSoft Basic, it goes wrong. See second picture. 

 

What could it be? I do have a numeric keypad on my Apple II, and when I use it it does not give any underscores. Strange!

D6CB05EF-2A13-47E2-A5CE-D6C03B1FF423.jpeg

41A09999-B3ED-4B72-BBD8-FD3AB26EB3A0.jpeg

Link to post
Share on other sites
3 minutes ago, bushok said:

Strange thing is: it doesn’t happen with the following keys:

3 7 W O S G K ; C /

Check the connection between the keyboard and the keyboard controller, the red connector with the very long pins. 

 

Quote

There are no stuck keys.

How do you know that? I am also referring to a key switch that internally is closed, as if it is being pressed.

Link to post
Share on other sites

Thanks for helping!

I’ve removed the top and disassembled the keyboard. The long pins appear to Ben in the red socket. 

 

I’ve checked the alps too. They are alright, they always were. 

 

A friend of mine mails me and thinks the duplexer chip could be the problem. No idea what that means or where it is located though. 

967C1A4C-2807-48AA-AF33-FD1D659EB488.jpeg

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
×
×
  • Create New...