Jump to content

SCSI2SD Mac Plus Issues


Recommended Posts

I recently purchased a V5.0b SCSI2SD from Inertial Computing to be used in my Mac Plus.  I cannot get the board to be recognized by a Win8 desktop. 

 

  • I've tried different USB ports on my computer, and different USB cables... The utility is always "Searching for device".
  • Windows does not detect a new device. 
  • When plugged in at first, it blinks slow then quick and stops.
  • I've tried to update the firmware, but still the utility cannot find the device ... "Searching for bootloader"
  • the SCSI2SD is only being powered by the usb cable, either USB 2.0 or 3.0 have been tried.

 

The board seems to just not be able to communicate via USB and I have no idea why.

 

Thank you for any advice.

Link to post
Share on other sites

Ironically I just spent the better part of the afternoon getting this to work! I bought the same 5.0b unit.

 

I am not sure I can help much as it seemed like it just required a ton of trial and error until something worked.

 

Some findings:

-- I never did get it to work on my Macbook Pro, possibly because the USB-to-C converter offers interference like a usb hub does (the instructions do say to avoid using a usb hub). I switched to my Windows 10 laptop with proper USB ports and eventually got it to work.

-- I tried with and without a supplemental power cable in addition to the USB cable to provide extra power. (I used one of those cable that you can plug into a molex power connector when you're trying to connect a bare hard drive externally.) In the end I think what worked best was finding the precise USB cable and USB port that the thing liked best. At this point, I can use just the USB cable to power it successfully. I'm not sure whether the external power cable ever made that much of a difference, but you can try it.

-- The "blink once or twice and then go off" behavior is normal. It will only flash steadily when a connection has been established or the card is being accessed. I wasted too much time and energy worrying about the fact that I wasn't getting a steady power light.

-- Plug the USB cable into the board first, and make sure that the utility is actively flashing "searching for device" and/or "searching for bootloader" before you plug the USB cable into the computer.

 

Good luck! My advice is just to try everything. It is frustrating but it does seem to work in the end. (Maybe it's like the modern day version of the famous SCSI Voodoo?)

 

There is a thread elsewhere on the board - I was just reading it - which reports that even after successfully initializing a SCSI2HD that can be recognized by a Plus, it is very difficult to get the Plus to boot from it (something to do with the Plus having a very early version of the SCSI standard). If you don't need it to be a boot drive things will be easier.

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
×
×
  • Create New...