Jump to content

Quadra 950 NuBus issues.

Recommended Posts

Hey all,

I've got a Quadra 950 that I've had for a few years that has recently started to have some issues. 

Its got 256MB of RAM, a Radius PrecisionColor 24xk and an FWB SCSI JackHammer in it currently. However, the SCSI JackHammer has suddenly failed, in fact, two of them have failed or are at least seemingly not working properly.

Here's the story, I was getting some "bus error" bomb messages, and at other times the machine would just hard lock. I tried and tried but could never figure out the source of the issue. I ended up moving and forgot about the machines problems until I sat down to hook it all back up. Upon doing so, the bus errors were still there, but the machine was functional. Eventually, the machine refused to boot, and would not detect any SCSI drives on that card. I looked to see if Slot Info would see the card but it did not. I tried everything I could think of to get the machine back to a bootable state, but alas, no dice. I made a post on the Facebook group about this, and someone offered to sell me another card to replace my failed one. I received the card and it worked, until today when I went to boot the machine and the exact same issue has appeared. The card, no matter what I do, fails to be seen by Slot Info when the machine is booted from an 8.1 CD.

Currently, the card resides in the top slot of my 950, and is attached to a single HD. I believe the ID of the drive is set to 1, term power is enabled on the drive, and there is an active terminator on the end of the ribbon cable. In addition, all the resistor packs on the card are there, and there is an active terminator plugged into the external port on the card, which lights green when the machine has power.

I'm completely out of ideas here guys, how do two SCSI cards seemingly die in the same machine back to back?

Link to post
Share on other sites

Hmm, maybe it's not the card that failed, but the machine. Did you try putting the cards in different slots? Maybe the slots are dirty. Did you try cleaning them?

If the cards have SMD electrolytic caps in them, it's entirely possible that those failed too.

Also, if you have any other NuBus-based Macs, you could try testing both cards in there to see if the problems persist.


Link to post
Share on other sites

I'm going to point out the obvious - have you tried resetting the PRAM? Pull the battery and hold down "Cmd+Opt+P+R" at boot time before the screen comes up with a happy mac.

Were there ever any incidents where one of the cards popped out of the nubus slot while the system was on?

Link to post
Share on other sites

IIfx, multiple PRAM resets have not solved the issue, unfortunately. :( This machine also lives without a PRAM battery installed. 

There haven't been any incidents where a NuBus card has popped out of its slot that I'm aware of.

I searched for many years to even find a Q950, so I try to baby this machine and look after it as much as all of my other vintage machines.

Link to post
Share on other sites

Could it be that your specific Q950 dislikes the SCSI Jackhammer? Your not having any crashes with just the Radius video card, correct?

It's unlikely that 3 Jackhammers are bad. What SCSI hard drive are you using, and what drivers are loaded on that drive? I have seen the Macintosh system software behave oddly using 3rd party drivers on some machines.

Link to post
Share on other sites

I suppose that it could be possible that my specific Q950 dislikes the JackHammer, but is that really a thing? I mean, I would think that the JackHammer of all things would have been designed with a Quadra 950 in mind. 


You're right, no crashes with just the Radius video card and me booting off the Quadra's Internal SCSI bus, but obviously this is slower than the JackHammer, and all of my stuff is on the SCSI-2 drive connected to it. Its model number is Quantum Atlas 10K TN09L881 and it has the Apple drivers, not the FWB drivers on it, although it does have JackHammer and HammerTime System Extensions installed on it. Until I started having issues with the JackHammer, that SCSI-2 Drive was my boot device, with no other drives attached to the system. :( 

Link to post
Share on other sites

Do you have a copy of FWB Hard Disk Toolkit? I would try out the FWB drivers instead of the Apple ones in this case.

Does the Radius card work in the slot(s) where your Hammer doesn't? I'm asking because if I remember right the Q950 Nubus is split into two bus transceiver domains, with 3 slots within each domain.

Link to post
Share on other sites

I do actually have a copy of FWB HDT, I just tried it out, but it doesn't see the card or the drive attached to it either. The JackHammer extension has been placed on the drive that I'm booting from, and in the "Slots" Section I don't see the hammer listed. Ditto when I run Slot Info 1.0a2. The Radius card works in every slot, neither of my Hammers work in any slot. :( 


Link to post
Share on other sites

Some thoughts that may or may not be of use:


1. My first thought is that it sounds like a driver issue. Could the Jackhammer driver that you have installed possibly be corrupt? Lots of downloads get corrupted because of resource fork issues, etc. Try another source, preferably downloading directly onto a machine running classic MacOS, from a reputable user's site like https://www.fenestrated.net/mac/random/JackHammer/ , rather than from a generic Internet archive.

2. Since the JackHammer's basic role is to provide another scsi bus, what would happen in a machine with a Jackhammer card with drives that are not functional or not properly terminated: could the machine still boot on the logic board's scsi bus but not be able to "see" either the Jackhammer's scsi bus, or the additional drives? I don't know....

3. Is the machine unstable or stable as things stand? Instability under these circumstances could be indicative of a scsi voodoo issue.

4. Have you tried other utilities like SCSI Probe, TechTool, and similar to see whether anything is seen in the Nubus slot, with and without drives attached to the Jackhammer?

5. Were Jackhammers flashable for use in PPC Nubus Macs as opposed to 68k hardware? If so, it might need to be reflashed. The requisite software was typically included in Nubus card driver updates.


I have one here that I need to get running too, so I'll be interested to see if you make progress.

Link to post
Share on other sites

I was just about to mention the cable as well. Try swapping it out with a "known good" one to see if that's it. My Q950 had similar "bus error" problems that randomly went away as it sat overnight, and I'm 99.9% sure it was the SCSI cable in that scenario.


The other most probable cause (IMO) is the PSU. I'd test the voltage with a meter.

Link to post
Share on other sites
  • 2 weeks later...

Well, Sorry for the very delayed response here y'all. The forum crashed, and then life got in the way, and now apparently the system assigned my post to another user, and the account that I made this post with vanished into thin air. (LXLS) Amazingly, my account from five forum software updates ago is still active, so here we go.


The Last three posts, @Floofies, @Unknown_K, @beachycove, you guys I'm going to respond to all in this post. First off, good to see so many old school members still around!

Floofies, I have never had to actually measure the voltage of the PSU on a Q950, where would I find the pinout to do this, and how would I jumpstart the PSU without having it connected it to the board?


Unknown K, I tried it with the terminator off, no go, but I did find the solution to my problem, see below. (Also, please try my solution, perhaps you can get your card working in your Q950 again.)


Beachycove, you're the man. I vaguely remembered flashing my original card upon initial installation because the driver alerted me to the fact that it needed an update. I tried using SCSIProbe and TechTool as suggested, and still no go, but then I was frustrated and walked away from the machine for a couple of weeks. I sat back down and re-read this thread in its entirety and as a last ditch effort downloaded fresh drivers from the link you provided. (I believe my original set came from there as well.) I figured what-the-heck, and had a look through the readme file that came with the JackHammer. In the readme, it describes how to manually update the firmware for the card. as it turns out, the computer knew that both cards were installed, but didn't know what to do with them, you were spot on when you said it needed to be reflashed. Here's how to do it:


Open the JackHammer Control Panel, Select "Slots". Hold the Option Key, and press the version (3.2.3) listed at the bottom of the CP. A dialogue box will appear and tell you that no cards were found, what slot would you like to manually program? Select the slot and you should get a confirmation, reboot the machine and tada! The SCSI JackHammer (both of them!) now appear in SlotInfo.


The question is, why did this happen in the first place? I'm an old school mac user and have been using SCSI for almost my entire life at this point, but perhaps I'm losing my memory already! (I'm only 25!) So, lets recap how you're supposed to set scsi up in case i'm wrong. 


1: Connect SCSI Cable with active terminator on the end to the card.

2: Connect HDD to SCSI Cable, and set SCSI ID making sure that it is unique.

3: Enable TermPower on drive to supply power to the terminator at the end of the cable.

4: Cross Fingers and hope that the machine boots up.


Right? This has always worked for me before, so I don't know what the deal is. Does anyone have a PDF of the manual for the SCSI JackHammer? It'd be interesting to see how this card is actually supposed to be set-up.


Thank you so much for pointing me in the right direction. I sat and worked on this issue for HOURS before taking a breather from the machine. I guess I just needed some time to relax and look at it from another angle. 




Link to post
Share on other sites

Nice. Very odd they had to be flashed a second time...


For future reference, here is how you can check most Pre-2K era Mac PSU's:


Providing the PSU works like most of the Mac PSU's from the 90's and late 80's, you will want to find 2 wires: /PFW (Power Failure Warning, also the primary "power-on" circuit) and +5VSB (the "flea power" circuit, marked as "+5V 1.25A Continuous" on the PSU label). In a Q950 the /PFW line is white, and the +5VSB line is yellow. Shorting the +5VSB line to the /PFW line should cause the PSU to power on, letting you probe all the conductors for voltage.

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...