Jump to content

SE/30 Revival progress

Recommended Posts

Ugh... Well it looks like im going to have to make an extension cable off the analog board and grab out the ol trusty scope.


I recapped and fixed the broken Vias, and all i get is no chime and solid white screen. Its a scanned screen with proper sync pulses so that means the video circuitry is running. Makes no difference if I remove both the video ROM and main ROM, that white screen is still there.... But the HAL chips have to be there. otherwise nothing.


Soo.... its not simasimac at least. LOL. The Fun continues... probably a bad logic IC or a broken inter-layer connection from the corrosion.

Link to post
Share on other sites

Compiling the new video now. Here are pics though.


I am going to have to find the CORRECT HAL to be able to restore all 3 boards. The one that was in it was a 341-0688 which is incorrect. The correct pal that brought it alive was 341-0754


the 0688 goes into the UE7 spot, it was stuck in the UE6 spot. So between all 3 boards, I have a double-set UE7 and missing a UE6 now. Somehow a UE7 IC got stuck in where a UE6 of 0754 was supposed to be.



Link to post
Share on other sites

Getting the board 2 video processed. It is also alive and well :-)


Fixed the vias and respositioned one of the capacitors and insured the solder joints were good. Still no video.


Wasn't as easy of a fix though, it was quite elusive but eventually i found the issue. :-) the video explains what I had to do, when the G5 gets done compiling... 3 hours later. LOL




Link to post
Share on other sites

Here is the video on Board 2:



Board number 3, the light green board with white PDS, I recapped it without loosing a pad. But still no chime or anything and I cannot find any physical defects with the board unlike the other two. So i am going to have to break out the scope on that one to find out which chip is holding it up. Would be nice to have a logic analyzer, i would clip it right into the PDS slot and find out whats going on. But i cant afford that stuff ;-)

Link to post
Share on other sites

Revival Complete! Mission Accomplished.


Video for board 3 is compiling and will be posted in 3 hours. LOL (G5 is slow at iMovie)


Board #3 was giving me fits. No matter how much I "flexed" it, it would not chime, would not produce video, nothing.. So i proceeded to further troubleshooting by first checking the Address and Data lines for shorts. Everything was ok there, so then I started checking the logical supply grid. Both the ground plane, and the +5V which is required at minimum to get it to boot. dont need the -5v or +/-12v to boot an SE/30. those are only needed for peripherals and sound.


Ground had proper connection at all ICs. 5V had proper connection at all ICs. So I was ready to throw in the towel for the day and worry about it later when I felt like dragging out the scope. But i decided to check all the filter chokes. Well guess what, L13 was open circuit, preventing +5v from getting to the 32Mhz Oscillator. Sure enough when I went to remove it, it fell apart. So that explains the intermittent operation and eventual failure.


Also, I did discover on Board #2 that there is a solder blob stuck inside the floppy connector header. So i dunno how I am going to fix this besides snip it all out and replace it.


Jumped out L13, and sure enough, it fired right up. it is now operational and stable. :-). Those are done, NEXT..... 8-)


I hope this helps people out. I haven't really seen any replies, So I am not sure what people think of all this. But as long as it helps out the next person, its all worth it.




Link to post
Share on other sites

Good to see that the boards were restored! ...but it's sad to see they were so abused before you received them.


A comment on technique... I'm more convinced now that wiggling the cap is not the best way to take them off. The best method I've heard so far and tried (if you don't have SMT rework tools) is to cut the metal top off with side cutters and then cut the remaining plastic base at the bottom in half between the two pads with the same cutters. Almost zero force is exerted on the pads. Maybe my caps were more soft and brittle than others, so when I try another board, I'll document it for comparison.

Link to post
Share on other sites

Great job! Thanks for sharing this valuable resource.


Just a few notes:


•Have you tried using a common ATX-PSU cable extender for connecting a compact Mac to the mobo on the bench? It makes servicing them way more convenient! ;)

•It doesn't apply to your testing, but the SE/30 actually needs +12V in order to boot: the RESET signal generated at a capacitor (C16) goes thru... one of the Sony Sound chips (UB11) which in turn work on the +12 supply as you know. Without that signal, the CPU keeps in a locked state and won't boot at all, although the dumb video circuits will work fine on just +5 V generating the SimasiMac pattern. Gave me one heaven of fright... :O

•I got one of the cheapest Hot-air reflow station out there, and it's a wonderful tool for recapping -- and everything SMT, of course. Since I'm not a pro fixing 10 boards a day, one of these fits the bill nicely at a very reasonable price (≈$80). It does make a world of difference, believe me...


I recently recapped my Mac II, using two irons for removal -- a couple of lifted pads and a slightly melted NuBus slot, but everything's working fine now. Now I'm working on the IIx, this time I removed the caps with hot air -- easy, quick, clean, no problems! Highly recommended.

Link to post
Share on other sites

You cant... the Via is toast bro, I did this on purpose because of previous damage during a cap replacement. I had to fold it over and solder into the ground plane. And I know how to solder. I have been doing soldering even down to 0402 SMD for 15 years?

Link to post
Share on other sites

Thanks. Appreciate the complements. I will be honest though, I am not that good with video, and on video. But hey at least its to the point. i think. :lol:


I think the real challenge lies just up ahead. I got 2 more boards coming that appear to be perfect, but Simasimac.

Link to post
Share on other sites

All 3 boards took a fresh system 7.1 install from my floppy disks onto the jaz drive, at the same time I stumbled upon that my FDHD drive is failing/failed. Going to have to find a head demagnetizer as the one I used to have is long since gone. The drive seems to destroy the data/magnetics of the disk when it encounters an error. Reformatting and rewriting the disk on another machine will fix the disk until the drive eats it again. lol.


So i grabbed out my spare manual inject drive temporarily to alleviate the issue.


Link to post
Share on other sites
  • 6 months later...

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...