Jump to content

Recommended Posts

I have revived yet another SE30. The HDD, however (Quantum Prodrive 80S) is throwing errors. I thought that a Lido format would find and reallocate bad blocks, but it does not seem to be doing that. So I tried the "Overnight Test" in the Lido software, hoping to do just that. However, it seems to be giving up after 100 errors have been found.

 

Would anyone have a suggestion ? I could replace the HDD of course, but would prefer of course to keep the original, even if that means reducing the capacity a bit.

 

Thanks in advance.

Link to post
Share on other sites

No, I don't think I get new ones. Just the ones that had grown during the 25 years in storage. The HDD was dead, but Lido's Format revived it. However, a 7.0.1 OS install failed.

 

I tried to split the 80M drive into two partitions, and I could install the OS into one of them. However, I found more bad blocks in that partition as well.

 

Do you know of any format/test software that reallocates bad blocks, and that is not limited to 100 media errors ? 

Link to post
Share on other sites

Weirdly enough all my quantums work great, I've only had bad luck with the sonys. (2 outta 3 are shot) It's usually the other way round.

 

One of the Sonys is currently on hold, having the same symptoms as your prodrive... But I ran out of sectors so I guess this one is toast. The Mac OS is able to format it fine though.

Edited by BadGoldEagle
Link to post
Share on other sites

Thanks ILikeTech for the advice. Downloading Silverlining Pro now, and will try this week-end when I finally got time to tinker.

 

And yes Techknight, I spend 27 years in R&D at Seagate, IBM, and HGST, working on HDD reliability, so I can tell you everything you want to know (or don't) about HDD failure modes!!

 

By the way, I used to create all my system floppies on a PC using Transmac and Disk Copy, but now that I have a MacBook, I use the "sudo dd" command on the Mac Terminal, using a $9 USB floppy drive bought on eBay, and it's a breeze !

Link to post
Share on other sites
  • 2 weeks later...

I finally found a solution to my problem. I used a combination of Lido and Macinstor software (I have an old external 600MD HDD from them, with the software in it). I found that most of the bad blocks were clustered in a small range, in the middle of the drive. What I did then was to note the range of block address (in my case between blocks 58,200 and 58,300), and create 3 partitions. Two of them with the "good" areas, and a small one with the bad block zone. Somehow, Lido allows for a "scratch" partition which never mounts. So now, I have a boot partition of ~30MB, and an extra data partition of ~50MB. I installed system 7.0.1, and I'm now up and running !

Link to post
Share on other sites

Weirdly enough all my quantums work great, I've only had bad luck with the sonys. (2 outta 3 are shot) It's usually the other way round.

 

One of the Sonys is currently on hold, having the same symptoms as your prodrive... But I ran out of sectors so I guess this one is toast. The Mac OS is able to format it fine though.

Yeah, those Sonys are finicky. I spent almost the whole week-end going through my collection of old 3.5" SCSI HDD's. I have 19 of them, and 6 external ones. Interestingly, none of my two Sony's full height 40MB spun on power on, but both did after I gently tapped their side. Looks like they both suffered from a mild case of stiction. They both formatted OK.

 

Of the 19 bare drives, 6 of them did not make it (2 Miniscribe, 2 Conner, 1 Quantum, 1 IBM). I love the 20MB Miniscribe drive, with its noisy stepper motor actuator that you can actually see. I still have two working ones and they are beautiful.

 

Of my 6 external ones, two were dead. So all in all, not a bad ratio overall. The thrill of reading data from magnetic domains on a disk surface, that had been dormant for so many years is incredible. I must say I also feel a bit of a voyeur when I open documents that people had left on them.

 

My best find: a full height HP 540MB, as healthy as ever, which I installed in one of the dead external drive.

 

By the way BadGoldEagle, I know you live in France. Are you French (I am) ?

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
×
×
  • Create New...