Jump to content

Mac IIci Power Supply Quirks and Issues


Recommended Posts

I have several working IIci macs and have been trying to get one in nice shape complete with a recap to set up in my working vintage mac office. Power supplies seem quirky and sometimes mysterious, so I thought I might post some of my observations here and see if any collective wisdom or similar experience might help guide my next steps.

 

Back in December I did some testing to sort out which machine to have recapped. In testing, it seemed all 3 machines suffered from a strange symptom where the on-board power button had to be held down in order to sustain power. Strange. Anyone seen this before? The only thing I did after this testing was to use compressed air to clean them out some. 

 

I have 3 power supplies: 2 Delta and 1 Astec. Photos with testing notes attached. My newly recapped IIci is completely dead with both Delta power supplies. The other IIci motherboards work fine with these same PSUs, powering up with both the keyboard and the on-board power switch. One board lacks sound, which I'm guessing is a symptom of needing to be recapped. So the Delta PSUs seem fine, suggesting a problem with my newly recapped IIci. The Astec PSU works ok with one of the unmodified IIci boards, but with the other (which lacks sound) powered on once and then off once, never to be powered up again with the Astec PSU. Retesting this board with a Delta PSU and it again powers up fine. 

 

Oddly, the Astec PSU DOES power up my recapped IIci intermittently, and only with the keyboard. I have to press hard, sometimes twice but if I play around enough it powers up and then behaves fine. 

 

Strange stuff. What I conclude from all this is I have a problem with the newly recapped board, and I probably should recap the IIci which still boots cleanly with sound. 

 

Any insights on any of this appreciated. I have another strange PSU issue with a Quadra 950 which I'll post in a separate thread.

 

Thanks all for taking the time to read this!

 

Craig

 

post-9149-0-60721400-1491319574_thumb.jpgpost-9149-0-23568000-1491319600_thumb.jpg

Link to post
Share on other sites

Good questions. I had this done by Charles of MacCaps.com and in email exchanges he assured me the board was fully tested and working prior to sending it back. In my next reply I can ask him more details.

 

He suggested I clean the board further, as follows:

 

"The power on circuit is located on the main board of the IICI and is sometimes an issue. It can be bypassed if needed. I do remember that area was really nasty, had some corrosion and required lots of extra cleaning, but again it did power up when i tried it."

"You can also try getting some 91% isopropyl and a tooth brush and clean these transistors and I/C's again. If you still have power on issues there could be some residual cap go as the area was nasty."
 
I have not tried this yet. Thanks for the reply.
 
~C
Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
×
×
  • Create New...