Jump to content

Macintosh SE/30 floppy drive


Recommended Posts

Hi.

 

Around one month ago SE/30 worked perfectly.

 

Two weeks ago I purchased some floppies with old software at ebay. I tried to copy/install software from they but all of them contains disk errors.

 

Afters this I tried to copy files from my MacBook Pro to SE/30 via USB FDD. MacBook formatted and recorded floppies without any problem (FAT12), but when I tried to read them on SE/30 I got a disk errors.

 

Today I repeated this and SE/30 shows that floppy disk has 500 kb free - that is right, because I writed almost 1 mb on it. But there is no files on the disk!

 

Should I replace FDD in SE/30?

Link to post
Share on other sites

does your SE/30 have original capacitors or have they been replaced?  is there a way to clean the reading head with alcohol?   

 

I opened Mac today and saw a leaked electrolytic glue around the capacitors. So I will try to clean motherboard by first.

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
×
×
  • Create New...