Jump to content

Macintosh 128k issues


Recommended Posts

Hello everybody, I'm back again with another conquest of mine!
This time luck has brought me nothing less than a Macintosh 128k, which I obtained from a guy in Italy.

Now, the story of this poor guy is an unhappy one, unfortunately. The guy who sold me this one said it was in working order and that he had found it in the garage of a friend, but of course that wasn't true - in fact, I discovered that he has bought this machine more or less a month ago from an american guy on eBay with defects. So now I have an open dispute with him to try and get back some of the money, but meanwhile I'm trying to get this poor thing back into working order.

 

First defect: I think the AB is probably toasted. As soon as I plugged it to the power line (using a 220V to 110v converter, since it's a 110V one), it started making very unpleasant sparks and fireworks... I'm assuming the previous owner tried to connect it to the 220V straight, unfortunately. I'll have to do some more investigation about this, though. I'm not excessively worried about this, as I think I'd be able to source a working AB if everything else fails.

 

What worries me more is the second defect, which appears to involve the logic board.

I put the logic board into one of my Macintosh Pluses for testing purposes, and instead of nicely booting with the chime it only makes a couple of "ticks" from the speaker and shows a vertical line pattern on the display which resembles the infamous simasimac of the SE/30. Also, sometimes it doesn't show anything on the screen at all, and when it shows lines they eventually disappear from the screen after a few seconds. If the floppy drive is attached, it also tries to make access to it. t'm attaching some pictures.

So I looked at the logic board, and something interesting is going on here.

First of all, it has been upgraded to use Macintosh Plus ROMs: the high rom is a 342-0341-B chip and the low rom is a 342-0342-A chip. Apparently, this is because they replaced the original 400k floppy driver with a newer, 800k one. Both chips have been tried on a different logic board and work fine. Also, I've tried to replace them with another set of known-to-be-working Plus ROMs, but the defect is still the same.

Secondly, at some point someone must have tried to perform a RAM upgrade, as there are strange connections around a couple of chips. At this moment, the chips are all MT 4264, which should be appropriate for this having 128KB of memory, although they don't seem to be the original ones as they don't have the Apple logo on them. It seems the issue is very similar to this one, which however also involved damaged rom chips.

 

Next week I'll probably bring this little boy to ferrix and see what we can do, but I'd like to ask you what should we try first.  

In particular, do you know what exactly that modification could be doing and how we could revert it to stock? Is it possible that one (or more) memory chips have died? 

post-2199-0-26481100-1450465214_thumb.jpg

post-2199-0-04906100-1450465381_thumb.jpg

post-2199-0-76978900-1450465438_thumb.jpg

post-2199-0-08501700-1450466406_thumb.jpg

post-2199-0-10068800-1450467272_thumb.jpg

post-2199-0-98222200-1450468467_thumb.jpg

post-2199-0-16490600-1450468867_thumb.jpg

post-2199-0-44960200-1450469364_thumb.jpg

post-2199-0-37806100-1450469491_thumb.jpg

Link to post
Share on other sites
  • Replies 59
  • Created
  • Last Reply

Top Posters In This Topic

This looks to me like it was, as Macdrone notes, a nicely upgraded-to-512ke specs-but-dirty-and-neglected unit that some L@@K STOVE JORBS!!!! eBay nitwit tried castrating back down to a stock 128k (despite completely not knowing what he was doing) in order to increase the perceived collectors value. To my knowledge RAM is *never* socketed on a stock 128k and all that piecework with the jumper wires is undoubtedly the hack to enable the system to work with 256k chips. It ain't going to work right as a 128k unless you remove that mod; before doing that I'd suggest at least trying to pull out the 4264s and replacing them with 41256's just to see if the board will run correctly as a 512k(e).

And, frankly, per the above, if it works as a modded-up 512ke I'd suggest leaving it like that. It's far too butchered to pass off as a pristine "collectors item" and it's a far more *usable* machine in the expanded configuration.

Link to post
Share on other sites

Yep, the original seller (the american one) said that a certain point this board was upgraded to support 1MB of RAM, which basically converted this thing into a Macintosh Plus minus the missing SCSI port. Since then, the chips have been reverted to the stock ones, with the exception of not being Apple branded; however I guess they "forgot" to remove at least part of the modification... 

I'm wondering if it would be just fine to remove all those cables? I honestly have no idea of what crazy magic they're doing to enable the machine recognize more RAM, but I recall that at least a few "ram upgrade" mods I've seen around resorted to an additional chip taking over some of the duties of the address decoder or mux to enable addressing larger amounts of memory.
EDIT: I actually noticed there is an extra chip stacked on top of the original one, in some sort of strange configuration, which practically answers my previous question about how this thing actually performs the addressing...
Actually, a couple of extra strange things: it looks like the yellow capacitor which should have been placed in RP3 has actually been replaced by a number of resistors; also, apparently there was something sledged to one of the central pins of the CPU, probably as part of this piggyback mod. However there are a number of things missing, and some cables have already been cut by the previous owner, so I'm not sure about the feasibility of restoring the full functionality of the memory hack.

Edited by Sherry Haibara
Link to post
Share on other sites

So... basically this thing has been butchered to heck and back; in addition to all the jumpers there are almost certainly some additional trace/pin cuts that might be devilishly hard to spot; to reliably convert this thing back it'd be a huge help to have the instructions for the mod as originally applied, and even if you *do* manage to convert it back you're going to have to live with having some ugly soldered jumper wires bypassing the aforementioned trace cuts.

Personally, if what I wanted was a 128k I'd go to the mat demanding a complete refund of the item as being nothing like as described. I'm sure it's *possible* to get it running again but right now it's a worthless wreck missing most of the important parts to be a "genuine" 128k; in addition to the hacked mainboard and blown-up analog you've got the wrong ROMs and floppy drive. Was it the American seller who ripped out the memory upgrade or the Italian guy who flipped it on you? The latter is obviously a sleazy liar, I'm just wondering where the blame for the stupidity lies.

The tragic thing here is personally I think the machine as-modified would have been far more interesting to have.

Edited by Gorgonops
Link to post
Share on other sites

Gorgonops, I'm equally disappointed as well. If at least the memory upgrade had been still in place, it would have been an interesting modification to have. Sadly, it could be hard to restore it; it seems most of it is still in place, but a couple of wires have already been cut here and there, so it would be a matter of reverse engineering it, which is not something I'm expert on. Sure, if somebody here is able to understand what is missing and what should be connected to what, then it could be feasible after all. I wonder if it would still work with the full modification in place and only 128k of RAM or if it would require a chip swap?

I'm mostly worried about the cut traces, if there is any: I can live with one or two extra wires to make the thing work, but I don't doubt it could be a daunting job to find out everything that went wrong. I'm not that picky when it comes to RAM chips mounted on sockets, after all; they remove part of the originality, true, but I'm not extremely offended by this.
I've got a friend who should have an extra pair of right ROM chips, so that modification could be easily reverted; the floppy, though, would likely remain a 800k one, unless I'm able to find a 400k drive in working order. I'm wondering if a 800k would work with the original ROM set and just be "castrated" to read 400k floppy, or if would just stop working.

For the matter, the italian guy is just a liar, it was the original american seller that made this heck of a crime by cutting things here and there.

 

Personally, I'd still be more inclined to keep it, as I have this "romantic" side of me that tries to save whatever comes across my way... I'm not sure what could happen to this puppy if I gave it back to the seller, but most certainly it would end up having a sad (and probably short) life, which I find to be a pity, since this particular Mac was built on the 4th week of January, 1984 (judging by the serial number) and so it's still a quite nice thing to have.

Part of my inclination to keep it also derives from the relatively cheap price I paid for it (150 bucks shipping included, but the seller has agreed to refund me 50 euros and I'm allowed to keep it) and from the fact that the 128k in Italy is practically unobtainable, since it was never sold here. Sure thing, a pristine 128k from the US would still be a nice addition to my collection one day, but I may consider it down the road when I'll have more money to spend and live with this for the time being. 

Edited by Sherry Haibara
Link to post
Share on other sites

I wonder if it would still work with the full modification in place and only 128k of RAM or if it would require a chip swap?

 

I've got a friend who should have an extra pair of right ROM chips, so that modification could be easily reverted; the floppy, though, would likely remain a 800k one, unless I'm able to find a 400k drive in working order. I'm wondering if a 800k would work with the original ROM set and just be "castrated" to read 400k floppy, or if would just stop working.

Do you mean leaving all that wiring in place but just have it magically work with the 64k chips in there? No. There's no identifier in these DIP RAM chips to tell the computer what they are, it's hardwired. The modification to expand a 128k to a 512k cuts free a normally grounded ("nc") line on the motherboard and uses it as an additional multiplexed address line. (IE, the 64k chips have A0-A7 which are time-multiplexed to translate a 16 bit address into two 8-bit row/column values; the 256 chips use the not-used-on-a-4164 pin1 as A8 to make the range of possible values 18 bits, IE, 256k. RAM is 16 bit wide, IE, two banks, which is why that translates to 128 and 512k RAM sizes respectively.) To make it work with the smaller chips you *have* to rip out the extra circuitry which does the address multiplexing and expands the memory map.

 

(And to make it even *more* intimidating, that memory mod, which undoubtedly involved piggy-backing a second set of 256k RAMs onto the first set, almost certainly means one of the piggybacked chips that's left behind was tasked in part with controlling which set of chips got the chip-select signal... which also implies a cut trace somewhere.)

 

Again, I'm sure it's totally un-doable, but the board's going to be a cut-up mess. Uniserver can probably help you identify exactly what rev board you have and provide you some pictures/schematics of what it's *supposed* to look like, but... I don't know, I think if I had that sitting on my workbench I'd probably start googling like mad to see if I could find the DIY article about upgrading a 128k/512k to a meg of RAM (it's gotta be out there somewhere) and try to put it back the way it was.

 

Per the disk drive, it depends on the mechanism. The first couple revs of the 800k mechanism are incompatible with the 64k ROM unless the HD-20 init is loaded from a compatible drive, which makes them completely incompatible with a 128k. (HD-20 init won't load on a 128k.) Later 800ks will work as a 400k drive, if you google around you can find the magic number to look for.

Edited by Gorgonops
Link to post
Share on other sites

WOW - You got the Purple/Blueish 68K on the marble/ceramic package... That is OLD!One of the first units out! I have not seen that in a very long time! Most chips are usually black epoxy/plastic... And chip date codes in mid '83! That says something!

 

Hope you get this baby to work!

Edited by Elfen
Link to post
Share on other sites
  • 7 months later...

Hi all,

Ferrix and I finally started the long troubleshooting process to bring this poor guy back in shape again.

So far we are focusing on the logic board, which is probably the most problematic.

As a first step, we have confirmed that the installed ram is effectively summing up to 128kb and also seems to be of the correct type (though I don't remember the chip number at the moment).

We have undone the modification that allowed ram expansion, using a working 128kb logic board as a reference to avoid cutting factory mods.

We have tested the board with a known to be working AB, and the symptom we are getting now is that the board simply resets twice as soon as we give it power.

We can hear a couple of ticks coming from the speaker, about one second apart. Nothing shows on the screen, which remains black. Floppy was not attached.

If you could give us some advice on what should we look for (eg suspicious cut traces, which however we didn't see at a first glance, or likely damaged chips which could produce this behavior), we'd greatly appreciate your help!

Link to post
Share on other sites

WOW - You got the Purple/Blueish 68K on the marble/ceramic package... That is OLD!One of the first units out! I have not seen that in a very long time! Most chips are usually black epoxy/plastic... And chip date codes in mid '83! That says something!

 

Hope you get this baby to work!

 

Nope. Heck, I have a pile of 512k hybrid boards with ceramics.

Link to post
Share on other sites

Well, downgrading it is easier than expected. 

Here's what I've done:

  • Remove all of the non-original modifications (jumper wires and piggybacked chips)
  • Install the missing resistors on RP3
  • Install a resistor on R4

There are no cut traces to repair

 

At this point, the machine would produce a very distorted chime and display a Sad Mac error code, 021000. That indicates a problem on ram G9.

 

post-2328-0-20623100-1470226227_thumb.jpg

 

Sure enough, I pulled the IC out and noticed that one of the pins was bent inwards.

 

post-2328-0-81438900-1470226263_thumb.jpg

 

Fixed that and now...

 

post-2328-0-53849900-1470226319_thumb.jpg

 

It's Alive!

 

Now I have to fix the fried analog board.

Link to post
Share on other sites

On the analog side, Most of the primary was blown (shorted transistors and open/drifted resistors) also found a shorted capacitor!

I have replaced all of the parts except the SCR, which should arrive next week.

 

I also noticed that the "international" boards are far more rugged that the US ones. Maybe this is why US boards fail more often.

Link to post
Share on other sites

SCR has now been replaced! 

We've got some progress, but we're still in need of some help. 
At the moment, we are able to get a "stable" raster (albeit it's somewhat shaking in the corners) by supplying exactly 63V to the board through a variac. Any more or less and the system enters an endless flubbing loop. This seems to suggest that something is going wrong in the power regulation circuit.
To be fair, caps haven't been replaced yet, but we're not sure whether they may have something to do with this or not. Flyback has been removed for testing, and the board exhibits the same behavior even without the flyback. There is an extremely subtle hiss coming from it when an isolated metal object is put nearby, but apart from that the raster seems to be of very good quality. 

Adjusting R56 changes the behavior a bit, but not to the point of solving the issue.  

It essence it's the same problem that this nice fellow had, but it's unknown whether he has been able to fix it or not. 

I'm attaching a couple of pictures of the AB as seen by a thermal imager and a picture of the raster. 

 

post-2199-0-76698000-1471016722_thumb.jpg

post-2199-0-83790700-1471016750_thumb.jpg

post-2199-0-75432100-1471016763_thumb.jpg

Link to post
Share on other sites

Judging by the wavy picture, I would say your main input filter is wasted. Or at least some of the output capacitor filters. 

 

Flubbing/pulsing is caused by not going into proper regulation. Need to check the opto-isolator or whatever other parts might be in the feedback loop, As well as checking the over-current sense circuit. Both will cause this. 

 

The way to determine which is to scope the output to the sweep circuits. If you see a nice ramp with severe overshoot before the "shutdown pulse" then its going out of regulation. If you see a swoopy line before shutdown, you have an overcurrent problem. 

Edited by techknight
Link to post
Share on other sites

The Flir One thermal camera is one of the most useful tools I've bough. It is great for troubleshooting Apple logic boards (the new ones).

If you have a shorted power rail on a MacBook you stick some voltage on it and with the thermal camera you immediately see where the damaged component is located. It is not uncommon to find a shorted ceramic or tantalum capacitor. I was also able to fix a shorted HD6970M MXM card from a 2011 iMac by locating a bad Mosfet IC.

If you deal with broken computers all the time, it is a really useful tool and will pay itself with all the time you'll save.

Also, it lets you see in the dark!

 

As for the Macintosh:

I started isolating the various rails by desoldering the inductors, the problem still persist.

I also tested the feedback circuit and the protection SCR and both seem to work (the SCR triggers at about 13.10V).

I think there is still something wrong on the primary (where they connected a 110V mac to a 220V line), maybe a failed ceramic or polyester capacitor that makes the circuit less stable therefore creating voltage spikes on the secondary.

Link to post
Share on other sites

I do have a first generarition Flir ONE (I took the photos at the Analog Board), the resolution is not that high (something like 80x60), but it uses a regular (VGA resolution) camera to increase the quality by blending the two images, this is the main difference between the Flir and the Seek camera

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

×
×
  • Create New...