Jump to content

erichelgeson

6502
  • Content Count

    311
  • Joined

  • Last visited

Everything posted by erichelgeson

  1. Quick update - 25 bluepills arrived and are genuine - so I do have a supplier now, though they're a bit more expensive then I'd like, but that seems to be with everything from China right now. I'll have 60 blanks and 30 bluepills ready to ship kits or fully assembled next week (fingers crossed) & already have 15 spoken for. I have a 3D holder designed too that should fits nicely into compact macs or an external case. We'll see how fast the supply goes and I'll guesstimate another run. Will update again once the boards arrive.
  2. Nice! With a BlueSCSI (arduiscsino) you could probably fit everything right on top (or maybe even on the same board, haha!). I'm interested in trying one out for my 512k.
  3. Well progress! I used CiderPress to make a new drive 1 kb smaller. Opened the image from apple-2.com, select all, copy, open the new drive I created and "special" pasted them in preserving prefix. After that I booted off the FloppyEMU again, opened Copy II - did a sector copy to the ProDOS partition on the Mac. Relabeled the drive to FE (to match the other image) - rebooted and walla - it works! @Realitystorm I did read through your guides and were helpful, but I was never able to create an exactly 32mb partition or have your images mount. As mentioned above any single
  4. Was able to play some Oregon Trail and Pac Mac with the wife last night so it was a good time, but still booting from the floppyemu. I did update to the latest image from apple-2.com - but I am unable to do a disk copy from within the apple ii as the sizes of the drives (floppyemu's and one on the mac) do mot match. When formatting ProDOS with Apple HD Setup Max(32Mb) is actually 1kb less than 32Mb! The size does not match and it fails to copy as it's not exactly the same. I did attempt to copy files again but still no boot. I'm not sure if there's an order or blessing
  5. Progress! - BMOW has a working po file on their site - so downloaded that and it booted right up! https://www.bigmessowires.com/2018/12/04/prodos-software-collection-for-floppy-emu/ edit: there's a more up to date image from the author here - will try it later http://www.apple-2.com/ I created an exactly 32mb drive on my RaSCSI - but OS7 doesnt seem to mount the drive if the only partition is a prodos partition (so couldnt set it in the iie card app) - so I created a 40mb file - formatted it exactly 32mb and the rest is a Mac partition. I copied over everything fr
  6. Getting further - got that image on the FloppyEMU in Smartport mode - shows it. But the IIe card starts - says: "Apple ProDos 8 v2.4.1" then "Previous Clock Installed". then "FBC4 - A=06 X=57 Y=00 P=71 S=F9" Not sure what it's trying to tell me. On the bright side FloppyEMU with regular disks seems to work fine.
  7. Interesting, I'll see if I can write that image to the prodos partition. Side note - the latest flopplyemu firmware has a new file called `emumode.txt` that if I understand it correctly can change modes on the fly without re-flashing - is that correct @bigmessowires
  8. It's mentioned in the manual https://apple2online.com/web_documents/apple_iie_card_owner__s_guide.pdf Just create a ProDOS formatted drive and it shows in the "SmartPort" section of the configuration screen. I have one setup but no idea how to use it
  9. I do have the software and can get into the card - all that works fine. The resolution oddly fixed itself after a reboot - not sure why it was cut off before. ADTPro seems nice but I'm having trouble getting any modern machine to actually use it - Sound wont work as the Input/Output doesnt seem to be passed into the iie card. I have both kingston usb->serial and usb->9pin - but they are not seen by my modern macs or windows machines. May have to buy a modern usb->9pin solution. I was able get MacADT to send the adt.dmp (version 1.3.3) to the apple i
  10. Hi all, I recently salvaged a IIe Card from a LC and have been trying to document and understand how to get software to it and manage/run programs. To be honest this is my first time using an Apple II since elementary school where all the commands were written on a chalkboard, so I'm a bit rusty. I have a bunch of random questions: The IIe card is in a Color Classic - but it seems the screen is cut off on the right. Is the resolution required for the card 640x480? I was able to take a `.po` file and write it to a 3.5" 800k disk (using the inter
  11. A few quick updates: I have the 1.0-b rev tested and is the final rev. I'm sourcing BluePills now from but everyone seems to be low on stock or jacking up shipping right now. Have a few on order but have had orders cancelled. Supply chain woe's. On the software side I've rebased the software component on ztto's which added support for different block sizes as well as updated to SdFat 2.x. I've also added a log file and debugging info in case of issues. I've added instructions and details to my Github repo wiki. I've sent a few boards and have had
  12. Hello all, I know almost all (read: none) of you have been wondering how you can run Mac OS 9 on your docker hosts. Maybe, like me, you keep hitting road blocks with netatalk2 and want to run your AFP File server on your modern server. Or your developing a new OS9 PPC game and want to add a build pipeline. Regardless the reason, now you can - thanks in most part to QEMU 5.2.0 release supporting PowerPC and OS9 https://wiki.qemu.org/Documentation/Platforms/PowerPC. This is a simple Docker image to compile and run with a few ease of use options. Be
  13. I have a 7.1 install with System Enabler 065 v1.1 - but am not getting a "bong" or anything on the screen. What I've done so far. Cleaned and recapped the board. Made a battery pack out of 3 AAA batteries Soft power is working - I hear things spin up, but nothing on the screen. Reflowed caps just to be sure and tested continuity on the ones i could - fine. Rescrubbed the board. Checked voltage on the scsi port while the machine was "on" - a bit under but only by 0.25v - analog board caps are on their way but not sure if that would prevent a boot. Disco
  14. Palm Pilots do! Have one sitting behind me - https://macintoshgarden.org/apps/palm-desktop
  15. Phase 2 - Mystic time! I got a 575 motherboard on a trade recently so I've started prepping. My todos are: Recap the 575 board 3d Print & Paint bracket Recap Analog board 640x480 mod I've already started with the Recap and Brackets. Got the 3d model for the bracket from powercc (which I think came from the 3d print thread here) - ~7 hour print and looks good. Need to figure out some paint matching or maybe I'll just paint it apple rainbow colors: The motherboard was quite corroded, some of the caps came off just with
  16. There was a good video just posted with all the details too
  17. Thanks for this - being an amateur myself and learning I'm always happy to see people share work even if it's not perfect. Do you have a photo of it all assembled? I have 2 bad LC PSU's - I might give this a go.
  18. True, I only spent that money for that one pin, though have gotten a few other uses out of it since. Somehow missed the link in the text, thanks!
  19. Great content as always - I had the same issue with the through hole cap on my SE/30 - the way I got it was to use a hot air station and heat up the surrounding area to remove it. What was the 3d bouncing ball on the screen at the end?
  20. I have LED, Berg power, and a few other minor updates done. Though have two questions before I put in the last prototype order: The floppy berg connector - I've seen conflicting #'s on the pitch - 2.5 and 2.54 - someone on discord measured his and it was 2.54 so I'm going with that. I'm having trouble finding the right diodes on Mouser - the ones I've found for through hole are all huge(physically) and rated very high (hence the size) - If someone could help find an appropriate diode I'd appreciate it! It seems when searching for components you can get the wrong filter
  21. Yes it's stand alone, after a few more people test it I'll open a PR for it. For now just give it a spin and see what breaks or could be improved. Open an issue and if you can, fix it
  22. It was - thanks! From my reading/learning that's how I thought it might work but glad to have someone with experience to chat with. If you are a Discord user you should jump on RaSCSI's discords (we talk about all things scsi, scuznet and ardscsino included)
  23. Great! Ya I was testing yesterday with a zip(term enabled) -> apple cdrom -> rascsi (term enabled) and the chain wasn't working. Though in all likelihood your device will usually be the last. Could you explain this a bit more how this works? I'd like to add something similar to arscsino - but pretty new to hardware design. Thanks for the detailed blog post too!
  24. I've added some pre-build system images and utilities image to help bootstrap your RaSCSI experience. They should cover all SCSI Macs, let me know if there's a OS or utility you'd like prebuilt. https://macintoshgarden.org/apps/rascsi-68kmla-edition Also I've been working on a new version of the web interface and adding features such as download to iso (eg, give it a Macintosh garden link, it will download the file, create an HFS iso and mount it, easy way to get utilities on your Mac) and a bunch more stuff. https://github.com/erichelgeson/RaSCSI-web
×
×
  • Create New...