Jump to content
stormy

MacTCP over PCMCIA ethernet slow startup

Recommended Posts

Hi there,

 

I am not too experienced with the inner workings of Macos 8.1, I am trying to get my internet to come up faster. 

 

System specs:

PB190cs w/ 40mb RAM

CF card HDD

MacOS 8.1

3com 589d ethernet using drivers from this page:

https://www.floodgap.com/retrotech/mac/enet3c589/

 

problem description:

Upon turning the computer on the light on the ethernet card connector is green/on, but the router port light is off. So no connection. If I load an internet tcpip app like Ircle, it will start 'connecting', the ethernet card light will turn off, I leave it for a minute or two and eventually both the internet card and the router port light will turn green, it will get its dhcp ip and eventually connect to IRC.

 

Thoughts:

I am not sure if this is the way the OS is supposed to work. I have the latest MacTCP and Opentransport 1.3. For instance my NTP control panel to set the date has the option to update on system start up and 'wait for mactcp' but I think this takes so long it gives up and never sets my date unless I do it manually. Once the internet is on and going there aren't any problems.

 

Also is AppleTalk supposed to be turned on all the time? I'm not sure, but at the moment it is on.

 

Thanks for any advice on this!

 

 

Edited by stormy

Share this post


Link to post
Share on other sites
8 hours ago, stormy said:

I am not sure if this is the way the OS is supposed to work

MacTCP won't start up until an application tries to use it for the first time; depending on the NIC, if TCP is the only thing bound to the card, this might mean that the link doesn't come up until it's opened.   That said, a minute seems overly slow.

 

Do you have the option of running Open Transport on that machine?  It may well be faster.

Edited by cheesestraws

Share this post


Link to post
Share on other sites

@cheesestraws Hi and thanks for the help. I do have Open Transport 1.3 installed. Should I disable MacTCP? Does that involve just disabling its extension? I am a proper MacOS noob thanks for the help :)

Share this post


Link to post
Share on other sites
8 hours ago, stormy said:

 Hi and thanks for the help. I do have Open Transport 1.3 installed. Should I disable MacTCP? Does that involve just disabling its extension? I am a proper MacOS noob thanks for the help :)

IIRC, there should be a "Network software selector" application in the Apple Extras folder which will automagically swap you back and forth between OT and the classic stack.

Share this post


Link to post
Share on other sites

@cheesestraws I had a look but found nothing, I then did a search online and found this:

https://apple.fandom.com/wiki/Network_Software_Selector

Quote

The Network Software Selector is a utility, found only on Power Macintosh 6100, 7100 and 8100 computers under Mac OS 8.5, Mac OS 8.5.1 and Mac OS 8.6, if Open Transport was installed.

So I guess I'm not supposed to have it, but I don't seem to have any MacTCP control panel etc so maybe I'm not using it. I do have a TCPIP control panel which is Open Transport afaik.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×