Jump to content
GregorHouse

Macintosh Portable - Hard Drive freezing at startup

Recommended Posts

A few days ago I got a good deal on a non working M5120 Macintosh Portable. I recapped it and it works fine except for the floppy and the hard drive. I think the floppy drive may have dirty heads or something, because mechanically it seems to work, but can't read or initialize any disc.

 

I had a strange issue with the hard drive. It was stuck at first, but after insisting on it a few times it finally started spinning and I even could recover the data from it. The owner rejected the data, so I went to wipe it. And here began my problems. Initializing it with Apple SC Utility failed, so I began using Micronet Utility. I couldn't format either, so I began to look for bad sectors and it resulted it had a LOT of them. So I was reassigning bad sectors with Micronet, but it was getting late so I turned it off and went to sleep. The surprise was next morning when the hard drive is somehow freezing the computer right after the boot chime. It just gets to the gray background with the mouse at top left corner. Sometimes enters in a chime loop. It won't even boot from floppy or from an external hard drive, unless I set the external drive to SCSI 0. This way I can boot the computer, but the internal drive won't show up on Micronet because SCSI 0 is being used by the external drive.

 

I'm 100% sure it's the hard drive causing the problem because I have another Portable M5126 and:

 

1. M5120 works fine with M5126 hard drive

2. M5126 also freezes the same way with the M5120 hard drive

 

I know I can look for another Portable Drive or buy a SCSI2SD, but I though I could get this drive running again, and it bothers me. Also my plan was to fix it and resale, so I don't want spend a lot on it. If anyone can give me some advice I'll appreciate it.

 

Thank you very much!

Share this post


Link to post
Share on other sites

Welp I fear what has happened was the degraded rubber seal has turned to goo, and the heads have slung it all around the platter. The longer you let it run, the more damage it has caused. 

 

You can take the drive apart and verify, and if this is indeed the case, theres no saving it. This is a known issue with these drives. 

Edited by techknight

Share this post


Link to post
Share on other sites

Well, it may be the case. Even I don't see it in the platter, the seal has turned into some kind of oil. By the way, should I do something on my working Portable drive to prevent it from happening?

Share this post


Link to post
Share on other sites

Those drives are the most unreliable ones I have ever seen. 

 

Out of 10... 9 are bad, moreover the unusual board and connector was only used in the Portable. 

 

You can lift the cover to prevent the seal from going bad, but there’s a risk to contaminate the platter as well. 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×