Jump to content
glay78

Macintosh Portable Sad Mac

Recommended Posts

Hi I’ve recapped my M5120 and it has sad Mac now. It works previously before capping. I’ve check both battery and power adapter that’s working great so power shouldn’t be the issue. It chimes but has the error as shown. Also swapped out the ram but it’s the same. 
 

Any help?

EA394A70-CA7C-42D3-81B3-EB3C696B7911.jpeg

Share this post


Link to post
Share on other sites
13 hours ago, desertrout said:

Is it the same error every reboot/reset? This link (https://udcf.gla.ac.uk/~gwm1h/Error_Codes/Sad_Mac_Codes.html) provides a breakdown 68k error codes, with some specifically for the Portable further down the page. If I'm reading it right, the error you show indicates a RAM test failure at Bank A.

Yes it is consistent every boot/reset.

 

its working all the way until it don’t one day. And I recapped and found this error. I don’t see any broken traces, how should I change the ram then? It’s soldered.

Share this post


Link to post
Share on other sites

Don't jump ahead just yet. There are a few things you could try first. If you have a RAM expansion card, verify it's in the correct connector (J11) - happens to everyone. You could try starting both with and then without the expansion card. After that, I'd examine the onboard RAM near where you were recapping to see if there is any residue or damage. I don't know offhand what banks are where, but start with a visual inspection.

 

Also make sure to do a power manager reset if haven't been.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×