Jump to content
petteri

Plus project

Recommended Posts

I was looking for a mouse for my 512Ke and ended up getting a broken Mac Plus with it.

 

Very boring unit, no extras or anything. Seems like it has the same issue with the analog board solders as my 512Ke. I was able to get some video by pushing the sides but I think it has some other issues as well. There is no startup chime and I have a hunch the logic board has been damp at some point.

 

My first task is to do an IPA wash for the logic board and check the analog board soldering.

 

 

plus1.jpeg

plus2.jpeg

plus3.jpeg

Edited by petteri

Share this post


Link to post
Share on other sites

Resoldering fixed the analog board a bit. There is still something wrong as the picture goes away if knock the box a bit. Much better than it was but looks like I missed something.

 

But the logic board has issues. No chime, some faint burp sound looping and stripes. I am not sure what to do next, I have to read through The Dead Mac Scrolls.

 

 

plus.jpeg

Edited by petteri

Share this post


Link to post
Share on other sites
29 minutes ago, petteri said:

Resoldering fixed the analog board a bit. There is still something wrong as the picture goes away if knock the box a bit. Much better than it was but looks like I missed something.

I had the same problem with one of mine.  First time, I had just remelted the existing solder.  That worked for a while, but then had problems again.  Second time, I removed and replaced the solder.  Also, I hit every solder point that looked questionable.  Third time, basically the same thing, remove and replace, hit every questionable point and even some that looked fine.  Last few times I booted, it was still fine.

 

If I've broken the trend, it should be fine the next time I boot it up.  If not, I guess the resoldering will be an annual event. ;)

Share this post


Link to post
Share on other sites

It was a ROM issue. I swapped a known good ROM from 512Ke and Plus boots up fine now. The floppy disk drive doesn't eject so it needs a cleanup and possibly a new eject gear. 

plus works.jpeg

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×