Jump to content
fimbulvetr

Floppyemu screen blanking out

Recommended Posts

I have the previous model of the floppyemu. I absolutely love that thing except for the damn screen. It has given me trouble since day one where it goes blank after it has been running for a while or it is blank when it starts up . I have to fiddle with how the screen is seated or reset it a bunch of times before I get anything on the screen. I mentioned the screen problem to BMOW and that was Steve's suggestion for the problem.  The screen is a known weakness with these things, and Steve has mentioned on the BMOW website that he is looking into a new screen. This problem has been getting worse as time goes on, and lately it has taken many tries to get the screen to work and now it sometimes just shows gibberish before I get it to display correctly. Last night was really bad and then I lost one of the stupid fiddly little button pushers for the case, which did not help my mood at all. Does anyone here have any solutions for getting the screen to work more reliably? It is an indispensable tool for keeping my old macs going, but the frustration with using it is starting to drive me crazy.

Share this post


Link to post
Share on other sites

Yeah, screen issues for me as well.  I took the screen off, and on the back there is some metal clips.   I bent those guys in while squeezing pretty hard on the bezel to try and sandwich the screen with a little more force.  Not perfect, but its working much better than before.  Seems like I always have to adjust the contrast after it sits for a while.

 

EDIT:  So this started annoying me even more just now, so I separated the screen from the PCB by unhooking the four metal clips.  On the back of the screen is this rubber thing with gold fingers.  All the fingers were black.  I cleaned it up with a splash of contact cleaner and wiped with a stiff lint-free qtip.  Fixed the issue for now, but we'll see how long before the screen starts going crazy again

Edited by joethezombie

Share this post


Link to post
Share on other sites

Huh. I bent those metal clip things (which helped, but was how I lost that stupid @#$%&# button pusher ... guess I'm whittling one out of wood now), but I've never had it apart to see the gold finger thingies. I'll have to check that out. 

 

I wonder if soldering it together instead of relying on pressure contact would help, and if that is even possible.

Share this post


Link to post
Share on other sites

Screen seems to be working better now that I’ve fiddled with it. It is still always blank on first start, but one push of the reset button fixes that. The button pusher I whittled out of a bit of dowel ended up working much better than the original plastic one. I may end up whittling replacement pusher for all of them...

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×