Jump to content

Search the Community

Showing results for tags 'plus'.

More search options

  • Search By Tags

    Type tags separated by commas.
  • Search By Author

Content Type


  • Important Information
    • The 68kMLA Forum Rules
  • Community Connections
    • General 68kMLA News & Stuff
    • Conquests
    • Trading Post
  • Projects & Hosted Forums
    • RetroChallenge
    • 68kMLA Wiki
  • 68k Model Forums
    • Compact Mac
    • Mac II, Quadra & Centris
    • 68k LC & Performa
    • 68k PowerBook
  • PowerPC Model Forums
    • NuBus Power Mac, LC & Performa
    • PCI Power Mac & Performa
    • G3/G4/G5 Power Mac, iMac & eMac
    • PPC PowerBook & iBook
  • Everything Else…
    • Apple I, ][, /// & Lisa
    • Newton
    • Software
    • Hacks & Development
    • Peripherals

Find results in...

Find results that contain...

Date Created

  • Start


Last Updated

  • Start


Filter by number of...


  • Start





Website URL












Found 23 results

  1. My Macintosh Plus has many hardware issues, but I would like to address this one today. This checkerboard appeared one day and alongside that, the sound stopped working. I already replaced electrolytic capacitors on both logic board and analogue board. I recently upgraded my Macintosh from 2.5Mb of RAM to 4Mb of RAM and the checkerboard changed. I would appreciate some help with this problem because I tried many solutions and none have worked. Before 4Mb upgrade: After 4Mb upgrade:
  2. I've been having A/V problems for some time now, I asked people on r/VintageApple and they said I should recap logic board. I already replaced all cylindrical capacitors on the analog board and a professional replaced the capacitors on the logic board, but alas, there wasn't any change, I still get this checkerboard on startup and there's no sound at all (except some occasional faint screeches). I am getting really desperate for solutions because this is a very specific problem that has not been (probably) documented yet. I really want to make my Mac Plus work again, but anything I've tried did not help at all (I guess I don't have to worry about caps anymore...). I have little experience with electrical circuits but from what I understand, picture is relayed through RAM, so maybe the RAM is broken? Although it shows 2,560K installed which is in fact the amount of RAM installed... Maybe there's a bad contact on J4, I really don't know. So, people of M68kmla please help me! P.s. along the things I already did is checking the voltage, it was a bit off and I did set it to 5V, but alas, no difference.
  3. Hello everyone! I introduce myself, my name is Rodrigo. I live in Argentina, so I apologize if my English is bad. First, I apologize for asking for help without having helped before. I've been reading this forum since 2017, but I've only just had time to get back to work on the Mac during quarantine. In 2017 I had the joy of finding a forgotten Macintosh Plus (Apple is not very common in my country) in an old warehouse. He had suffered a lot, he had the rear battery door with the battery burst and a lot of dirt. When turned on, the dreaded SadMac appeared with a code that I did not find in the repair manuals. Since poor Mac needed a shower, I started to take it apart. I washed its plastic parts, and removed all the corrosion that was possible (leaving marks on the analog board that do not affect its operation). But, due to my clumsiness, I made a mistake in testing. I forgot to connect the CRT ground wire, to which the Mac responded with sparks inside the Electron Gun and smoke coming from the analog board. I turned it off quickly but the damage was already done. I proceeded to plug the cable into the corner of the CRT, and turned it on again. But the Macintosh now only managed to show a small line to the center of the screen. I noticed that it was the same width as the SadMac logo. With the error code noted above, I started to see its possible causes. Which led me to the HIGH ROM. I got the file to flash an Eprom in a forum, and upon posting it, the Mac booted up, but showing only the top of the screen and a horizontal line in the middle. In the repair books, it specifies R3 and Q1 as causing this problem. But having analyzed them off the circuit, I concluded that they were fine. I do not remember when it happened, but the central line shifted higher, since there is now only an image in the upper third, no longer coinciding with the other cases raised in the books. I have replaced: R3; R2; CR2; C5, Q7, Q4 (The 2n4401 for a BC337) but everything remains the same. I also got a full identical CRT, but it displays the same way. Unfortunately I don't have an oscilloscope, nor the possibility of getting a replacement MPSU51 or MPSU01. I've started parsing two equivalents for these, but I'm not entirely sure. TIP117 for MPSU51 and TIP112 for MPSU01. Data that may be useful: -Analog board: 820-0082-E 1986 -FlyBack: 157-0042C -Input Voltage: 110 (Non international version) Hope someone can help me. A very big greeting to all.
  4. It’s been long in coming but I finally kicked it out today. Yes, even your working order Mac 128K through the Plus can use a recap. A video INDEX is in the text description on YouTube to help you easily refer to different sections of this 1 hour video. Even if you aren't interested in a recap, check out the bad Flyback segment where it lights up in the dark!
  5. sfiera

    What’s this C1?

    I’ve been reading up about how to care for my new Plus, and one of the things that comes up is the capacitors, particularly C1. So I opened it up and found this surprise: I think it’s probably original, given all the hot glue around it, but it doesn’t match the images I’ve seen online. Is it a better capacitor for the job? I’m not really sure what to make of it. The other capacitors look alright to me, so I’m not in a hurry to replace them.
  6. Hello, I have a Macintosh Plus that have 2 problem: The Analog board only provide 9.4V measured on the connector on the Analog board side (Same on the J8 from the Logic board). All the connector have been soldered (with new solder past). The board had bad corrosion traces but I did measured all connection with an ohmmeter and they all seems to be fine -> I will probably need to change the 12V 5W Zener diode to solve the first issue. (I guess). I know that the Analog board has an issue because I tested it with a known good logic board and I had the same issue (9.4V instead of the 12V) The logic board was cleaned and the ROM and RAM where re-seated. When testing the logic board with a known working Analog board, the Macintosh Plus will reboot rapidly in a loop. The screen is not even able to show a good icon, only try to show a partial image. To be safe I removed the Programmer and Logic switch to check it wasn't due to a reset being inserted by the bad contact on these switch. I check on the Dead Mac Scroll but I wasn't able to seen a similar issue. Power line on the logic board aren’t shorted... however on a good logic board I was able to measure ~150 ohm between +5V and GND, while on the "bad" logic board I only had ~70ohm Anybody had an idea on how I should proceed? I do have a working unit to compare and test parts... Thanks in advance
  7. Hello all - For the past few days I've been wrestling with this Macintosh Plus that has some serious analog board issues. When turned on, the system does not chime - it is completely silent. It appears to be dead, however, if the brightness is cranked up nearly to the max, a very distorted picture can be seen. It appears to be a partial vertical collapse, but on the top of the screen rather than in the middle. I've never seen a Mac exhibit this symptom before and am stumped as to where it is originating from. The small bit of vertical picture left also occasionally changes, as can be seen in one of the photos. Of note is the fact that measuring voltages through the mouse and external floppy ports, I get noticeably weak voltage - approximately 3 volts on the +5 volt rail, 8 volts on the +12 volt rail, et cetera. The floppy drive is also completely non-functional. I'm not sure if the problem here lies with the power supply or something in the video circuit. I've replaced most of the capacitors except for a few which I did not have replacements for, and those I verified with my meter to be within spec. (I did not replace C1, but it measured close enough to 3.9 uF that it seems to be fine). I've reflowed the yoke connector J1, the logic board power/video connector, and the flyback transformer solder joints and made sure they all have proper continuity. I've also tested the logic board with another known good Plus, and it boots and functions as normal. If anyone could point me in the right direction in fixing this issue, I would be extremely appreciative. Regards, CJ
  8. Here's an update to a previous thread of mine in relation to getting a SCSI2SD booting with the Plus. The Plus is notorious for having a flaky/early version of scsi that doesn't work as expected and as far as I can tell there is no other reports of it working with the SCSI2SD. So my previous attempts to make a bootable SCSI2SD drive with codesrc's tutorial (found here) on the Plus resulted in weird behaviour (clicking noises, resets etc). I found out through setting up the SCSI2SD as if it was a HD 20 (see this comment) and using an earlier unmodified version of the HD SC Setup (v7.1) I could install System 6.08/7.0 to the drive and boot from it. However this relies on access to either a way to easily make 800k disks, access to an original floppy with an early version of HD SC Setup or a floppy emu (in which case why would you bother with the SCSI2SD). So for perpetuity's sake I've copied the driver partition that HD SC Setup created - this can be used in lieu of the ludo.img mentioned in codesrc's tutorial. I've tested this with both the revision c rom and a Rominator (which I believe is based on the c revision), it would be great if someone with a Plus running an earlier rom version to give this a shot too. Apple_Driver.img
  9. The MAC MANIAC!

    I have no logic!

    OK if you have seen my post about my CRT issue you know that it has a strange problem. But when i was messing around it seems i broke a rom chip and now my logic board is mostly inactive! After putting in a disk it spun up for about 2 seconds and then cut off. I decided to check my rom chips and see if had put them in wrong. But when i switched them it just made a loud sound as if i made a remix of the Macintosh pluses startup sound. 3rd times the charm right? Well no, its not, in fact i found that a leg broke off of the LO rom. So i think that getting a new logic board will fix this? Also it makes no startup bong when i switch it on. Things that work is the- CRT power supply floppy drive analog board
  10. Hi, I bought Macintosh Plus (with 2.5Mb of ram) with CMS external SCSI hard drive, i also bought sealed and new system 6.0.8 floppy disks, i installed them on CMS external hard drive; when i open scrapbook or control panel or file manager, co-processor not installed error pops up, it keeps happening every time i open scrapbook or control panel or file manager. Please help me.
  11. TechEdison

    Retr0Bright Questions

    This coming summer, I will be doing a Retr0Bright treatment on my Macintosh Classic and Plus, including keyboard/mouse. I've got a few questions on methods, so I can end up with the best possible results. -Should I remove the little apple emblem on the front? If so, how do I re-attach it when finished. -Is the original color really nearly white, because after looking at an even slightly yellowed case, it doesn't look right... Looks too "bright" -What's the best method for cleaning/whitening/Retr0Bright-ing the Plus's keyboard and the ADB keyboard/mouse for the classic. Should the keys be removed? What's the best way to do this. -Removing internals... Insulated screwdriver+alligator clips to discharge the CRTs, and then disassemble it, correct? -The plus has a 20SC hard drive, which definitely needs Retr0Bright. Briefly looking it over, it doesn't look straightforward to disassemble, am I missing something? I think those are all the questions I have right now. If there's any other tips or information, I'd love to know that too. As I slowly build a collection, my plan is to have each item look, function, and feel brand new.
  12. steven6502

    Looking for Mac Plus KB and mouse

    I am looking for a macintosh plus keyboard and mouse. Don’t care about looks just care if they work. I would prefer to get them in one deal but I am happy to buy them individually.
  13. sigtau

    Sad Mac (Plus, Rev 2 ROM)

    Thought it would be better to have a separate topic so anyone finding this by search/Google could see it more easily. I installed four 9-chip, 30-pin 1MB SIMMs into my newly built Plus, and when it boots upon performing its RAM test, I get a Sad Mac code 030ff0. Googling around indicates the first byte (03) indicates a memory failure, and the latter two bytes indicate which chip failed, although since it's a set of SIMMs that isn't a terribly helpful number. I have several sets of this type of RAM laying around and I've tried different combinations and it doesn't work. Occasionally, the error offset may change to something like 030400, but that's still a memory failure error code. Resistors R8 and R9 are clipped and pulled aside to enable detection of high-density SIMMs. I'm going to try resoldering it and installing four 256K SIMMs to see if that fixes the issue. The board has been cleaned on a hot (no-detergent) dishwasher cycle as of two weeks ago and no shorts, scratches, or defects are otherwise visible. Note that the board arrived with the resistors already clipped, so I have never seen the machine boot with any different RAM configurations. I'm making this thread mainly to ask if there is anything else I can try, any chips I should inspect for faults, and if there are particular types of SIMMs that I should look for in the future to mitigate this kind of problem. I've read things about ECC and non-ECC RAM but I don't know enough about RAM to know one way or the other.
  14. Hello people! I recently acquired a Mac Plus while doing a clean out of my grandfather's old factory. The keyboard and mouse were FUBAR, as they had been left under an old can of paint which leaked all over them. He said that there was also a hard drive somewhere, but we couldn't find it. I scrubbed as much old paint of this Mac as I could, and besides from a rather even coat of yellowing, it seems to be in pretty good nick. I took it home and plugged it in, and it made the start up bong and the floppy drive made noises, but the screen never fired up. I cracked open the case and besides some dust, everything seemed to be in relatively good shape. No caps were leaking, and nothing looked corroded. I also discovered that this Mac had 4Mb of RAM. Nice! I came to the realisation that this Mac had deeper problems. I noticed when I found the Mac, that it had LOTS of screen burning, which indicated to me that the CRT as a whole could have just bit the dust, or that the flyback transformer was completely screwed. Further poking around inside the machine also revealed that the CRT power connector looked like it was burned or melted. I thought while I had it open, I'd perform the cap change just in case, for longevity if I ever got this thing working. I couldn't find all the correct caps, so I used some higher volt ones, and there was one blue non-polar one that I didn't change at all. Upon firing this up after the change, it worked! I have no idea why the cap change fixed it, non of the caps seemed damaged in the slightest, I verified this when I removed them. No residue or anything! So now I have a semi working Mac, but I have 2 issues which I'm unsure of how to fix. The computer makes a REALLY REALLY high pitched squealing noise. I think this may be the flyback transformer, but I'm not sure. UPDATE: When I fired up the machine to take the photos in this post, the noise was gone! I'm unsure if it will come back, has anyone else had this problem? It's also VERY hard to insert floppies into the drive. The seem to be stuck on something, I'm not sure what though (I've made sure it's aligned correctly). Also, sometimes when I put them in, the jitter around in my hand like crazy until whatever mechanism in there stops, and I can finally insert the disk! And on top of that, the auto eject doesn't seem to be working, but I'm not that familiar with macs that boot directly from disk, as my other mac (a mac classic) is currently not working AND it has a hard drive. I also have no boot disk to test this machine further. Let me know what you guys think!
  15. Good afternoon all, I have acquired two Mac Plus units of which neither want to boot. I've started with the usual logic and analog board cleaning and recapping to no avail. The most promising combination of boards only achieves a white horizontal line accompanied by noise from the speaker, as seen in this video: Other combinations of board only achieve a flupping noise at various speeds with a blank screen. Nothing seems particularly broken on any of the boards, except scorching underneath the 5W 1Kohm resistor on both of the analog boards, both of which tested open and have subsequently been replaced. I know there are a lot of variables at work here and not having a working system to swap parts and narrow down the problems makes it more difficult to diagnose, but are there any specific areas that need checking/replacing to start off? Thanks
  16. sharpjon

    Bare-metal Mac project

    Hello fellow 68k enthusiasts, I'd like to share a Mac project I've been working on for a bit now. I've been exploring "bare-metal" programming on the original Macs (128k/512k/Plus) and just got around to writing up my initial efforts here: http://jonsharp.net/retrocomputing/bare-metal-macintosh-programming-part-1/ But perhaps more importantly, I'd like to solicit some help in the next stages of my efforts to produce something modestly useful/interesting on the Mac hardware, without any real help from the ROM/System. I've got an 'experimental' branch in my 'HappyJon' repo that carries things further than the initial demo in my writeup. This branch demonstrates a compact font, character and string assembly routines, and the beginnings of porting newlib. And it's this last part that I'm hoping to get some help with. I'm having some difficulty with pc-relative code and linking... Anyway, would love some feedback on this or any other aspect of the project. Here's the repo: https://github.com/jrsharp/HappyJon Thanks all! -- Jon
  17. IlikeTech

    Repairing A Macintosh Plus

    Hello everyone, I recently bought a Mac Plus on eBay, with a power cord. It did not come with a mouse or keyboard, and the seller priced them more then the computer itself. Thankfully, it's PRAM battery had been removed, even though the contacts were slightly corroded. The first time I tried to start it, it came up to a sad Mac with error 038000 on it. I checked and reseated the RAM, to no avail. I recently ordered 4x1 MB ram sticks, and when they come I'll keep you posted. I got it from the state next to mine, so shipping was not a complete killer. It unfortunately is missing the screw under the battery cover, but I think that is all right. I am going to build an adapter for a keyboard and mouse so I can use modern peripherals, unless someone is willing to donate them. I am a young person who is interested in old computers, and trying to fix them. If I get it working, I will keep this forum updated. If anyone has any advice in the meantime, it is very welcome. Thanks, IlikeTech
  18. Does anyone know the pinout of the mac plus logic board to analog board cable? I was wondering if it used black and white composite video.
  19. andy2k68kMLA

    Macintosh Plus Logic board problem

    Hello everyone I'm trying to troubleshoot a 1MB logic board (820-0174-C). It doesn't chime only does what I posted in the video. I tried reseating ram, booting only with 1 stick of RAM, etc. reseating and cleaning hi and lo ROM DIPS. Voltages are good from a good, working analog board. The -5 voltage regulator on the logic board measures okay (-4.999 volts). I hear the TSM DIP can go bad too. Any other ideas as to what might be wrong? Any other guides for troubleshooting the logic board. Please watch attached video. Thanks everyone. trim.524A3B4F-052B-44CA-9011-5E24ED3DEFEC.MOV
  20. pierofirenze

    20SC Hard Disk

    Good morning to everybody, I have found a very nice Macintosh Plus computer complete with its external Hard Disk 20SC that is probably not working. This is the reason why I am here... I would like to ask if anyone know the functionality of this drive. When I switch on the Hard Disk the red led on it will ligth five times, then, if I will switch on the computer the 20SC led will blink again other five times and then it will blink continuosly very shortly, it seems that the the computer is trying to read the HD but it does not work. Does anyboy know what is happaening? And perhaps how to fix the problem? Thanks in advance
  21. Trying to clean the floppy drive of a Macintosh Plus, now every time I insert a floppy it will automatically eject it. Disassembling the 800k floppy drive I realised that when I put a floppy in it, the motor doesn't spin and then the disk is ejected. Anyone know how to repair it? Any help will be appreciated.
  22. Juliet Elysa

    Mac Plus Temporary Jailbar Screen?

    Hey everyone! I'm SO glad I found this forum, I've been reading posts as a guest for a while and just now got around to making an account. Today I pulled my Mac Plus out of my closet for the first time in three to five years. It's sitting on my living room floor at the moment, though hopefully it will have a desk to sit on soon. The closet gets pretty cold, especially during winter, so I was a bit anxious about turning it on, not knowing what to expect. Thankfully it booted right up without any major issues. :b&w: It seemed to think that there was a disk in the internal floppy drive so it tried to eject something that wasn't there, but that (and me putting a few non-system disks, oops!) was the only hiccup. However, I had to turn the Mac on and off a few times since it froze when I tried running programs from the software sampler disk, and I noticed something strange while doing it: For a second before it started looking for a startup disk it displayed a screen like this: After the bars went away the screen grew dimmer and the black part slowly became grey. Then the screen flashed black for a fraction of a second before the computer booted normally. The thing that concerns me most is, the bars took up more of the screen each time I turned it on and off. When I restarted it with the restart button in a system error message the lines didn't show up at all. Can someone please give me an idea of how serious this display issue is/whether or not it's a warning sign of something major and what's causing it? By the way, I have very minimal experience with circuit boards. I can identify things like RAM and a CPU but don't know much about capacitors and other less obvious stuff yet. Thank you all!