Jump to content

Search the Community

Showing results for tags 'Rom'.

More search options

  • Search By Tags

    Type tags separated by commas.
  • Search By Author

Content Type


  • Important Information
    • The 68kMLA Forum Rules
  • Community Connections
    • General 68kMLA News & Stuff
    • Conquests
    • Trading Post
  • Projects & Hosted Forums
    • RetroChallenge
    • 68kMLA Wiki
  • 68k Model Forums
    • Compact Mac
    • Mac II, Quadra & Centris
    • 68k LC & Performa
    • 68k PowerBook
  • PowerPC Model Forums
    • NuBus Power Mac, LC & Performa
    • PCI Power Mac & Performa
    • G3/G4/G5 Power Mac, iMac & eMac
    • PPC PowerBook & iBook
  • Everything Else…
    • Apple I, ][, /// & Lisa
    • Newton
    • Software
    • Hacks & Development
    • Peripherals

Find results in...

Find results that contain...

Date Created

  • Start


Last Updated

  • Start


Filter by number of...


  • Start





Website URL












Found 18 results

  1. What EPROM parts are compatible with the Macintosh Classic logic board?
  2. So when I first acquired my PowerWave, it had some posting issues which were due to RAM, which were resolved quickly and the machine ran well. However, after decided to upgrade from the "fine" Mach64 with a Rage128 I had sitting around, things got weird: get a chime and then the screen gets a signal briefly, then nothing. not even a black screen, my monitor just says there's no signal. The machine wouldn't post at all, even after a board reset before powering back on. Tried pulling RAM, reseating the ROM, reseating and changing out CPU daughtercards. Nothing. I put the Mach64 and it immediately posts and boots right up. I upgrade/reinstall the ATi drivers, shutdown, replace with the Rage128, reset the board, power on, and after a few seconds it finally posts. Okay, fine, no harm done I guess. Time comes where I have to reset the PRAM. Upon doing so, I'm back to a black screen, no posting at all, nothing beyond the bong. Would the ROM on the PowerWave just see the Rage128 and not know what to make of it because it's too new? This all seems very odd. Just wondering if anyone has any advice or has had a similar experience. Edit: as an addendum, if it really is something about a contemporary (to a PowerMac 85/9500) that it needs as far as a graphics card, what would be a decent replacement for the Mach64? VRAM modules for them are nearly double what you can get a standalone card for.
  3. MacinPosh

    SE/30 burnt ROM socket

    I was in the process of cleaning and recapping an SE/30 logic board which had been subjected to a battery leakage. I've checked and rerouted all the rotted traces (totalling about 15) between the RAM, ROM, VROM and GLU but when I was satisfied enough to attempt a boot, pin 63 on the ROM burnt out (causing pin 64 to fall off, but pin 63 was definitely the offender) leaving me with a dead SE/30. Any ideas what might have caused the sudden burning on the ROM? I've checked it in another machine and now it only boots a grey screen with death chimes. Maybe there is a short I haven't noticed, or there are broken internal traces too? Any suggestions are much appreciated, but I fear this machine is un-repairable.
  4. Hi - I have a 128K Mac with a Levco Monster Mac 2MB upgrade card installed in it, and somewhere over the years the covers on the EPROMs on the Monster Mac card have come off... and now the machine comes up to a sad mac icon with an error code of 0180D7; which my brief google search indicates that it's failed a ROM test - unsurprising considering the lack of UV protection on the EPROMs. I don't think the original Apple mask ROMs (they are mask ROMs, aren't they? Not EPROMs? They have no window on them...) are bad; just the EPROMs on the Levco board - so what I need is an image of that - but, the way I think the board works is it overlays the first 4K of the ROM address space with what is on the Levco board; so a standard ROM image obtained from software running on a working Monster Mac should have the data I need in it... well, I hope, anyway. So - can somebody with a working Monster Mac card run a ROM image program (such as CopyRoms http://www.gryphel.com/c/minivmac/extras/copyroms/) and post the result? Although, any other ideas would be welcome also... :b&w:
  5. SE30_Neal

    ROMINATOR, RAM & 7.5.5

    Hi guys, having trouble getting my SE/30 up and running post Rominator II and ram installation. ok thats not entirely true i can boot into the Rom side and it shows its 24bit with 128MB yet wont boot into my actual HHD with the revised configuration. Please note i had 4MB and standard rom which booted fine in to 7.5.5. now I understand from big mess of wires there’s some issue with 7.5.5 and you need res edit 2.1.3 and disc copy 6.3.3. So the question. How do i fix this, do i need to downgrade my 7.5.5 to 7.5.3 if so how do i do that? Does picker help? Then do i need to take the rom and ram back out, put the old stuff back in? load res edit. This bit im unsure of too as I’ve never used res edit before. if anyone can assist whos successful upgraded there SE/30 to 128mb on 7.5.5 using the rominator to make it 32bit clean i would really appreciate any advise. On the plus side i now know all the hardware works. Neal
  6. Hi all, Since Dandu's dump of the 1.3 Pippin ROM (which supposedly does no authentication checks), my interest in Apple's only foray into the gaming console space has been renewed. I do a bit of homebrew game development for the Atari 2600 and Nintendo Virtual Boy in my spare time, and a few years ago ported an unreleased Pippin title to OS X and Windows, so I'm very interested in the possibility of unlocking homebrew for the Pippin. I currently have in my custody two Pippin units on loan: a retail US @WORLD model, and a late atMark prototype. Both kits have the stock 5MB of RAM. I have dumped the ROMs of both units-- the @WORLD has ROM 1.2, and the prototype unit has the "Golden Master" pre-release ROM. Using Pease Turbo, I can (occasionally-- it's pretty flaky) mount an AppleShare over the printer port and run my own software, albeit very slowly. Relying on Pease Turbo however (or even the "Tuscon" CD-ROM) imposes additional constraints, particularly with regard to what INITs and other system files I may or may not choose to load at startup. I can alternatively mount an external hard drive using a dual drive SCSI ribbon cable in either kit, but only the prototype with the GM ROM can boot from an external drive. This by itself opens up a world of possibilities for running my own software on the Pippin-- anything that can run well in 3500K of RAM on a Power Mac 6100 is a solid candidate. However, therein lies the rub-- I can only fully take control of the prototype system. Pippins are scarce enough, pre-release units even more so, 1.3 ROM Pippins possibly rarer than that. Seems I've hit a wall if I want a realistic shot at this. Maybe not. All Pippin ROM boards are 120-pin PCBs with an as-of-yet unknown pinout. Retail Pippin ROM boards are populated with four custom Apple chips-- most probably ROM chips of some type, but without public datasheets or other relevant documentation, that's a dead end. *However* the GM ROM my prototype has is populated not with custom Apple chips, but with 16 AMD erasable Flash chips; AM28F020-120JC chips to be precise. Bonus points: the datasheet for that chip *is* available! Looks like my GM ROM was for the most part built with off-the-shelf components, the PCB itself notwithstanding. What does all this mean? If the GM ROM board can be traced, and thereby cloned (not entirely unlike dougg3/BMOW's ROM SIMMs), then one could conceivably flash their own Pippin ROM and use it in a dev kit, a retail kit, or any Pippin really. In the absence of the RSA signing key and process to create new authenticated Pippin boot discs, this could be the key to making Pippin homebrew available to a wider audience. I don't know the capabilities of the 1.3 ROM since I have yet to experiment with it, but I do know that the GM ROM does allow for arbitrary software to boot and run, so at the very least, a cloned ROM board could be flashed with this ROM and thereby run homebrew software. As a test, I swapped out the 1.2 board for the GM board in my @WORLD with no observed issues, so if there are any differences in the final hardware, they appear to be irrelevant. Now, I have some good news and some bad news. The bad news is that unfortunately, the GM ROM board appears to be a multi-layer PCB, so tracing it out will be non-trivial. I do not have access to an x-ray machine (yet, but I'm working on it) nor am I willing to destroy this rare board in my efforts by sanding down each layer. The good news though is that I think(?) I've determined the pin numbering based on labels near the ROM socket on the Pippin logic board, and based on those labels and the datasheet for the Flash chips, I've traced out a small percentage (about 1/6th) of the pins that have visible traces on the outer layers of the PCB. I admit that I am in way over my head with this endeavor; I am very much a software guy, and I'm doing this mostly so I can get to the software part. Is there anybody with experience tracing multi-layer boards who could give me tips as to what to do next, what questions to ask, and/or who to go to for help? Thanks
  7. SE30_Neal

    Currupt ram and rom

    Hi all, having problems installing rominator 2 and owc memory. tried installing both separately without sucess as i just get a grey corrupt screen on boot up and funny sound. I cleaned up the board and connectors with contact cleaner as i thought maybe my se/30 is afterall 27+ Years old and may not have had the simms installed/removed in that time but still no look, put the old rom and ram back in and it worked straight away. Now i have a new 1gb hdd with Mac os 7.5.5 installed and wasn’t sure if that was causing the rominator from working but as i cant even get a boot up screen that wasn’t the problem, any suggestions?
  8. My house is surrounded by snow and fallen trees so I had some free time to throw this together. I like the idea of having a custom rom in my se/30 because a 10 minute ram check is tedious every time I boot. However seeing that there are no open source projects out there for a rom-simm, and the next best thing requires an expensive programmer for no reason :^). I call this project "EconoSimm" because the total price of a unit is around $15. The major benefit comes from it using standard PLCC flash chips. So while the max memory is restricted to 2MB/16Mb anyone with a standard programmer can flash the EEPROMS. It's open source for everyone to enjoy Basically: Custom roms for less than the cost of a tank of gas Github link: Click here! Board: Totally not thrown together in gimp render: Schematic:
  9. patatas

    Spectrum/24 PDQ+ V3.1

    Looking for someone to burn me a couple of Spectrum/24 PDQ+ V3.1 ROMs (I have the ROM dump)
  10. patatas

    Radius Le Mans GT Rom

    I have a Radius Le Mans GT with ROM v1.01...I have read that there is a newer version V3.0....Anyone have a copy?
  11. Hey all, I know our friends over at BMOW have their rom module for sale at 2mb and there's one on ebay thats 1mb, but I have a design in progress for a 8MB (ish) simm that would allow for the installation for bigger ramdisks and the like. Throwing out a feeler here, anyone interested? OW ill probably just fab up some boards for my own use. (oh and buy BMOW's programmer because finding 72 simm slots is impossible )
  12. defor


    From the album: Documentation

    Burndy MICROBUS™ 50 mil. Low Profile Card Edge Connectors Datasheet Detail Reduced to 150dpi. Highlight on part number of connector used in Pippin for both ROM and PCI/Storage expansion.
  13. From the album: Documentation

    Scan of the Pippin Retail ROM PCB (KINKA v1.0) with chips removed for clarity. Original scanned at 1200dpi, Reduced to 600dpi. Front and back halves aligned and scaled for PCB tracing.

    © (c) 2017 defor (Eastrain Design)

  14. Hi all, First order of business, is this a IIsi/IIfx ROM SIMM? It seems like it has the potential to be one. back side: And second order of business. I noticed that my SE/30's Video ROM is a little different than most. Most don't have a paper label placed on top of the ROM chip, and most aren't an EPROM! That's right, underneath that paper label is a glass window for erasing the EPROM with a UV light. Thought it was a little different. As always, here's a pic: Thanks, TheMK
  15. Antoshig

    Mac Plus Sad Mac Repair

    I purchased a Mac plus online from someone for a few bucks because it wasn’t working, so I decided to repair it myself plus it would be a great opportunity to learn about computers since I am pursuing in that field. I am having trouble with it. Symptoms: At startup the chime sound comes on, but I get a sad mac icon with a checksum of 0101A0 with some morse code on the bottom. Steps I took to try and solve the issue: I looked it up and it’s a ROM test failure. I tried resoldered the ROM sockets, but with no avail. I also tried replacing the simms with new ones, still didn't work. I checked the voltage coming from the power supply they were all good. I did more research about ROM’s and found out you could read the data and analyse with some ROM images from the internet to see the integrity of the data. In order to read the ROM, I would need a EPROM programmer which I don’t have. I need help in fixing the Mac Plus. I'll put some picture for reference. It's my first time posting on this Forum. Thank you
  16. steeler_fanatic

    Mac Plus V3 ROMs

    Anybody have Mac Plus V3 ROMS (LOUD HARMONICA) they can part with or burn? I have version 2 and want to "upgrade" Thanks!
  17. Neat article about BMOW's writeup about a rewritable ROM based on work from Rob Braun and Doug Brown: http://hackaday.com/2014/12/23/rewritable-rom-for-the-mac-plus/ And the BMOW article: http://www.bigmessowires.com/2014/12/20/rewritable-rom-disk-for-mac-plus/
  18. Well. Lately I've been studying 68k assembly. I find it a lot harder to understand than my ol' Netronics Cosmac Elf II's 8-bit RCA 1802 in hex. Still, i really want to start developing stuff. I can find much of the 68k instruction set reference on many website but, there aren't many about the macintosh toolbox. Most of them (like Inside Mac pdf's) got reference about using the toolbox with C and Pascal, and almost no assembly reference. It leaves me with unanswered interrogations about it. With some hope i searched in some forums on here but did not found what i was seeking out. I am mostly looking for the traps's Input/output, etc (Axxx). The assembler i am using is Lightsoft's Fantasm 6 ( which has become free) with Anvil. So, if you have any suggestions like books or online resources for me, could you post it here? Thanks for replies! Edit: I specified more what i am searching for.