Jump to content

Search the Community

Showing results for tags 'Macintosh'.

More search options

  • Search By Tags

    Type tags separated by commas.
  • Search By Author

Content Type


  • Important Information
    • The 68kMLA Forum Rules
  • Community Connections
    • General 68kMLA News & Stuff
    • Conquests
    • Trading Post
  • Projects & Hosted Forums
    • RetroChallenge
    • 68kMLA Wiki
  • 68k Model Forums
    • Compact Mac
    • Mac II, Quadra & Centris
    • 68k LC & Performa
    • 68k PowerBook
  • PowerPC Model Forums
    • NuBus Power Mac, LC & Performa
    • PCI Power Mac & Performa
    • G3/G4/G5 Power Mac, iMac & eMac
    • PPC PowerBook & iBook
  • Everything Else…
    • Apple I, ][, /// & Lisa
    • Newton
    • Software
    • Hacks & Development
    • Peripherals

Find results in...

Find results that contain...

Date Created

  • Start


Last Updated

  • Start


Filter by number of...


  • Start





Website URL












Found 75 results

  1. I have a Mac Plus that has been working perfectly for decades, but it has recently developed a few issues. When the Mac boots, it will promptly reach the desktop as usual, but anywhere from 1-5 minutes after booting, the Mac will crash out entirely to a blank screen and replay the startup bong repetitively in no particular pattern until I shut the Mac down using the switch at the back. When the Mac crashes, it will play the startup bong repetitively about 5-10 times and then it will somewhat restore itself and begin loading, only to crash out again during the startup process either before the happy mac or during the "wellcome to macintosh" screen. This occurs when I boot the Mac from a floppy or drive. The power cable isn't at fault, I have used it with other Macs in the past and for them it seems to work fine. It makes no difference whether I'm using the Mac, or simply leaving it dormant, so I assume an old failing component is to blame. I have checked the Dead Mac Scrolls for this issue, but it doesn't seem to be documented in there. I've breifly searched the internet, but haven't found anyone with this exact error yet. This Mac has only been used to demonstrate some vintage games and software, and has never had any upgrades done (besides a 4mb RAM upgrade, but I assume that was done years ago). I haven't had the time to crack the Mac open yet, but I will get around to it sometime in the next few months. Has anyone had this issue before, or at least seen a Mac with this issue? If so, what should I be looking out for when I eventually do the repair? Thanks!
  2. My Macintosh Plus has many hardware issues, but I would like to address this one today. This checkerboard appeared one day and alongside that, the sound stopped working. I already replaced electrolytic capacitors on both logic board and analogue board. I recently upgraded my Macintosh from 2.5Mb of RAM to 4Mb of RAM and the checkerboard changed. I would appreciate some help with this problem because I tried many solutions and none have worked. Before 4Mb upgrade: After 4Mb upgrade:
  3. I've been having A/V problems for some time now, I asked people on r/VintageApple and they said I should recap logic board. I already replaced all cylindrical capacitors on the analog board and a professional replaced the capacitors on the logic board, but alas, there wasn't any change, I still get this checkerboard on startup and there's no sound at all (except some occasional faint screeches). I am getting really desperate for solutions because this is a very specific problem that has not been (probably) documented yet. I really want to make my Mac Plus work again, but anything I've tried did not help at all (I guess I don't have to worry about caps anymore...). I have little experience with electrical circuits but from what I understand, picture is relayed through RAM, so maybe the RAM is broken? Although it shows 2,560K installed which is in fact the amount of RAM installed... Maybe there's a bad contact on J4, I really don't know. So, people of M68kmla please help me! P.s. along the things I already did is checking the voltage, it was a bit off and I did set it to 5V, but alas, no difference.
  4. Hello everyone, I recapped the logic board and the analog board of my Macintosh Classic but when I turn the computer I hear the chime and then I get a gray screen with a pointer I can move using the mouse. It will no go further than this gray screen. If I disconnect the hard drive I get the usual floppy with the question mark. I tested the hard drive power cable with a voltmeter and I got a strong 12V and 5V respectively. I guess the hard drive may work but has the boot files corrupted. Something that caught my attention and I don’t know if it is part of the problem is that there’s no way to make it boot from the ROM using command+option+x+o, I tried doing it with and without the hard drive connected with no luck. I don’t know if the keyboard has a problem also but as I said before the mouse at least works when I move it during the gray screen. For now I don’t have any floppy disk with an operating system to try, I count on booting from rom but I don’t know why it’s not working. I also washed the logic board to remove all the electrolytic fluid from the leaked capacitors and then used some Qtips with IPA to clean the stubborn parts. Thanks for the help.
  5. Hopefully, this would come in handy for anyone curious about the PCMCIA module made for the PowerBook 500 series. I've posted as many pictures from various angles of the board assembly and parts (in case anyone has interest in planning modifications and how much space is inside the module) as I don't intend to open this up very often. If at all. There are three hex screws, one plastic tab, and a sticker holding my Rev C module together. I didn't have a hex bit of the correct size, but a Torx T6 proved a snug fit that allowed me to remove the screws. When I depressed the plastic tab back a small distance, I was able to carefully lift and separate the pieces only slightly, hinging at the sticker in the back. Some patient "working" back and forth allowed me to carefully separate the sticker from one of the pieces, and the unit was opened. I worked the board assembly from the back to the front to lift it from the bottom molding. The module ejection mechanism is separate from the board, and is a fixture on the bottom molding - it may be difficult to replace if it becomes damaged. Here is the bottom side of the board assembly. All pieces, angled, minus screws. Left side top (from front of module). Right side top (from front of module). Left side bottom (from front of module). Right side bottom (from front of module). Overview of bottom of board. All pieces of the module. Front hinging doors of the module. There is one stretched "rubber band" that acts to spring the doors back to resting position. If this part breaks someday, you could probably just install a rubber band to replace it...I'm actually surprised this one hasn't dry-rotted, yet. Or hack another spring assembly to your fancy. Okay. Just let me know when you make USB and cardbus possible for the 500 series.
  6. Hello everyone! I introduce myself, my name is Rodrigo. I live in Argentina, so I apologize if my English is bad. First, I apologize for asking for help without having helped before. I've been reading this forum since 2017, but I've only just had time to get back to work on the Mac during quarantine. In 2017 I had the joy of finding a forgotten Macintosh Plus (Apple is not very common in my country) in an old warehouse. He had suffered a lot, he had the rear battery door with the battery burst and a lot of dirt. When turned on, the dreaded SadMac appeared with a code that I did not find in the repair manuals. Since poor Mac needed a shower, I started to take it apart. I washed its plastic parts, and removed all the corrosion that was possible (leaving marks on the analog board that do not affect its operation). But, due to my clumsiness, I made a mistake in testing. I forgot to connect the CRT ground wire, to which the Mac responded with sparks inside the Electron Gun and smoke coming from the analog board. I turned it off quickly but the damage was already done. I proceeded to plug the cable into the corner of the CRT, and turned it on again. But the Macintosh now only managed to show a small line to the center of the screen. I noticed that it was the same width as the SadMac logo. With the error code noted above, I started to see its possible causes. Which led me to the HIGH ROM. I got the file to flash an Eprom in a forum, and upon posting it, the Mac booted up, but showing only the top of the screen and a horizontal line in the middle. In the repair books, it specifies R3 and Q1 as causing this problem. But having analyzed them off the circuit, I concluded that they were fine. I do not remember when it happened, but the central line shifted higher, since there is now only an image in the upper third, no longer coinciding with the other cases raised in the books. I have replaced: R3; R2; CR2; C5, Q7, Q4 (The 2n4401 for a BC337) but everything remains the same. I also got a full identical CRT, but it displays the same way. Unfortunately I don't have an oscilloscope, nor the possibility of getting a replacement MPSU51 or MPSU01. I've started parsing two equivalents for these, but I'm not entirely sure. TIP117 for MPSU51 and TIP112 for MPSU01. Data that may be useful: -Analog board: 820-0082-E 1986 -FlyBack: 157-0042C -Input Voltage: 110 (Non international version) Hope someone can help me. A very big greeting to all.
  7. Yes, even 400K floppy drives need to be recapped. This video walkthrough holds your hand through the process. I show a few clips of Epyx Winter Games at the end. The bootable 400K DSK image I created yesterday is now on Macintosh Garden. https://youtu.be/71Lz9OjJFe8
  8. I recently bought a Performa 450 which was in very good condition, no visible leakages, blown-up batteries etc. When I power it on, I can only hear a clicking sound from the speaker. Fan is working correctly. I measured output of the PSU and so far it looks like I'm getting wrong voltage on +12V and +5V lines. It fluctuates around +8.5V and +2.8V respectively. -5V line shows correct voltage though. Do I have faulty voltage regulators or should I recap the PSU? It's one of the Dyna Comp (not TDK). Close-up photos attached.
  9. I finally finished my video on recapping the SONY CR-44 PSU, which can be used in the SE and SE/30. The video is long but informative. A Mouser Cart is linked in the text description under the video (you'll have to watch it on YouTube to see that), for those of you wanting to easily purchase all the electrolytic capacitors required. You also find a link in that description to my SEASONIC PSU replacement video, for those of you who haven't seen that one either. There's still reason to recap the SONY PSU though -- it's fanless and dead silent when operating. If you have only 1 PDS card and no major upgrades, the SONY PSU, once recapped, is more than adequate. Enjoy.
  10. Well, I'm in tears again over my own foolishness. I've been shooting a video that focuses on recapping of 400K floppy drives. I hadn't begun the actual recapping but was doing some preliminary tear-aparts and testing. I had my 400K floppy drive mechanism connected via ribbon cable to my 512K motherboard, but I had the drive mechanism pulled outside the back (with the back case off) and sitting on some plastic floppy disk cases. I had a single jumper wire with alligator clips at either end connected to the metal chassis of the Mac and to the metal chassis of the floppy drive. All was going fine until I switched on power and noted there was no Bong sound! I looked down in horror to see one end of my alligator clip wire had fallen off the floppy drive and onto the 512k motherboard, shorting one or two pins of the SYP6522 (about where the red dot is shown below) to Chassis ground (connected to Earth via wall socket). With my heart racing and sweat on my brow, I immediately switched off the machine and removed the jumper wire. When I switched on the machine, to my delight I was able to hear the startup bong! And when I put in a disk, the 400K drive would spin the disk and move the head to try to read from it. It spit out the disk, but the drive had been spitting it out prior to the Epic Blunder because I think the disk was bad. Anyway, I then booted from my FloppyEMU (which was also attached at the time on the external Floppy connector), and it booted to the Desktop just fine. Thinking that all was well, I put in the same disk into my 400K drive, but the drive motor didn't spin. Basically nothing happened, just as if I had the 400K drive disconnected and inserted a disk. I then shutdown the machine and powered on, then put the disk back in, but the drive still wouldn't spin the disk or move the head! And yet, when I power on each time, I do see the head move a few millimeters as it normally does at cold boot. Even so, disk insertion results in no motor spinning and no head movement at all. Yet my FloppyEMU works perfectly every time I try it. I have another 400K floppy drive, known good, so with the machine powered off, I disconnected my dead 400K drive and I connected that other known-good drive via the same ribbon cable to the motherboard -- it too is an internal 400K drive mechanism. That 400K drive accepted my floppy, tried to read it but couldn't, then spit it out. So I booted from my FloppyEMU (still connected), and at the Desktop I inserted my floppy again. Sadly, this second drive has now stopped spinning the motor! I powered off and on, then inserted the floppy again, but it still won't spin and the head won't move. But like the other drive, when I power on, I see the head move just very slightly as it normally does (which happens even when no floppy is inserted). So why would the head move a little at power-on, but then give me no motion at all when I insert a floppy? And why would both of these drives accept the floppy the first time, try to read it, then spit it out (perfectly normal when a bad disk is inserted), but then after booting to the desktop (via FloppyEMU) suddenly stop working? If the above schematic is to be believed, it would appear I may have shorted one or more of the address lines (pins 36 and/or 37??) to Ground with that stupid jumper wire. But why would a short there ultimately kill both of my 400K floppy drive mechanisms? I have another 512K motherboard, but I'm a bit scared to test my 400K drives with it for fear that whatever now plagues the 400K drives could harm that motherboard too. I would certainly appreciate hearing your thoughts and suggestions, especially yours, @Bolle. Thank you.
  11. After recapping my Mac512's Analog Board and booting either from a floppy disk (in the internal 400k drive) or booting from the FloppyEMU, with the case back off, I can faintly hear some beeping sounds coming from the area of the analog board, but it doesn't seem to be the speaker that I can tell. Here's a recording of the entire boot sequence, booting off the FloppyEMU: Mac512k_FloppyEMU_BootSounds.mp3 Honestly, I can't remember if I had heard these sounds before the recap, since I normally have the case on. The flyback is good (and tested in a dark room), but it wouldn't make beep sounds anyway, and certainly not during floppy access. Again, there are no sounds like this at all normally. The sounds only occur during floppy drive access, whether the 400k drive or the externally connected FloppyEMU. Voltage is a rock solid 5.0V during the floppy drive access, so that isn't an issue. I also checked the voltage on a scope, before and after the recap, and there was no change after the recap. I recapped the motherboard (stock 512k, with 64k ROMs) many years ago using tantalum capacitors. I'd appreciate hearing your thoughts.
  12. Below are 2 photos of AC line filter "LF2" from two different Macintosh 128k~Plus Analog Boards. The newest board is stamped 4192 (1986 PCB), which I assume means 42nd week of 1992, and uses the LF2 without the green Earth wire. The other PCB is a 1983-84 version stamped 0792, which I assume means 7th week of 1992, and you can see it has the green earth wire wound inside LF2. Indeed, most every Analog Board I've seen has the Earth wire wound in LF2. Why do you think the green Earth ground wire was not wound into LF2 on the 4192 board? By the way, the 3-pin power connector mounts those 3 pins to the PCB, but the Earth pin has no PCB trace. Regardless of which board we look at, the Earth ground coming from the power cord screws down to the metal chassis, so the chassis is Earth grounded. It's simply a matter of why that green Earth wire does or does not go through LF2 that I am curious about. Search this PDF for "LF2" as a keyword to see the schematic which mentions that it does indeed go through LF2. Hmmm...
  13. Hello everyone! I was just wondering if anyone knows where I might be able to find the 1984 Macintosh Security Kit for sale (see the pictures below for what I’m looking for)? I’ve tried looking on eBay, but I don’t think there’s anyone selling them! If anyone could recommend some places that I might be able to find them and buy them, that would be really appreciated! Thank you everyone!
  14. I tend to swap out the electrolytics in a recap and leave the film or metalized paper caps alone if they are good. Some among us have experienced blown filter caps near the power input on the original Macintosh analog boards, specifically these Rifa caps: C33: 4700pf 250VAC Minibox (sometimes found to be 2200pf?) C37: 4700pf 250VAC Minibox (sometimes found to be 2200pf?) C38: 0.1uF 250V Minibox The stock Rifa caps all appear to be metalized paper capacitors. A directed replacement for C33 and C37 would be the KEMET PME271YA4470MR30, also metalized paper. But would a Polypropylene version safety capacitor like the WIMA MKY22W14703F00KSSD be a better choice? There is also the KEMET F462AG472J1L2A polypropylene cap, but it is not classified as safety and therefore I do not know if it's failure mode would be open circuit when it blows. Similar thinking should apply to replacements for C38. Please let me know your thoughts. Thank you.
  15. I scored four NuBus cards in an IIfx, and one of them was the Thunder IV GX 1360! The IIfx was sold as untested, and still, it works like a charm, even with the original 160 MB Seagate! Thank you @Bolle for helping me out identifying the cards!
  16. macfan2350

    Rom Question

    Hey guys, I just have a simple question to ask. I have a Macintosh 128k with what I think to be a 512k upgrade board. It even says 512k on a little sticker on the board. However, it is missing the Roms to it. It just displays a checkerboard. My question to you guys is, what roms should I purchase? 512k roms or 128k roms. Thanks again, any help is welcome.
  17. macfan2350

    Fine vertical line on 128k

    Hey guys, hope your doing well. I wanted to ask another favor of you guys. A while ago, I had asked about my mac 128 with a fine vertical line issue. You guys asked me to reflow the solder, which I have done. However, the problem still persists, and I wanted to ask if you had any ideas. I get no beep. just a fine vertical line. Sorry for not getting back after over 4 years. Thanks again. I really appreciate it. See attached photos:
  18. Hey! I'm trying to find the software that is featured on the cover of the first edition Macintosh Plus manual, which can be found here! It looks like a spreadsheet/charts application, but I can't seem to find anything about it on the internet. Thanks everyone!
  19. curtiscoffee

    Macintosh SE Not Working

    Hi, This is my first post on these forums. I felt this would be the best place to come to ask how to get my Macintosh SE working again. So I managed to get my hands on this Macintosh SE. It came with the original manuals, mouse, keyboard, and even a carry bag! I paid around $5 New Zealand dollars for it. Yes I can't believe it either. So when I got it home, I plugged it in and it turned on, and it worked! I think that the disk drive is dead, because it just had the disk logo with a question mark and ejected the yellow protector disk. I left it on for a few hours. I then noticed a burning smell and smoke came out of the back of it. I opened it and being very careful i turned it on and i noticed that the flyback transformer was arcing and the monitor wasn't turning on, But I did get the start up sound and the fan was running. At first I thought a cap had popped on the analog board, but after inspecting it they all look perfectly fine. Also checking the main board it looks perfectly fine and the battery hasn't leaked. Has anyone else had this problem before? Any help would be greatly appreciated.
  20. The quantum hard disk in my color classic died, so I bought a SCSI2SD and was reading some information about it on codesrc.com and there was written that SCSI2SD needs to run on 5V or else the board would break.
  21. Just uploaded my Apple Hard Disk 20SC recapping video, which also covers the 40SC, 80SC and 160SC since they all use the same SONY CR-43 PSU. Check the text description for a Mouser Cart and useful info. At the end, I do a boot test with a 2015 15" MBP.
  22. I finally kicked out my Apple TechStep video today. This has been long in coming. Be sure to check out the text description beneath my video on YouTube because it contains a link to a SIT file containing Disk Copy images of the two included floppies, one of which has a pretty neat HyperCard stack.
  23. Hey everyone! I ordered some floppy disks a few days back and they arrived today. All the Floppy Disks are 1.44MB High Density Disks, and they are all unformatted. However, I am having an issue with them. When I insert them into the Macintosh SE/30, I get the menu to initialise them, and then it goes through the "Initialisation" process. It says "Formatting Disk", then "Verifying Disk" and then it ejects the disk and it says "Initialisation Failed". Nothing else. I'm very new to this, so I don't really know what could be causing this. The disks are unlocked and are not protected. How can I fix this? Thanks
  24. Charadis

    PowerBook 550c

    Hey, all! I've been lurking around here for a while, enjoying all of the acquisition posts and knowledge from the different subgroups of this community. Reading about the stories posted here really got me excited about vintage hardware from one of my favorite tech companies. I wanted to make sure my first post would be on the "Apple" of my eye. I've been hunting for a PowerBook 550c for a few years, and lately, the time has been ripe. I recently acquired one on Yahoo! Auctions, which had the 100Mhz (or 99MHz?) PPC upgrade and 32MB module installed. I also found a PCMCIA Rev C module and a NUpowr 500 167MHz 8MB daughterboard/set. There were a couple issues: when I picked up the package, I was so excited that I had to open it right there in my car outside on the lot. I was worried about the long trip it had to take overseas that it could be damaged, and I did not insure the package. It was dark, but I had the Map light on, and looking at the unit took my breath away. It was a sight to behold. As I played with the "feet," I ended up snapping the left side foot trying to pop it out. Some JB Wield/superglue remedied that, and has held up very very well so far! Also, the right side battery had corrosion that ruined the battery contacts inside. I'm just glad the unit still functioned, but I wanted a permanent solution. I bought a 520 on eBay recently, and transplanted the right side battery contact module over to the 550c. The transplant was a success, and I successfully revived one of the batteries that the unit came with using the Intelligent Battery Recondition and EMM VST program after reading here on some of the past experiences of users that posted previously. This was merely just so I had some kind of verification that my soldering work was not crap (: Here is a picture of the current setup. I am truly ecstatic about this new addition to my Mac fam, and I truly appreciate the wealth of knowledge I've been reading here on the forums. I am still waiting for a IDE -> CF card adapter. The drive that was included in my 550c was a 1GB Apple-branded IBM drive connected to a SCSCI -> IDE attachment by ADTX. Enjoy the pics! I have quite a few more, but having trouble loading them up here. If I can load more later, I post an update! Cheers
  25. Hello, My Macintosh SE/30 motherboard has been having issues since I received the computer in mid July. First of all, it used to turn on and do the simasimac, and death chimes but then I sent it out to MacCaps, and he tried to repair to no avail. It did the same thing when I got it back, so I tried washing the board in 5% White vinegar, but that didn't do anything. Any suggestions? Thanks! -Ryan