Jump to content

apm

6502
  • Content Count

    191
  • Joined

  • Last visited

3 Followers

Recent Profile Visitors

525 profile views
  1. apm

    SE/30 Daystar P33 weirdness

    Finally got a chance to add the resistors to R24 and R26 and the bridge across C1. There seems to be some improvement: the card no longer goes unstable after it heats up, provided there's no Radius card installed. However, the Radius Color Pivot card still doesn't work, and if the Radius card is installed, the accelerator goes unstable when it heats up, like before. I can run the Mac for a long time with no Radius card with no problems, then attach the Radius card (P33 still warm) and the stability problems immediately resurface. So it is the P33 heating up that makes the difference. Does the signal at R24 and R26 come out to the cache slot connector anywhere? I'm wondering if this might be a signal quality problem from having too many long traces on a high-speed signal.
  2. apm

    SE/30 Daystar P33 weirdness

    Progress: adding the pull-up to /CFLUSH has fixed the crash-on-cache issue. I can now boot with cache enabled and open the control panel. I can also display address $5207 0000 now. However the other issues remain unresolved: the card still goes unstable and crashes after it heats up for a while, and the Radius card still works intermittently, if at all. I'll try the clock modification next. Happy to send the card to you for testing and documentation, or let me know if you have other suggestions.
  3. apm

    SE/30 Daystar P33 weirdness

    Thanks, I'll try that. I do have a scope so I can probe any signals you think would be relevant. I could look at the 50MHz clock but I'm not sure I'd get much out of that: my scope only has 70MHz BW, and I'm not confident the waveform wouldn't be affected by the capacitance of the probe. However I might go sleuthing for a pin that toggles on the access to $5207 0000. Which GAL is responding to the specific accesses to $5205 0000, $5206 0000 and $520F000? I'd be happy to send you my P33 for inspection and disassembly. I think James's one is in regular service though, so I don't know if just the one is useful.
  4. apm

    SE/30 Daystar P33 weirdness

    All very interesting, thanks. I've tried removing jumpers C17 and B23. Now the floppy drive works with the bad P33 (hooray), and there is a modest improvement in the Radius card. Occasionally it will flicker the default grey screen with Radius logo briefly on startup, and more occasionally it will keep working as the system loads. Sometimes it still doesn't work. However, the other issues haven't changed. Accessing address $5207 0000 still results in a hang (every other address of the form $520x 0000 works fine). And the same issue persists with random errors (illegal instruction, bus error, etc.) popping up when the card has heated up for a long time. This appears to be bits randomly flipped on instructions loaded from memory, based on what ends up in the registers compared to what is displayed when I disassemble the most recent code in MacsBug. Curiously, when the card heats up, the Radius card becomes more likely to work. A finger temperature test (carefully, given the CRT) reveals that the 68030 gets rather warm, and it appears that U13 is also pretty warm, and maybe U11 and U9 as well. Here's the good P33 belonging to James: And here's the bad one I have. Not sure about the source of corrosion on the CPU and FPU; maybe it was in a battery explosion machine at some point? I can try the resistor modification next. To confirm, do you want me to short out C1 on the P33? What's the function of C1?
  5. apm

    SE/30 Daystar P33 weirdness

    Thanks. I hope to try some of that tomorrow. In the meantime, I looked back through the Power Central and Power Demo code, and both of them show the following flow: A condition is tested. One branch writes $520F 0000, then $5206 0000 -- this must be the "cache off" condition. The other branch writes $5207 0000, then tests a different condition and writes either $5205 0000 or $5204 0000. I can post code listings if that's useful, but basically it appears there are two more functional addresses in the GALs ($5207 and $5204). Could this have anything to do with enabling or disabling the FPU? There is a switch for that in Power Central, but I don't know if that needs any bits flipped in hardware. Out of curiosity, what is happening when one removes jumpers C17 and B23, and why would it affect the floppy drive? Interested to know what's going on with the clocks and cache. One final issue I didn't mention in the first post is that the bad P33, once it heats up for a half hour or so, becomes unreliable and generates random crashes. There's no obvious pattern I can see in MacsBug, but it looks like it might be loading instructions incorrectly from memory (one or more bits randomly flipped). I think this problem might be on the P33 logic rather than in the CPU itself, but I'm not sure.
  6. I've been trying to get a Daystar P33 accelerator (50MHz 68030) working in an SE/30 with one of @Bolle's amazing adapters -- in this case the model from the early 2020, short form factor with Asante ethernet card underneath. The P33 itself is faulty in some odd ways which I'm trying to figure out. Thanks to @james_w we've been able to make comparisons between this P33 and another known-good P33, and also between my Bolle-adapter and the earlier "tall" type Bolle-adapter that James has. The SE/30 runs with the P33 inserted, but it locks solid when you try to open the Power Central control panel in the Finder. Loading Power Central at boot also locks the machine if and only if the P33 cache is enabled. (To test this I would remove the P33, change the settings, and reboot with P33 inserted again.) Other symptoms are that the floppy drive (including Floppy Emu) doesn't work with the P33 inserted (shows "disk unreadable"), and that a Radius Color Pivot card in the passthrough slot doesn't work, although it works fine without the P33 and Bolle-adapter. I spent a lot of hours with MacsBug and eventually traced the freeze down to an instruction which reads memory address $52070000. I can open a debugger, type DM 5207000 and it locks. This address appears to be some kind of register on the P33 card. Other addresses accessed in the Power Central control panel include $520F0000, $52050000 and $52040000. None of these lock the system. James's known-good P33 does not exhibit this lockup problem, so there's clearly a problem with the card (maybe faulty cache RAM?). But here's where it gets weird: If we put the bad P33 in his Bolle-adapter, the floppy works and the Radius card works. If we put the good P33 in my Bolle-adapter, the floppy works and the Radius card works. So it's only the combination of my Bolle-adapter and the bad P33 that produces the other symptoms. Any ideas what might be different between models of this board? Any other thoughts on what to look at on the P33?
  7. Tom is overly modest about his own role in this project! We actually finished the design back in 2017, but the rest of life took over and documentation seemed like an insurmountable hurdle until the current lockdown. I've tried to put sufficient materials on the Github repo so that anyone can make their own board if they can get their hands on the right parts. The hard-to-source bits are the XC2018 CPLD, the 42C4064 VRAM (in ZIP package) and the oscillator cans, though you can get away with fewer and/or different frequencies depending on which resolutions you need (see the table here). At least for the chips, I was able to find small quantities on eBay, though I still haven't found the exact oscillator frequencies from the original. The whole design is through-hole with the exception of a single extra NAND gate that was needed to replace the original GAL, and would only fit the board in surface mount package. It's interesting to see that there are quite a few video cards of this era based on essentially the same design, whose origin seems to be the Lapis DisplayServer series of cards. This card that Bolle found seems to be another example. Besides the design materials themselves, I've documented what I could reverse engineer about how the card works. It might be useful in adapting this design to other screen resolutions and even to other machines.
  8. Yes, both monitors worked as they would on standard MacOS.
  9. Yep absolutely. I installed that pot on the reverse side of the PCB so I could adjust it more easily. It took some back and forth between Cutoff and the PCB pot (basically, video gain) to get a good picture. Also, I discovered today that A/UX doesn't work with the greyscale harness. The screen goes black when it boots the kernel. Doesn't matter whether I started from 256 greys or B&W. However, with an external monitor attached such that the internal video goes back to the logic board, A/UX works. Anyone had any better luck?
  10. And it works! Thanks @Bolle for the PCB. Making the cable harness took longer than populating the PCB. One thing I've found is that the picture quality is quite sensitive to the Cutoff control on the analog board. In its default setting (pre-greyscale), most shades of grey were nearly black. Adjusting it improves the range of greys, but it's easy to end up with the scan lines visible.
  11. I just joined the club. I saw the following SE/30 on eBay UK. At first glance, like any other cap- or battery-damaged machine: But what caught my attention was half of a black DB-15 port, centred in the panel. Radius video cards don't look like that. Could it possibly be...? A 3.5 hour train journey out and back, and this is the result: Success! The rest of the internals are mostly a write-off. The logic board has been paid a visit by "Maxell's Silver Hammer": The hard drive ran for about 10 seconds and then entirely stopped responding. I'm not sure the PSU is producing sufficient +5V either. But the Micron card works fine in another SE/30: There was no greyscale adapter in this machine, but by happy coincidence I just got a PCB from @Bolle and hope to build it up soon!
  12. I replaced the TDA4605 and recapped the whole board. Not sure if the results are progress. Now with the video cable unplugged, the monitor powers up and makes an ominous sizzly noise. I think it's coming from the flyback but I'm disinclined to get close enough to really pinpoint the source. I may have heard a couple arcs, but I can't see anything even with the lights off. There's a dim raster that overscans the CRT. With the video cable plugged into a Mac which is turned off (i.e. no signal), the sizzling stops and I get a bright white raster, wider than the screen and a bit too short [1]. With a video signal present, it goes back to power cycling like it did before. So where's the sizzling coming from and why? Damaged flyback perhaps, or maybe damaged sweep IC (TEA2037)? Perhaps even an ongoing power supply problem: I don't have a meter or scope to hand right now, so I can't check the voltages. Perhaps they are still too high. As it happens, I was able to do some testing on a working unit recently. The normal power supply voltages are around 40V and 12V (mine would rise to 50V and 18V before shutting down). The mystery RP13 is a vertical ceramic resistor of some sort -- see picture -- which is unlabelled but (from memory) measured between 5k and 6k. [1] That plugging in a cable, even without signal, changes things is not unexpected from what I understand of the schematic. There are a few odd bits of circuitry on the analog board which take their input from one of the monitor sense pins that's grounded when you plug it into a Mac. One bit of circuitry looks like it would increase the voltage to the flyback primary by maybe 2V when a Mac is connected. Another looks like it would add a 1200pF capacitor in parallel between the drain of the HOT and ground. I'm not sure what purpose either of these circuits serves or why they were designed in.
  13. Good thoughts, thanks. I think the HOT and its driver (TEA2037) are okay: there's a sensible signal at the HOT gate (not itself diagnostic), and a reasonable voltage appears on the one flyback secondary I felt comfortable to test with a 10x probe. When I retrieve my 100x probe from the office I can probe the higher-voltage parts of the horizontal circuit, but it looks like that's not the source of the problem. I will have to get my hands on an isolation transformer. Any particular reason to put the isolation transformer on the scope rather than the monitor? I guess I could also just try replacing the TDA4605 and see what happens.
  14. DP5 is on the primary side of power supply. Why it shorted I'm not sure. See attached reverse-engineered schematic. (Apologies for low-quality photo; no time to format this properly right now.) A few components I couldn't read the value, especially the SMT caps. In any case, I believe RP13 serves as a kickstart to the TDA4605 by providing a trickle of current from the unrectified mains line. It looks like after the circuit starts up, the winding of ZP1 pins 3-4 would provide a source of continuing power to the TDA4605. In a circuit in the datasheet for the TDA4605, a similar resistor to RP13 has a value of 75k. I tried 47k and then 22k, which is what's in the later Classic analog board. Same result in each case. I don't think it could go much lower without needing a >2W part, which doesn't seem likely given the size of the pads. I can't put a scope on the primary side of the circuit, but I did scope the secondary side tonight. There are two secondary voltages, a higher one used for horizontal sweep and the CRT neck board, and a lower one powering most of the rest of the circuits. See attached. Both voltages rise together until they reach around 50V and 18V, at which point the regulator shuts off, and the cycle begins again 500ms later. I don't know what the voltages ought to be when stable, but I'm wondering if this is an over-voltage crowbar circuit kicking in. In the brief period these two voltages are active, the horizontal sweep runs: I can see a periodic signal on the gate of the HOT, and voltages appear on (at least) one of the flyback secondary windings.
  15. I've worked out a schematic for quite a bit of this monitor by now. It has some similarities for the later Classic analog board, though with considerably more complexiy in the video circuit for various types of geometry correction. The CRT neck board looks like a pretty good design on which to base a grayscale adapter for compact Mac CRTs. More on that later. In the meantime, replacing DP5 (an 18V zener which was shorted) and trying 22k or 47k for RP13 results in a "flup-flup-flup" power cycling where the LED transiently comes on and then the system powers down, repeating the cycle about 2 times per second. It's possible a different RP13 is needed (anyone have one of these monitors??). But I'm wondering what else might cause this problem.
×