Jump to content

ttb

6502
  • Content Count

    103
  • Joined

  • Last visited

Profile Information

  • Location
    US

Recent Profile Visitors

The recent visitors block is disabled and is not being shown to other users.

  1. That's another good point. Both of my faulty-config ABs are also recapped (with the same caps) so I shouldn't rule them out, either. On the 5V rail itself it looks like there's just a 100 uF cap in what looks like an RC filter for the AB, but it's certainly possible the other circuits on the AB using the 5V rail could be impacting things. I'll do some PSU and AB swapping to see what the effect is. If it does seem isolated to the PSU I'm somewhat tempted to be lazy and swap a modern PSU like the Seasonic into my dead Astek enclosures, but it would be nice to get the Sonys working in my application.
  2. Alright, this is (somewhat) solved. As @Crutch pointed out, there's no reason to trust two power supplies, especially since I recapped both with the same parts. I first tried splicing in a lab power supply between the AB and LB, but it appears the LB either looks for the -5 and -12V lines before booting or there's something with the power on sequence that's lacking with this setup so it didn't work. Next, I tried it with a third AB/PSU combo, this time both unrecapped and the PSU is an Astek rather than a Sony like the others. No issues! Boots both the PowerCache and the Turbo 040 from a cold boot every time. The Turbo 040 config freezes once booted, but I believe that's because it's taxing the old PSU beyond what it can take. So what's causing this? Well, the risetime of the 5V line (measured at the cache connector, as above) is less than 1/5th as long as with the recapped Sony PSUs. I'm measuring it at 9ms. The span is the same in this window as the above to get an idea of the remarkable difference: Now I guess I'll have to dig into some analog circuits theory to figure out what I can do to decrease the risetime on my two Sony PSUs. I'd be curious to know what the 5V risetime is for other working configurations with the PowerCache or Turbo 040.
  3. Another update on page 9 (power connector: the ground isn't shown on pins 1-5, 7, 8 as it is in the original: Sorry for dropping all these here, I'll figure out github one of these days!
  4. I also bought an "L88M" 040 from eBay with similar results. Seems like an oddly specific thing to counterfeit, I guess using a full 040 makes it harder to dispute. Does anyone have thermal camera images of a known good L88M or K63H running with no heatsink? That would provide more robust evidence of what's fake/real than more subjective anecdotal statements like "real ones run cool to the touch". FWIW, my "L88M" does 40MHz at 60 °C with a low profile heatsink attached. Decidedly not "cool to the touch".
  5. Also, adding to this thread since I happened across this and someone in the future might find it useful as it's relevant to question 2 in the OP. The Artmix site had a page that talked about firmware versions here: https://web.archive.org/web/20070814112501/http://www.artmix.com/romver.html On that page, they claim that the "040i" version doesn't enable the FPU on a full 040 without a ROM change. I believe that's not correct per my above results.
  6. The PSUs are both stock Sony and both recapped except for the one large 400V cap that I bought in the wrong size (too tall). I recapped them both with the same caps, so it's quite possible I did something consistently stupid, though I'm thinking I'll try to rig up a lab power supply to the AB so I can eliminate that as a possibility. There doesn't seem to be too much voltage sag during power up, but maybe my timebase is too short here. It seems pretty stable at 5V once it finishes rising. The yellow trace is measured at the floppy connector and the green trace is at a 5V pin on the cache connector. I'll try measuring it over some seconds instead and see if anything interesting pops out.
  7. I would probably stick to software released before whatever computer came out. Maybe add a year or two at most. At this point you won’t be running anything released within the last 20 years on your Mystic, so why try to push it? In a lot of cases the most current version a machine can run might be painful to use. i think that’s why no one has tried to compile a list like this. Otherwise if the online software archives strictly enforced a PPC/68k flag, that would be a good way to filter for what will at least function.
  8. Alright, I have an interesting data point to share. I just procured a PowerCache P33 and swapped it in for the Turbo 040. Same result! Flashing question mark initially, but blipping the power causes it to boot. So the good news is that my accelerators either both work fine or are miraculously both broken in the same way. My current best guess is that maybe the PSU rise time is too slow for the accelerators. I've measured it at about 50ms from off to full 5V at the cache card connector. If the motherboard components started working at a lower voltage than the accelerator (or vice versa), this could cause them to get out of sync. The closest I've come to verifying this is that when blipping the power switch the CPUCLOCK signal from the cache connector will fully drop out but the 5V supply to the cache connector drops to 2V. Green is 5V line and yellow is the CPUCLOCK signal: I'm going to keep probing the other signals on the cache connector. If anyone has a schematic for the PowerCache and/or Turbo 040 or can tell me what I should look at to determine whether it's "alive" that would help out too since then I can pinpoint when it comes up in the startup process.
  9. ttb

    Color Classic VGA Mod. the CORRECT way

    Echoing @Crutch a bit, but how is everyone feeling about this mod a few years on? It seems like @Bolle did it with "satisfactory" results (dark, unfocused image; better after warm up) and @dkjones96 did it and is considering undoing it (sync loss on warm reboot and lack of clarity). I get that it's as close to Apple-endorsed as possible, but that feedback is worrisome, especially given the amount of additional tweaking both of these guys had to do. It seems really hard to directly compare this to the old preferred way (Option 1 on https://powercc.org/640x480/) since there are different AB revisions and perhaps even more variation at work. I guess I could try to do it the way presented here and then fall back to Option 1 as a plan B, but it would be nice to avoid excessive rework on a 30-year-old PCB.
  10. ttb

    La Porta's Finds

    Glad it made the trip down there unscathed! Sorry I didn't have the port cover, it came with an ethernet card installed. I guess that would be a slightly more expensive way to fill the open hole
  11. ttb

    Trick to desolder thru holes?

    I've had good luck with my Hakko FR-301. I used an old bulb-style Radio Shack desoldering iron for over a decade that worked, but tended to leave solder in the holes like you mention. The FR-301 can blast through a whole PDS connector in no time and leave the holes squeaky clean. It can bog down with a large ground plane but in that case bumping the setting up one step usually does the trick. There's probably clones if the cost is too high.
  12. I am trying to get a Daystar Turbo 040 working in my SE/30 using one of @Bolle's short adapters. I've already managed to work through other issues, but this one has me stumped. Basically, the machine will not find any startup disks when it boots from a cold start (e.g. flipping the power switch after it's been off for a second or more). I have tested this with two different working SE/30 logic boards, two different AB/PSUs, and two different SCSI2SDs. Also tried a different accelerator adapter, different floppy and SCSI cables, tried it with six different sets of RAM in different arrangements, swapping ROMs, etc. The test matrix is basically accelerator installed vs not installed on one axis, floppy vs SCSI2SD on the other: Floppy SCSI2SD Not installed (1) (2) Installed (3) (4) The boot floppy has a System 6.0.8 system folder on it. The SCSI2SD has a 7.5.5 system folder. The Turbo 040 has firmware 4.11. The SE/30 has the stock ROM. Notes about each configuration: 1) Works fine, no issues. 2) Works fine, no issues. 3) The system shows a gray screen with cursor. After a little bit, it shows the Turbo 040 happy mac briefly before ejecting the floppy. It then goes to a gray screen with no cursor an stays there. If I reinsert the floppy and press the reset button, the same thing happens. If I reinsert the floppy and blip the power switch (turn it off for less than a second), the same thing happens. Basically there is no way to get it to boot from the floppy. IMG_1448.mp4 4) This would be the normal operating configuration (accelerator installed, boot from SCSI2SD). From a cold start it goes straight to a blinking question mark. The amount of time it takes to show the blinking question mark can vary a bit. It can be almost instant like below, or take several seconds. If I insert the boot floppy while the question mark is there, it goes into the same state described in note 3 above. If I hit the reset button, it will just give the blinking question mark again. IMG_1449.mp4 The real weirdness (and hopefully a clue as to what's wrong) happens when I blip the power switch. This means interrupting power for less than a second (I haven't tried to find the lower bound, yet). When I do this, the system boots up without any hesitation. Additionally, once it is booted up, I can restart it at will and it remains fine. Hitting the reset switch also reboots it without issue. IMG_1450.mp4 My initial thought was that the PSU is overloaded. I've only scoped the 5V line but did not see any sag on startup. I have not checked the other rails and I'm not sure whether the Turbo 040 would even use them. My other thought (before I did a lot of testing with the boot floppy) was that it was related to some setting in the SCSI2SD. I tried adding delay, different modes, etc but it always produced the same results. Any thoughts on where I should start? I've basically done all of the component swapping I can think of to narrow it down. I'm hoping someone with a better idea of what the boot process entails and how the Turbo 040 integrates with that might be able to point me in a direction. Thanks!
  13. Thanks to @EvilCapitalist I am now rolling with 4.11: Note that it appears the processor speed is encoded into the ROM. This was originally a 33MHz accelerator but is currently running at 48MHz with a 24Mhz crystal. Relevant to this thread about firmware differences: with the 4.01(i) firmware I had an issue I briefly discussed above. Starting up after a full power off, it would always do a RAM check regardless of the fact that I disabled it in QuadControl. For the duration of the RAM check (a minute with 68MB of RAM), it would show a simasimac screen. Then it would finally show the regular gray screen and then a flashing disk (that part persists). Now with the 4.11 firmware it actually skips the RAM check and doesn't show the simasimac screen. It goes straight to the flashing disk. (As above, it will then boot if I blip the power switch.) So based on my experience it seems like 4.01(i) to 4.11 may fix some RAM issues. It at least now appears to pay attention to the QuadControl setting for skipping ram checks. Perhaps that option was only added in the 4.11 firmware?
×