Jump to content


  • Content Count

  • Joined

  • Last visited

Recent Profile Visitors

The recent visitors block is disabled and is not being shown to other users.

  1. Hello there - I recently tried installing 7.5.5 on my SE/30, and after 23 something floppies it installed just fine. Everything works correctly on it, but I noticed if I use the Shutdown or Restart options in Finder it bombs with just "bus error". The restart button on that message works just fine. If I boot it back up with my 7.1 floppy, Shutdown+Restart work just fine. Any idea why it would bomb like this? Not sure if the install was a bit corrupted, or if there's some other issue. Board is recapped and in good shape.
  2. Bolacore

    Macintosh 128K - no video and humming sound

    Finally found the fault, a 74LS166. Works great now
  3. Bolacore

    Macintosh 128K - no video and humming sound

    Really looking forward to getting this one working, never owned an original Macintosh before. Even more so to get the HyperDrive working, would be cool to have one of the few working units in the world
  4. Bolacore

    Macintosh 128K - no video and humming sound

    Almost got this one working! Good few patch wires at this point, and a new 74LS166. We're now booting and are functional beyond a weird screen. Since it works perfectly other than that, I suspect one of the 74xx ICs for the video generation are also faulty. I will get this stubborn Mac going
  5. Bolacore

    Macintosh 128K - no video and humming sound

    Taking another look after work and there's rotten traces from battery damage near the TSM IC. Started patching wires and now we have video on the screen, albeit just garbage. Does anyone have a nice high res schematic of the 512K board? The only one I can find is the official apple one, but it's very hard to read.
  6. I picked up a rather interesting 128K and it finally showed up this week. It's quite an early one as it just has a Macintosh badge instead of the later 128K/512K ones, but was upgraded with a HyperDrive 20 rev 2 and 512K board. I've been trying to get it working, and after patching it's analog board, I'm now getting just a humming sound from what appears to be the analog board (I can't really tell) and no video at all. The sounds reminds me of my aquarium air pump, with a slight whistle to it. No video at all when this happens, but I still see the CRT is on with the glow from the heater. It did have quite a lot of battery damage in the case, and some rusty bits near the two switches in the top left. Cleaned it before I tried to power it up (but after the picture was taken). Interestingly, if I swap in a good board from my Plus, the system works fine with no noises, and if I try the 512K board in my Plus it makes the same sounds there. When running the voltages seem fine, seeing 4.89V for 5V, 4.51V on the battery pin, 12.23V for 12V, and -12.4V for the -12V. I've turned the voltage control pot down slightly, but it can go up to 5.2V when I tried. No obvious shorts on the logic board either, lowest resistance I'm seeing is 59 ohms between 5V and ground. I've pulled off the HyperDrive board for testing (I bent the header pins removing it, so just left it off for now), in case that was the issue, but no change there. Nothing gets warm on the board either. Any idea what's up with this one? I'm slowly going through the schematic, but I'm not really sure what's up with it. I'd like to get it going again, just because I think the HyperDrive is really weird and neat.
  7. Bolacore

    Radius SE 2.1 ROM Dump

    The only other part would be getting the GAL equations, as it has a handful of them on the board. Apart from that, you could probably figure it out if you had the time and clone it, although I'd imagine you could greatly simplify it with an FPGA.
  8. Bolacore

    Radius SE 2.1 ROM Dump

    Hello, just wanted to share I've uploaded the v2.1 ROMs for the Radius 16/25 accelerator for the SE. I've not found another copy online, so hopefully this helps someone who wants to run Sys 7.1/7.0 on their SE with Radius card. Link: https://www.macintoshrepository.org/27255-radius-se-accelerator-2-1-roms
  9. I recently picked up an LC that had a TDK power supply with lots of leaky caps. When powered on one of the big TO220 diodes would get red hot. The back side of the power supply is all black as well, presumably from being run when shorted. I've replaced all the caps, resoldered all the joints on the low voltage side, and now it longer heats up, but just clicks. If I put the output on a scope it rises and falls with the clicks, but all 3 rails hit the right voltage before the click. Does it once every 1.5s or so. Under load it does it every ~1s and the output sags down to a couple volts. Not really sure what else to replace on this, as I can't find any schematics for it. Any ideas on what to try next?
  10. What do you mean? The drive passed the test in Apple Personal Diagnostics, as well as the bad block test. May very well be going bad though, it is from 1990 after all. I have a SCSI2SD showing up sometime soon, so will probably switch to that at some point.
  11. Just to update, I finally found one program that seemed to work: SCSI Specialist. Initialised the drive, and I can now install Sys 7.1 without issue. No idea why the others didn't work
  12. If it helps, I fixed a Mac Classic recently with the exact same error. In my case, it was the 74LS174 - a few of it's pins had corroded from bad caps and were no longer making contact. That little chip generates the timing for the CAS PAL in the corner of the board, and if it's not working, you'll see half (or all) the data bus not working very well. Pulled the chip on mine, cleaned the board, and put the chip back on. Booted right up after. Looking at your board, it looks the same as my did before I repaired it.
  13. I recently got my Macintosh Classic up and going again after recapping (analogue + logic). It passes the Apple Personal Diagnostics tests on the long RAM test, logic board test, and floppy test. It has it's original 40MB SCSI drive, and already had Sys 7.0.1 on it that worked just fine. I wanted to reinstall it fresh with Sys 7.1, so I started up Disk Tools from the Sys 7.1 disk set, and ran Initialize on Apple HD SC Setup. It ran for about a minute, and then bombed with an illegal instruction error. Every time I now try I get the same issue, and can't format the drive. I've tried with Disk Tools from 6.0.8, 7.0, 7.1, and 7.5.3, all fail with generally the same error a minute in. I've also tried Lido 7 which also fails with an illegal instruction. Not sure what to do now, as I can't understand why it keeps bombing on me. Is the issue with the drive, or is something else possibly at fault here? Thanks in advance for the help
  14. Hello, I've picked up a Macintosh SE that was said to have a broken CRT, and did not power on at all. Indeed if I powered it on with everything connected, the 5V rail seemed dead and only 0.5V was on the +12V rail. Since I had them on hand, I replaced all the electrolytic caps on the analog board and inside the Sony CR44 supply. I put the Sony power supply on a load after and it seems to be able to put out the rated current on all rails. Powered it up with just the analog board, plus CRT + yoke boards connected and the fan spun up and I saw 5.6V on the 5V line and 11V on the 12V line. However, if I connect the logic board, the fan no longer spins and I get the same really low voltage levels as before. Nothing seems to get hot though - if I look at the logic board after 10 mins with a thermal camera everything is cold, and everything on the analog board is too. There's a short somewhere (I'm assuming), but I cannot seem to find it. If I measure the resistance at the analog board of the voltage rails everything seems fine. The logic board seems fine too, although it's 5V line measures 110 ohms at the J12 connector. I'm not quite sure where to start, as it's not obvious to me which piece is at fault. Has anyone else seen this behaviour before? Thanks in advance
  15. Bolacore

    Macintosh Classic - low beep with garbled screen

    Is there a compatible chip? I see it's Motorola branded, and I've found other ICs from them that were RTCs + SRAM. If not, I'll try the trading post here seeing if someone has a spare. As well, do you know what the screen should look like without the ROM installed? Should it be blank, or actually display lines/rectangles like mine does?