Jump to content

AppleTree

6502
  • Content Count

    12
  • Joined

  • Last visited

  1. Great. Count me in for 1 set (4 modules). I was thinking of getting 128MB but I think that's probably a little over the top (though it would be cool to look at "About this Macintosh" and give myself a satisfying nod )
  2. Hi would you ship to the UK? I am interested too
  3. Yeah, I've fixed it. It turned out to be the RTC chip. I checked the NMI and it was all fine so that was not the problem. Then I searched the forum and found someone who had the exactly same issue as me last year, albeit with Q700. Battery leak damage, startup chime is fine and then the computer hangs with 0000000F 00000001 error. @AlexTheCat123 re-soldered the RTC chip and got Q700 to boot. I actually had checked RTC chip connection a few days ago against the schematic so I was a bit skeptical that this would work but I was running out of options. I de-soldered the chip and found that two pads were badly damaged. I cleaned the board under the chip with alcohol and re-soldered the chip and WOW it fixed the issue. IIfx is alive again. As I mentioned, I had already checked the RTC chip connection so I am not sure what changed. Maybe the two damaged pads weren't making good contact before or maybe there was cap goo under the chip that I could not clean with the chip soldered on. So it looks like IIfx does POST and then RAM check and finally accesses the RTC/PRAM chip, which I presume is for getting the stored configuration setting (maybe get the startup disk config)? When it fails, it hangs with 0F 01 error. Thank you @techknight for replying to this post. No one was answering to my post so I was getting a bit discouraged there so it was great to have your replies to keep me going. I was getting close to just giving up. Thank you @AlexTheCat123 for leaving your experience with 0F 01 error. That was the last missing piece of the puzzle that I needed to find after replacing a SRAM chip and fixing about 10 traces and vias. Mac_IIfx_-_fixed.mp4
  4. Thanks @techknight. Yes the online resources tell me 0000000F is software related, which confused me. But maybe NMI is being triggered somewhere, causing this error code to appear. I will check the NMI area carefully (which I haven't done yet apart from adding R11). At this stage, I am assuming POST is successful (the fact initial boot chime sounds followed by the screen coming on and going to memory check) so it's either memory or NMI as you suggested. Thanks.
  5. Thank you @techknight for your reply. The first photo was just to show what the board looked like when I got it. As part of repair, I cleaned up the area and added all of the missing components including R11. I don't believe NMI button is stuck because if I press it before the screen comes on, it goes to death chime straight away. So I know the button functions and it registers when I press it. However I will check the NMI traces again as you suggested. I checked all traces from four Bank A RAM slots to RP6,7,8 and UL11,13,16,17 (74F573) yesterday using the schematic and they are all good so it doesn't look to be trace issues with SIMM slots. (BTW I found a mistake in the Bomarc IIfx schematic, SIMM slot data out pin should be 47, not 44. I found a couple more as well, which I can't recall right now) So it looks like POST passes and it goes to RAM check and I thought it maybe failing there but with all SIMM slot traces looking good, that is not the case. From various places I read that RAM check is the last check Mac does before showing the happy Mac screen. If RAM SIMM traces are all good, why would it fail? Could something between RAM SIMM and the memory controller be failing? I am also going to hook up another Mac and see if I can use the diagnostic mode to get some more info. Never used a diagnostic mode before but hopefully I will figure out how to use it. I added two more photos. One showing after cleaning up the damaged area and another showing after missing components added in (R11, D2, D3, R18) Thanks.
  6. Hi I bought a non-working Mac IIfx from eBay. There was a battery leak damage to the motherboard. Some components near the start up circuit were missing and many traces and vias damaged. The SRAM at UD16 had a couple of pins corroded away as well. Not surprisingly, initially it didn't boot at all. I cleaned the motherboard in alcohol (I soaked the board in it) and replaced missing components. Replaced the leaky caps. And I replaced the SRAM with a NOS from eBay (The board had M5M5256BFP but I replaced it with equivalent HM62256LFP, which is actually the chip on the IIfx schematic). I got it to boot with normal chime but after the screen comes on, it gives a crash chime but no error code. It just hangs on the grey screen. (Please see the video below - in the video I put the RAM chips in Bank B, but it makes no difference whether the RAM chips are in Bank A or Bank B. Behaviour is exactly the same) I replaced the ROM with BMOW Rominator and it also starts with normal chime, screen comes on, followed by a crash chime (same as above) but interestingly this one gives a Sad Mac error code 0000000F 00000001. I don't know how far it gets in self test but it seems to get past the memory test, as when I insert 16MB as opposed to 4MB, the crash chime takes longer to appear (using the original ROM) I've fixed all the damaged vias and traces that I can see around the batteries. I used the IIfx schematic to check the connections near the battery as the following: - All pins going out from top RAM slot in Bank A (closest slot to the batteries) - All pins going out from SRAM (UD16) - The one I replaced - All connections between Z8530 (UC17) and Serial PIC (UC16) - All connections between RTC (UF18) and 65C23 (UE12) I am stumped as to what to do from here. I presume Rominator would give the same error code as the Original ROM, though I am not sure why the original ROM does not show the error code. What is 0000000F 00000001? The web page I found is a little confusing to understand. It says Mac II error with 000F ending on the first line is reserved for compatibility. What does that mean? Closest error code I can find on the page is actually (000F 0001) Bus Error. Any idea what I should test next? I have a working IIfx so I am going to swap the CPU tomorrow to see if that makes any difference, though I doubt if the CPU was faulty, it would even get that far. Could the damaged Z8530 (serial comm controller above the battery) cause an error? That is another chip that had bit suspicious looking pins from battery damage, though after cleaning with alcohol, it looks ok). Thanks in advance. iifx-sad-chime.mp4
  7. AppleTree

    IIci logic board power issue

    Yeah I did think about just cleaning underneath and soldering the chips back, but I couldn't be bothered doing it twice if it didn't work. I had already ordered the chips (they only came in lots of 20s so I have plenty of them anyway) so I just replaced them to save the hassle. Now IIci is working as it did when I bought it 30 years ago (or my parents bought it for me, rather )
  8. AppleTree

    IIci logic board power issue

    I am answering back to my own question. I fixed the shutdown issue with my IIci by replacing three chips in the startup/shutdown circuit (UB13, UD13, UE13). It is working perfectly. I do not get the shutdown delay that Jon183 reported. You can see the photo of the motherboard with chips removed in my topic (see the link right above). Thanks.
  9. I finally got around to looking at this again (only after 9 months ). I've fixed the issue. I am posting my result for anyone who is having the same issue. I checked all traces and vias using the IIci startup/shutdown circuit schematic. I found no issues. In the end, the only thing left to do was to replace the three chips (UB13 - 74HC74, UD13 & UE13 - 74HC132) involved in startup/shutdown. I desoldered them, checked the traces under them (no issues) and put in new chips and soft shutdown is now working without a problem. Since I replaced all three with new ones, I do not know which one was actually the issue, but it was probably either UB13 or UD13 since they seemed to be in the shutdown circuit. And in fact, maybe it had not died. Maybe it was the cap goo under the chip that I could not clean without desoldering the chips that was causing the issue. But I didn't want to put the original chips back in after cleaning to find that it still doesn't work so I just replaced them with new ones. Now my IIci is working as it did 30 years ago when I first got it. I am so happy! Next task, upgrade my IIci to 128MB and add more disk space, maybe SCSI2SD PS. The sticky residue you see in the bottom of the photo is flux I used during chip removal.
  10. AppleTree

    IIci logic board power issue

    Hi Jon183, it's been a while since you posted this so this is a long shot but I thought I'd give it a try. I have a similar issue to you. I dug up my 30 year old Mac IIci and it didn't boot properly (It started up a couple of times, no sound, and then eventually it stopped booting completely). I cleaned the board with alcohol and replaced all caps. I actually recapped the PSU as well (all caps apart from one cap, which was impossible to reach) Now it starts up fine. I have sound too. But when I go to shut down, it gives me "It's now safe to switch off your machine" and stays there. In your case, you stated that it shuts down after a few seconds. In my case, it stays with the message. The only way to shut it down is to pull the main plug, which is a real hassle. I actually worked on this last Aug and I left it at this. I started looking at it again and I found your post. Did you ever manage to find out what was causing this message to come up in your IIci? Here is my post from last year for reference. Thanks.
  11. Hi all, I got my 30 year old IIci from my parents' place a couple of weeks ago. It had not been switched on for over 20 years. It did power on but there was no sound. But eventually it stopped powering on as well after a day or so. I looked at the board and not surprisingly the surface mount electrolytic caps had leaked so I recapped the entire logic board (including horizontal radial caps) and after that it powered on fine and the sound started working as well. The power on worked with both the keyboard power switch and the push switch at the back. I thought all was well but no... When I went to shut down the machine, instead of a complete shut down, it gave me the message "It is now safe to switch off your Macintosh" as if it was a compact Mac with a physical on/off switch. The only way to turn it off was to unplug the power cable. So I recapped the PSU as well (Astec model). There was just one capacitor I could not replace, as it was in a place that was impossible to reach unless I unsoldered a daughter board, which was too much work. But apart from that one, I recapped all the others, including RIFA caps. Unfortunately it didn't fix the issue. I am still getting the 'It is now safe..." message and it does not switch off. I am not sure where to go from here. I looked at the board and all traces look good. Could the cap leakage have damaged the chips in start up circuit? (The logic board picture is taken after recapping. I replaced SMD caps with same ones, to be historically correct :-) )
×