Jump to content

elemenoh

6502
  • Content Count

    112
  • Joined

  • Last visited

Profile Information

  • Location
    Bay Area, CA

Recent Profile Visitors

The recent visitors block is disabled and is not being shown to other users.

  1. Hm, that looks like 682 to me which would be 6.8k. There seem to be a bunch on digikey. You'd just need to narrow down to the right package size. https://www.digikey.com/products/en/resistors/chip-resistor-surface-mount/52?FV=mu6.8+kOhms|2085%2C-8|52&quantity=1&ColumnSort=0&page=1&stock=1&k=6.8k+resistor&pageSize=25&pkeyword=6.8k+resistor Perhaps this one would work? https://www.digikey.com/product-detail/en/te-connectivity-passive-product/CRG0805F6K8/A126384CT-ND/7603439
  2. @Trash80toHP_Mini The KiCAD files are also posted. Please feel free to make one mega sheet with them!
  3. @Trash80toHP_MiniThere should be a single file version in the folder called "Macintosh SE/30 Schematic Redraw of 050-0253-01 May-25-2020.pdf" https://drive.google.com/drive/folders/1a29ekZRdQKhGU77sb_dueorzq3sbFU0k?usp=sharing Please let me know if you don't see it there.
  4. elemenoh

    Need help desoldering SE/30 RAM SIMM connectors

    @trag the sockets are all still in place due to solder that won't come out of the ground pin connections. I'll give Chip Quick a shot. Thanks for all of the tips everyone!
  5. I'm replacing some SIMM connectors with broken plastic clips with new metal-clip connectors on some SE/30 boards. The solder on the data pins was easy enough to get out with solder wick. But the ground pins are being unsurprisingly difficult. I've tried lots of flux, adding fresh solder and various temps but haven't had luck. I have a Hakko soldering station with a relatively small wedge tip. I also have a hot air station, solder wick and flux. My cheap pump broke recently. Any tips for clearing out those difficult connections with these tools or recommendations of needed gear if the kit I have isn't enough? Thanks!
  6. I just ordered a set of caps to service several Color Classic analog boards. There are 23 different caps on this board, so just getting all the right stuff in the cart was tedious. Here's a Digikey cart link to make it quick and easy for anyone else doing the same. https://www.digikey.com/short/zmr2t1 This is for a complete recap, which may be unnecessary. Check out the various guides if you want to trim it down to only likely culprits. Also, the quantities in this cart are to replace caps on one board, with no spares. Most are very cheap, so you might want to get 10 or more of all to have them handy if you plan to to other recapping work in the future. Cheers!
  7. @bibilitThat did the trick! It's working great now. Thanks!
  8. Not many areas flaked off. I think I've now checked every trace and did find one bad connection. Patched that but got the same symptom. All the joints were reflowed anyway. Even with a lot of flux and scrubbing the pins on the IC don't look great, but test okay. I guess I can try swapping parts from one board to the other but I've probably already sunk more time into this than it's worth. Any other suggestions?
  9. After a full recap of the PSU and daughter board, the Mac won't power up. When I swapped the daughter board from another working (recapped) PSU it worked okay. So something is bad on this board, but I'm not sure what. I gave it a couple of cleans and checked that all the pins make contact with their first several connection points. Does something here look clearly bad? Where would be a good place to focus troubleshooting? Before and after photos:
  10. Updated the RAM SIMM page with a couple of minor labeling corrections.
  11. This one is pretty interesting. It boots with a typical samasimac screen, but the chimes are all over the place. I guess I have an accidentally circuit-bent SE/30 synthesizer! I've already replaced UD8, UE8 and UF8. Known-working ROM and RAM is installed. This is a different board than the other one I've been posting about recently. I'll get to testing stuff, but if you have recommendations for where to focus please let me know.
  12. elemenoh

    SE/30 no chime or video (MLB issue)

    I triple checked and booted with another board OK. Moved its ROM and RAM to this board but get the same result. Slow chimes. Does replacing the F258's next make sense?
  13. elemenoh

    SE/30 no chime or video (MLB issue)

    I checked all of the data lines and did another inspection for solder blobs but didn't find anything wrong. After shuffling the socketed chips again it now gets a slow chime with samisimac pattern. All ram socket pins tested okay. So maybe I have one or more dead F258s? I ordered some from Mouser to be sure. If there's other stuff I should check, please let me know.
  14. OK I finished fussing with the address lines and the KiCAD files have been cleaned up, archived and added to the shared folder. The topmost sheet just links to the other sheets at the moment. I didn't import any of the global pins onto it, but that should be quick and easy if it's helpful to you. Go forth and be awesome, fellow nerds. If you find these helpful in your projects, please do me a favor and check my post history and help me out with my various unsolved mysteries https://drive.google.com/drive/folders/10VO6n72vsn52xqMyOgSZpi11tbyv7_Yx
  15. elemenoh

    SE/30 no chime or video (MLB issue)

    Yep I did try with a known good stock ROM too but got the same result.
×