Jump to content
brenan6

Mac Classic floppy giving error message that all disks are unreadable or damaged, both before and after a refurb, cleaning and lube

Recommended Posts

Someone suggested that replacing the PRAM battery could be a solution, but I'm not sure. The drive is very clean and functions perfectly mechanically, yet despite this, it refusing to read any disks (even tho they are read perfectly on my LC II). Any idea why a functioning floppy drive would have issues reading? Thanks

Share this post


Link to post
Share on other sites
19 hours ago, MOS8_030 said:

Howdy!

Have you tested the floppy drive from the Classic in your LCIII to confirm that the drive itself is not the problem?

No I havent. I'm unable to operate on the LCII (borrowing from a friend, cannot open it). 

Share this post


Link to post
Share on other sites

There are components on the mother board that can fail and cause the symptoms you are seeing, but it could also be the floppy drive.

You'll have to find some way to test the floppy drive with another computer to isolate the problem.

Or test another known good drive in your computer.

 

Look online for a pdf copy of Dead Mac Scrolls by Larry Pina and Mac Classic & SE Repair and Upgrade Secrets also by Pina.

They contain information about troubleshooting floppy drive issues.

 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×