Jump to content
  • Posts

    • Hi everyone,   I have been working on a recap job for a forum member on their LCII board. It was in reasonable shape short of cap electrolyte all over as expected. I did the recap, everything went well. Fired up the board in a test stand, and it started up but had weird audio scratchiness, video issues, and would occasionally restart itself. I figured that the electrolyte probably made its way under a few on the nearby chips and shorted something. So, I removed UA10, U12, U9, and UB9. As expected, there was a lot of electrolyte under there that I cleaned, then resoldered the chips. This time, I got a completely clear bong when starting, but then got the ascending/descending chime of death. Reseated the VRAM SIMM (and tried without it), but that did not help. The only other chip that looked like it had a lot of electrolyte exposure was U10. So I remove U10, and it was somewhat stubborn, requiring probably 20 seconds of heat to lift off. There were a few deep ruts near some of the pins, and exposed traces as a result of the electrolyte that I cleaned up under there. I checked continuity where the breaks had occurred, and amazingly, everything checked out ok. So, I resoldered U10 into place. Now, when I start the board up, there is no bong, nothing. The LCD I have it hooked up to has an amber status light, which turns green, but no gray screen appears. Could I have somehow damaged U10, and how would I go about testing this? Looking at the Bomarc schematics, it appears that U10 is tasked with controlling parts of the RTC, disk controller, and the reset circuit, but other than that I am not sure how it would be causing this.   Is there anyone out there who might have some insight into this? So much for this just being about replacing caps...
    • At probably 3x the price of the ISA PC version.
    • ...and of course you could upgrade your IIvx/IIvi/Performa 600 with a NuBus Pro Audio Spectrum 16!      
    • By 1992 most PCs were coming with a SoundBlaster Pro (8-bit 22khz stereo) or if one really splurged, a SoundBlaster 16 (16-bit 44khz stereo) or Pro Audio Spectrum 16.
×