Jump to content


Photo

Help with troubleshooting a Plus


  • Please log in to reply
14 replies to this topic

#1 batwings21

batwings21
  • 6502

Posted 17 February 2017 - 05:58 AM

Hello, I've recently picked up the compact Mac addiction. It started with a classic that had pram battery cancer, then I got another classic that just had some leaky caps. That one is all good now but then I stumbled upon a super clean Plus.

The problem is it doesn't boot properly. I get a boot bong but it's extremely long. Then I will get a cursor and the ? Floppy but the cursor doesn't move. Sometimes the screen blanks out as well or it reboots. I will try to attach a video.

I have resoldered the Jx connectors on the analog board, cleaned the connections, checked voltages (4.96 - 12.15 - -12.2) and inspected capacitors. Also I never hear a peep out of the floppy drive and it acts the same if its disconnected.

https://youtu.be/gMNkM79Kp0Q

Edited by batwings21, 17 February 2017 - 05:59 AM.


#2 just.in.time

just.in.time
  • 6502

Posted 17 February 2017 - 07:18 AM

That is strange, never seen that one before.  It almost seems like something is holding the entire computer in a state and not allowing the clock to to roll forward and the processor to proceed to the next instruction.  Just a very uneducated guess on my part.

 

Your voltages look decent.  Those are constant, correct?  Since the video looks stable and sound is loud I'm going to guess that your analog board is okay.

 

I'd look back to the logic board and floppy drive.  Try unplugging the floppy drive and give it another go.  Still same symptoms with the floppy drive unplugged?

 

PRAM battery?  Completely dead and gone is okay.  Healthy is obviously good.  Some people (myself included) can get away with a AA battery @ 1.5 volts.  HOWEVER, a battery much below 1.5 volts, but above 0.0 volts may be leading to corrupted PRAM.  Remove the battery all together and try starting up again.  Still the same symptoms with no battery present?

 

You mention the mouse is not responsive.  Unplug it, and use a can of compressed air to clear all the ports on the back of any possible debris, along with the keyboard connector up front.  Power up without the mouse or keyboard plugged in.  Still the same symptoms?

 

How does the logic board look?  Use the compressed air to clean it of any dust.  In rare scenarios, the dust can be causing small shorts, leading to strange anomalies. While it is out, go ahead and reseat the two ROM chips, as well as any other removable chips.  Sometimes corrosion forms in the sockets causing a bad connection.  Assuming the board isn't rusted out, a simple reseating of these chips can usually clear enough corrosion for a decent connection.  After reseating the ROMs and any/all other components on the logic board, go ahead and try firing it up again, still with no mouse/keyboard/floppy drive.

 

If it finally does work, slowly add things back one at a time until you either have a working system, or found the component that caused the failure you are seeing.

 

If none of this advice helps, then you may need some more advanced troubleshooting techniques.  Good luck :D



#3 360alaska

360alaska
  • 6502

Posted 17 February 2017 - 07:10 PM

My guess would be a ram problem, have you swapped the ram?



#4 batwings21

batwings21
  • 6502

Posted 17 February 2017 - 09:00 PM

I have swapped RAM with some 1meg 30pin 8chip simms I had. Same thing, Pram battery is removed. Tried it with and without the floppy connected, tried it with no mouse or keyboard. The board is pretty clean but I will try blowing it off and inspecting the connectors for foreign objects. I have also removed the Roms and reseated them. I'm going to try to check the clock tonight and see if I'm getting the proper frequency.

#5 techknight

techknight
  • 68LC040

Posted 17 February 2017 - 11:50 PM

Judging by the correct video, and correct audio tones, your clocks are good. 

 

But I am thinking the ROM might be bad? 


Main PC: Intel core I7 920, MSI x58 platinum, Radeon4850
PB: tibook G4, ibook G4, ibook g3x2, Lombard, 160, 165, 180, 180c Duo 2300x2, Duo 270c x2, 520cPPC, 3400c, 1400c
Desktop: G3AIO, SE, SE/30, 512k, plus, LCIII, iMac G4, iMac intel, 6400/225

#6 batwings21

batwings21
  • 6502

Posted 18 February 2017 - 03:24 AM

So is it normal for the tone to be that long? I only have my classic to compare it to but it seems to last forever.

#7 just.in.time

just.in.time
  • 6502

Posted 18 February 2017 - 03:44 AM

Definitely not normal. Haha that chime is awkwardly, bordering on comedically, long :D

Edited by just.in.time, 18 February 2017 - 03:45 AM.


#8 techknight

techknight
  • 68LC040

Posted 18 February 2017 - 02:05 PM

Nope. the length is NOT normal, the pitch of the sound is though. 


Main PC: Intel core I7 920, MSI x58 platinum, Radeon4850
PB: tibook G4, ibook G4, ibook g3x2, Lombard, 160, 165, 180, 180c Duo 2300x2, Duo 270c x2, 520cPPC, 3400c, 1400c
Desktop: G3AIO, SE, SE/30, 512k, plus, LCIII, iMac G4, iMac intel, 6400/225

#9 zuctronic

zuctronic
  • 6502
  • LocationChicago

Posted 18 February 2017 - 10:37 PM

That is not a normal chime. I admit I started laughing about 5 seconds into it... "comedically long" is accurate. I think you may have a bad ROM.



#10 Johnnya101

Johnnya101
  • 68000
  • LocationLancaster, NH

Posted 20 February 2017 - 02:18 PM

Hahaha that is a LOOONNNG boot chime!

 

ber ber beeeeeeeeeeeeeeeeeeeeeeeee......[x37] rp.


resized.gif       BRENT RAMBO APPROVES

Apple IIGS, Classic II, SE/30, Color Classic, Quadra 700, 2x Imagewriter II,  Macintosh Color Display, Power Mac 7100 and 7200, LC II, Macintosh Color Display,  and a box full of ADB keyboards... Soon to be owner of another Quadra 700 and PowerBook 165c


#11 batwings21

batwings21
  • 6502

Posted 21 February 2017 - 08:29 PM

OK so I have a Willem programmer, does anyone know if a EPROM or eeprom can be a drop in replacement? I can handle downloading a bin and splitting it but was hoping I could find a replacement before I tear into it again.

#12 apm

apm
  • 6502

Posted 22 February 2017 - 12:34 AM

It could be a ROM problem, but I'd also wonder about a problem with interrupts and/or connections to the VIA chip.

 

Guide to the Macintosh Family Hardware has some good info on how sound works on the Plus and earlier Macs. The CPU fills up a memory buffer which is played back automatically by DMA. The memory buffer contains enough sound for one video frame (370 samples at 22.25kHz = 1/60th of a second). It sounds like the Sound Manager in ROM is supposed to update the contents of the buffer on every vertical blanking interval. If the contents don't change, it will just play in a loop.

 

The pitch is correct, but the tone is way too long with buzzing at the beginning. It sounds to me like the memory playback is okay (i.e. DMA and system clock are fine), but that the buffer is getting updated way too infrequently. Some possible causes would be that the vertical blanking interrupt isn't being received properly, or that it's being preempted by some other interrupt which is eating up all the CPU time.

 

Most of the interrupts on the Plus go through the VIA, so I'd have a look at the board around that chip. There are some electrolytic caps nearby: C12, C13, C14. The Plus doesn't usually have a caps problem, but these could still leak and corrode nearby traces. Also check around the SCC (serial) chip and the Bourns filters (the orange chips) which have been known to go bad on occasion.



#13 batwings21

batwings21
  • 6502

Posted 23 February 2017 - 03:33 AM

Well its not a ROM problem, I read the hi and lo roms, combined them and then compared to the mac plus v3 rom from the web and they are identical. No visible capacitor damage.

 

Edit: I have also noticed that sometimes when I hit the reset button I get a Sad Mac with code 0f000d.


Edited by batwings21, 23 February 2017 - 04:04 AM.


#14 apm

apm
  • 6502

Posted 23 February 2017 - 11:12 PM

0F000D is the code you should get when hitting the interrupt button, not the reset button. (Can you confirm if you get that code when hitting the interrupt button?)

 

If it happens when pushing the reset button, then something very weird is going on with the interrupts. I might look around the CPU to see if somehow the interrupt pins (23, 24, 25) or their traces are corroded or shorted together in some way. But it sounds like a pretty unlikely thing to happen.



#15 batwings21

batwings21
  • 6502

Posted 28 February 2017 - 03:04 PM

I've ordered a copy of "inside Macintosh IV" which I understand should detail the boot process. Once I get that I will pull it back out and verify that the reset button is causing the sad Mac.




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users