Jump to content


Photo

Cardbus ethernet


  • Please log in to reply
11 replies to this topic

#1 beachycove

beachycove
  • 68020
  • LocationOntario

Posted 14 January 2012 - 03:38 AM

Can anyone recommend a cardbus-compliant ethernet card for a PowerBook 2400c?

I went WPA on my home network and now cannot connect wirelessly in MacOS 8.6, so need an alternative to look for on eBay. An older 16-bit card that I had for a Powerbook 190 is painfully slow -- so painfully slow that it may be on the way out. A 32 bit card (I gather they have an on-board processor too) might make all the difference.

I have googled but haven't been able to find useful information; however, someone on here may know the exact series to go for to suit a machine this old.

#2 johnklos

johnklos
  • 68000
  • LocationEarth

Posted 29 January 2012 - 11:05 PM

If you're accustomed to the speed of wireless, then the speed difference between a 16 bit and 32 bit PCMCIA is not going to matter much. Even the slowest byte mode of 16 bit PCMCIA is a little less than 4 MB/sec and I'm certain the 2400 supports word mode at faster rates (which would be 20 MB/sec; the card might not, but all cards I've ever seen support word mode at least, which is a about 7.8 MB/sec).

Try it. It may have been either the older PowerBook which was a factor, the driver, or both.

#3 martona

martona
  • 6502

Posted 15 July 2012 - 02:55 AM

Could you guys make recommendations on specific cards that would work with a PowerBook 5300CE?

My machine with OS 7.5.5 has a GlobalVillage A930 modem/ethernet card, but sadly the dongles are missing so it's quite useless. You can find a few of these cards on Ebay but they are all "card only" which I take to mean no dongles...

Recommendations for alternatives would be greatly appreciated.

#4 ClassicHasClass

ClassicHasClass
  • 6502
  • LocationElectron Alley

Posted 15 July 2012 - 05:13 PM

I use a 3C589-series card in my 1400 and this driver (disclaimer: I'm the maintainer) should work just fine in your 5300. Those cards are dirt cheap.

http://www.floodgap..../mac/enet3c589/

#5 martona

martona
  • 6502

Posted 15 July 2012 - 07:09 PM

Thank you! I will give it a try.

#6 ClassicHasClass

ClassicHasClass
  • 6502
  • LocationElectron Alley

Posted 16 July 2012 - 04:44 AM

Mind some of the comments on that page; depending on your OS version, you may need to install other software on the 5300 to make it happy.

And just for the pedants, yes, neither the 1400 nor the 5300 has Cardbus; this is just a regular PCMCIA Enet card.

#7 martona

martona
  • 6502

Posted 19 July 2012 - 09:36 PM

Well, I tried it, and it worked great. I had a system error on the first boot, but rebooting without extensions and manually moving a bunch of junk from Extensions to Disabled Extensions solved the problem.

FWIW this is a used Mac with a lot of older software on it. Next thing will be a fresh install of 7.5.5 and getting Ethernet working, but I'm sure I'll manage.

Thanks for the tips. The 3C589 cards are pretty easy to come by on the 'bay.

#8 ClassicHasClass

ClassicHasClass
  • 6502
  • LocationElectron Alley

Posted 20 July 2012 - 05:04 AM

I was never able to figure out why the first boot would throw that bomb, but it doesn't seem to hurt anything. My 1400 still uses the original card I tested the driver with (back when I was running 8.1).

#9 martona

martona
  • 6502

Posted 20 July 2012 - 11:15 PM

It wasn't the simple one-off bomb mentioned on your site - I kept clicking Restart and the error message kept reappearing without an actual reboot taking place. Pulled the power, booted with Shift pressed down, went into Extensions and moved a bunch of stuff (including Apple Built-in Ethernet) to Disabled Extensions (for some reasons these did not appear in Extension Manager where I first tried disabling Ethernet stuff as per the install instructions), and everything started working.

Thanks for your work on this. It's a very useful piece of software. When I get around to doing a clean install I'll post here with any interesting lessons learned, if any - but it'll probably take me a week to get around to playing with a 7.5 reinstall as I'm totally swamped with work right now.

#10 ClassicHasClass

ClassicHasClass
  • 6502
  • LocationElectron Alley

Posted 21 July 2012 - 05:09 PM

Ah. Yes, most of the Ethernet extensions will conflict.

#11 martona

martona
  • 6502

Posted 28 July 2012 - 03:23 AM

So I'm happy to report that the clean install of 7.5.5 went without a hitch.

I zapped the HD, installed 7.5.3, updated to 7.5.5. Installed Stuffit Expander then Open Transport 1.1.2.

I moved the "Ethernet (Built-in)" extension into the "Extensions (Disabled)" folder, dropped your driver into Extensions, and rebooted. When the system was loading it when through an unexpected reboot (I think this is where I was supposed to get a System Error) but upon going through the motions again it booted fine.

I opened the TCP/IP control panel, selected "Alternate Ethernet" as the NIC, installed iCab, and presto, I was online.

#12 ClassicHasClass

ClassicHasClass
  • 6502
  • LocationElectron Alley

Posted 28 July 2012 - 05:10 AM

Excellent!




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users