Jump to content
  • Posts

    • I have this Quadra 840av board, it isn't working at this stage and I noticed two capacitors are missing on the bottom of the board suspected rough handling.   On the underside on the battery end side;   C399 C397   Really keen to fix this board up.   Does anyone know what voltage/value they would be?

      Cheers AP
    • Just opened the screen and saw this:  
      That doesn't look good at all I guess the only option is to get a replacement screen
    • IMG_0656.MOV     So I got the board recapped by a pro who tested it and said there were no issues. However once I got it back and plugged it in the flicking issues were still there (see video). 

      I'm assuming this is an issue with the CRT or the flyback. Any one got any thoughts? IMG_0656.MOV
    • Wow, what a restoration!
      I've been meaning to recap my 190CS as well.
      Do you happen to have part numbers or spec for the caps still, by chance?
      And wow the active matrix screen upgrade is glorious, I must do that to mine as well.
      Have you looked into upgrading the CPU to a full 68040? I know of someone that tried it but it seemed they had trouble finding a legit one, or getting the FPU to function when they had one that did identify as a 68040 instead of an LC040.

      I've had pretty good luck with a CF-IDE adapter with mine so far, and have been trying to use an IDE->MSATA SSD adapter, which works!... for a little bit until it gets warm, and then I think the old capacitors have had enough and the machine crashes, with no more booting until it's cooled down.
      CompactFlash solutions are definitely cooler, though the SSD itself seemed faster.
    • So, the screen on my PB160 has generally kicked it. I'd already replaced the capacitors around the LCD and video quality had been as good as it gets for the 160 for some time.
      I come down to find the screen black one morning.
      From what I can tell, from some disassembly and recapping the inverter, is that the inverter caps leaked, and ended up shorting the DC/DC convertor module on the LCD PCB itself.
      The module burned, partially to ash.   All other function of the machine seems fine, it boots up, and definitely gets to a desktop (I hear it yell at me for not shutting it down properly).

      I can't find *any* solid reference to the TDK CE-0705 DC/DC module online, even in TDK's parts catalog (there's an 0703 that's similar).
      Does anyone know of a suitable replacement for the CE-0705, or failing that... what other screens are suitable replacements for a PB160?
      I'm extremely hesitant to buy "parts" systems on eBay at eBay prices, especially if they can't show working display because this is a literal time bomb on original caps, and it's very likely that "dead" units may have screens with the same issue or worse.
      I know this is not really the best PB of the series but I sort of have some sentimental attachment to it. I'd rather not gut a working system for it if I can help it though.
      Any ideas?
×