• Hello, Guest! Welcome back, and be sure to check out this post for more info about the recent service interruption and migration.

Trying to connect to my NAS via AppleShare, getting an error 12 instead?

khaz

Member
What I have:
a Synology NAS with the latest DSM 7.0.1-42218, properly configured, hopefully.
An iMac G3 with OS 9.2.2 and an Airport card
an LC475 with OS 7.6.1 and a Farallon PN592 network card

What works:
Connecting from the iMac: using AppleShare I can access and transfer files both ways>
Connecting from the LC475: I can SSH into the NAS with SSHeven

What doesn't:
Connecting from the LC475 with AppleShare. I can enter the IP and the ID/Password, but the computer crashes with an error 12.
I tried MacNFS and NFS/Share 1.3.3, but can't connect either. Though I feel like I just don't know how to use these software / NFS in general.

I installed the Network card drivers, AppleShare 3.8.3 and OpenTransport 1.3.

I feel like I'm so close. The connection physically works, as shown by SSHeven, and the NAS has a working Appletalk connection, as shown with the iMac.

Here's what I have, if it matters:

Name Size Version Type Creator
------------------------------------------------------------------

Extensions
------------------------------------------------------------------
------------------------------------------------------------------
CFM-68K Runtime Enabler 424,196 bytes 4.0 INIT cfm8
Apple CD-ROM 94,794 bytes 5.3.3 INIT psap
Apple Ethernet CS 24,228 bytes 1.0.3 comd encs
Apple Ethernet LC 16,845 bytes 1.0.3 comd enlc
Apple Guide 759,209 bytes 2.1.1 INIT reno
Apple Modem Tool 168,201 bytes 1.5.3 cbnd amdt
AppleScriptª 304,359 bytes 1.1 INIT ascr
AppleShare 474,638 bytes 3.8.3 RDEV afpt
Claris Kermit Tool 62,964 bytes 1.0v1 fbnd ctbf
Clipping Extension 26,115 bytes 7.1.4 fext clip
Color Picker 124,066 bytes 2.0.1 INIT cpmg
Desktop Printer Extension 340,310 bytes 2.0.2 fext dtpx
Desktop Printer Spooler 42,093 bytes 2.0.2 appe dtps
Desktop PrintMonitor 113,276 bytes 2.0.2 APPL prmt
EtherTalk Phase 2 15,212 bytes 2.5.7 adev et20
File Sharing Extension 194,085 bytes 7.6.2 INIT hhgg
Finder Scripting Extension 203,081 bytes 7.5.5 fext fsfx
Foreign File Access 34,687 bytes 5.1 INIT ufox
Iomega Driver 69,028 bytes 5.0.3 INIT id40
LaserWriter 8 564,347 bytes 8.3.4 PRER vgrd
Network Extension 81,343 bytes 7.5.5 fext user
ObjectSupportLib 41,585 bytes 1.2 shlb cfmg
Open Tpt ATalk 68K Library 293,219 bytes 1.3.1 libr OMGR
Open Tpt Inet 68K Library 383,652 bytes 1.3.1 libr OMGR
Open Transport 68K Library 480,857 bytes 1.3.1 libr OMGR
OpenTpt Modem 68K 56,721 bytes 1.0 libr OMGR
OpenTpt Remote Access 68K 355,515 bytes 1.0 libr OMGR
OpenTpt Serial Arbitrator 7,492 bytes 1.0 libr OMGR
OpenTransportLib.68k 54,458 bytes 1.3.1 shlb otan
Printer Share 80,502 bytes 1.1.3 INIT pbc2
PrintMonitor 64,062 bytes 7.1.2 APPL prmt
QuickTimeª 1,446,305 bytes 2.5 INIT Œnd6
QuickTimeª Musical Instruments 477,731 bytes 2.5 INIT dvb
Serial Tool 32,896 bytes 1.0.2 cbnd ctbc
Shared Library Manager 168,335 bytes 2.0.1 INIT OMGR
Sound Manager 266,845 bytes 3.2.1 INIT sad
Speech Manager 30,321 bytes 1.4 INIT ttsc
StyleWriter II 301,908 bytes 1.2 PRER IJR2
Text Tool 26,079 bytes 1.0.1 fbnd ctbf
TTY Tool 65,463 bytes 1.0.1 tbnd ctbt
VT102 Tool 151,359 bytes 1.0.1 tbnd ctbt
WorldScriptª Power Adapter 30,786 bytes 7.5.3 scri univ
XMODEM Tool 69,207 bytes 1.1 fbnd ctbf


Extensions (Disabled)
------------------------------------------------------------------
------------------------------------------------------------------
Color SW 1500 827,959 bytes 2.2.1 PRER chle
Color SW 2500 828,219 bytes 2.2.1 PRER auro
Color SW Pro 410,494 bytes 1.5.2 PRER CRKt
ColorSyncª 590,679 bytes 2.1.1 INIT sync
Find File Extension 3,042 bytes 1.1.1 INIT ffEx
Findit INIT 65,198 bytes 1.0 INIT FdIt
ICeTEe 10,226 bytes 1.2b4 INIT ICTE
ImageWriter 46,106 bytes 7.0.1 PRES IWRT
LaserWriter 300/LS 318,156 bytes 1.2 PRER LWL2
StyleWriter 1200 808,871 bytes 2.1.1 PRER dblo


Control Panels
------------------------------------------------------------------
------------------------------------------------------------------
Apple Menu Options 54,378 bytes 1.1.2 cdev CDJR
AppleTalk 211,567 bytes 1.1 cdev atdv
Cache Switch 6,957 bytes 7.0.1 cdev CASH
Color 11,396 bytes 7.1 cdev colr
Date & Time 68,565 bytes 7.5.1 cdev time
Desktop Patterns 280,624 bytes 7.5.1 APPL dskp
File Sharing Monitor 3,146 bytes 7.1 cdev fsmn
General Controls 69,664 bytes 7.5.8 cdev misc
Iomega Drive Options 367,754 bytes 1.2 APPL IoDO
Keyboard 8,424 bytes 7.5.1 cdev keyb
Labels 2,927 bytes 7.1 cdev flbs
Launcher 60,469 bytes 2.8 cdev mash
Mac OS Easy Open 140,995 bytes 1.1.3 cdev meo
Map 39,999 bytes 7.5.1 cdev wmap
Memory 41,722 bytes 7.5.7 cdev mmry
Modem 214,380 bytes 1.0 cdev modm
Monitors 52,152 bytes 7.5.6 cdev cdsc
Mouse 27,894 bytes 7.5.4 cdev mous
Numbers 16,044 bytes 7.1 cdev nbrs
PC Exchange 335,084 bytes 2.1.1 cdev dosa
PPP 471,617 bytes 1.0 cdev rmot
QuickTimeª Settings 16,148 bytes 2.5 cdev Œnd7
Sharing Setup 3,140 bytes 7.1 cdev nstp
Sleeper 323,264 bytes 3.5 cdev YAWN
Sound 54,258 bytes 8.0.5 cdev soun
Speech 105,343 bytes 1.5 cdev earc
Startup Disk 6,421 bytes 7.5.3 cdev sdsk
TCP/IP 297,782 bytes 1.3.1 cdev ztcp
Text 15,003 bytes 7.1 cdev tecd
Users & Groups 3,141 bytes 7.1 cdev ugcf
Views 2,926 bytes 7.1 cdev fvew
WindowShade 21,764 bytes 1.3.1 cdev WS2!


Control Panels (Disabled)
------------------------------------------------------------------
------------------------------------------------------------------
ColorSyncª System Profile 12,747 bytes 2.1 cdev synC
MacDim 131,999 bytes 2.2.1 cdev MDim
MacLinkPlus Setup 42,012 bytes 8.10 BunÉ cdev DVCP
MacLinkPlus Setup CW 46,493 bytes 9.7 cdev DVCP


System Folder
------------------------------------------------------------------
------------------------------------------------------------------
MacTCP DNR 3,455 bytes - cdev mtcp
 

badCaps

Well-known member
Hey have you had any luck with this?

If not, may I suggest trying to enable anonymous access to the share as a test on the NAS if possible? This resource I found suggests that older Mac OS may not support authentication protocols present in later versions of AFP:

 

Nathan_A

Well-known member
FWIW, I've found FTP on my local LAN to be the most trouble free and reliable way to migrate files around between all my machines. I'm fairly certain that Synology supplies an FTP daemon for their NAS solution. Just make sure your Synology is firewalled off from your WAN connection (which you should be doing either way).

I have my primary Linux workstation that's more or less the primary host to which I download and organize vintage software and documentation.

Then I've currently got out my:
  • SE/30
  • Quadra 650
  • 7100/80
  • PowerTower Pro
  • eMac
all connected to the LAN and I pull down software to them over FTP from the Linux machine. I also push files back up to the Linux machine when I want to share them between the old machines, but where I don't want to drag out my Jaz drive.

The only particularly annoying part is having to make sure things are safely encoded for FTP transfer.

I toyed for awhile with using the PT Pro as an AppleShare server that was at the intersection of compatibility with everything else. So, I'd download things from the Internet to the Linux machine, then pull them down over FTP onto the PT Pro, and access everything on it from the other machines over AppleShare. It worked, and it was nostalgic to be using the Chooser to locate and mount shares, but ultimately the extra step in the process was annoying. Especially given that being able to save "bookmarks" on the desktop of each machine using its local FTP program made getting at the central host super easy.
 

khaz

Member
Yes, Guest login worked! Though with "Apple Standard VAM", "Encrypted Password" had its guest option greyed out.

I'm not a fan of having a passwordless guest account active on my local network, but it'll have to do for the moment.

About FTP, I didn't consider it because it doesn't keep the type and creator of files, and it's annoying. It would be a last resort connection locally.

Thanks guys!
 

Nathan_A

Well-known member
Yeah, I made some AppleScripts for BinHex encoding/decoding things easily both directions. Basically little "droplets" that I use to drop files into that then automatically go to the FTP server properly encoded.
 
Top