• Hello, Guest! Welcome back, and be sure to check out this post for more info about the recent service interruption and migration.

SE brightness instability

LaPorta

Well-known member
On my restored, electrolytic recapped SE, I have this issue where after a while, the screen will suddenly in an instant get noticeably brighter, then later on after a few minutes will instantly get noticeably darker. Any ideas as to what may be failing inside to cause this? Note: RIFA caps were not replaced, nothing else was replaced, but all electrolytic on the AB and PSU were all changed and the machine is otherwise in good, working order.
 

LaPorta

Well-known member
…so like any good problem, when you attempt to record it, it refuses to happen. I’ll leave the machine on a while and try again.
 

shadedream

Well-known member
I'm having a similar issue on a Color Classic (with the addition of a little distortion when it brightens), be curious to know if it's a similar cause. I didn't hit all the smaller caps on my AB or the big filter cap, but did most of the others.
 

LaPorta

Well-known member
Ok, here was the best I could get. Not as prominent in the video as in real life. At 24 seconds, you will see it get brighter than it was at the start of the video. That’s all it is. More subtle this time, sometimes it gets quite a bit darker.
 

Attachments

  • IMG_2705.MOV
    26.8 MB · Views: 9

joshc

Well-known member
Hope somebody can suss this out. I have an SE/30 that does something similar, it goes darker and darker the longer its switched on.
 

8tto

Active member
Hopp! It’s hard to say if the SE, SE30 and the Color Classic suffer from the same problem.
They might just need rinsing the video adjustment pots of the brightness knob (in the SEs]. Or reflowing/cleaning the the connections from the analog board?
 

LaPorta

Well-known member
Hope somebody can suss this out. I have an SE/30 that does something similar, it goes darker and darker the longer its switched on.
Mine is a bit more haphazard. Sometimes it does it, sometimes not. it is more visually annoying thank anything and doesn't affect usability much since at this point it doesn't make it so dark that it is unusable. However, I take it as a harbinger of something worse lurking in the long term.
 

LaPorta

Well-known member
Hopefully no one minded my PT Pro playing the Encounters Star Trek AfterDark module in the background :p
 

shadedream

Well-known member
Hopp! It’s hard to say if the SE, SE30 and the Color Classic suffer from the same problem.
They might just need rinsing the video adjustment pots of the brightness knob (in the SEs]. Or reflowing/cleaning the the connections from the analog board?
Sadly I've done both on the CC which is why I'm hoping this thread goes somewhere to maybe give me a hint.
 

techknight

Well-known member
Did you spray and clean out the brightness potentiometer?

Its also entirely possible the CRT is starting to develop an issue in the electron gun. Check that too.
 

LaPorta

Well-known member
Ive been trying to figure out whether or not to move...so this took a tad bit of a back seat. I will do both of those things for sure. How would one go about checking the second?
 
Top