• Updated 2023-07-12: Hello, Guest! Welcome back, and be sure to check out this follow-up post about our outage a week or so ago.

SE/30 Logic Board and Analog Board Recapped, Boot Chime Quickly Followed By Death Chime, Nothing Shows On Screen

Hi all!

I got my SE/30 two years ago and I've been working on and off it since then. When I got this unit it would boot chime to the missing floppy icon. The battery wasn't bombed but there was some leaking cap juice which I've cleaned up. I recently recapped the logic and analog boards. I've left the PSU board alone for now.

I turned on the switch at the back and it does a boot chime quickly followed by a death chime which is the first time I've heard/read of it happening. I've attached a video so you can hear the sounds it makes. Nothing shows on the screen as well. What do you think is wrong and where should I begin diagnosing?
 

Attachments

  • IMG_7190.MOV
    4.9 MB
Turns out the brightness was turned down. When I turned it up I got this Simasimac pattern. If the Dead Mac Scrolls is to be followed the problem is the ROM?
 

Attachments

  • IMG_7209.jpg
    IMG_7209.jpg
    502.9 KB · Views: 6
Tried swapping out RAM sticks and only testing four SIMMs at a time but it didn't work. I also submerged the board in vinegar, washed it soap and distilled water, submerged again in IPA then air dried plus compressed air but still no dice.
 

codevonlux

Well-known member
This seems most likely a RAM problem. It is very possible that some trace finally breaks after all these years
 

dalek

Member
I had a similar issue - in my case the glue plcc needed reflowing as I suspect it being near the power connector, over time the flexing of removing/reinstering the power plug cracked the solder joints under the glue chip.

So if as above you've already beeped out all the other ram connectivity then also check for continuity at the glue for the address lines that don't run to the ram.
 
Top