• Updated 2023-07-12: Hello, Guest! Welcome back, and be sure to check out this follow-up post about our outage a week or so ago.

SCSI floppy drive for Mac SE/30?

I have not had any success fixing my Mac SE/30 floppy drive interface. But I do have a working SCSI interface and SCSI2HD hard drive. I do have some original 3.5 inch 1.44MB diskettes that I would like to use on my SE/30 and am wondering if anyone has successfully interfaced a SCSI floppy drive to a Mac SE/30.
That Iomega Floptical drive would work for me. Unfortunately, they are pretty pricey on eBay. Looked at the completed auctions and it appears I just missed a sale for it. Bummer. I’ll keep my eyes open for a motherboard for sale that works. Thanks.


Well-known member
Out of interest, what's up with your floppy interface? I'm trying to repair an SE/30 board which sees the floppy but won't format it successfully.


Well-known member
PLI's Turbo Floppy 1.4 is probably what you want. No idea if there are any for sale anywhere now though. There were also a couple other options but this is the only one I've seen in person. They apparently don't read 800k or 720k floppies though; HD only.
Here is what’s up with my floppy drive:
I have a Mac SE/30 with Rominator II and SCSI2SD drive. I have a 1.44MB superdrive as the internal floppy drive. I can sometimes read an application or formatted disk, but most times after opening a file or writing a file to the disk the Finder shows an error that the disk "<disk name>" cannot be found and the disk icon disappears from the desktop while the disk is still in the drive. When I try to format a 1.44MB disk I get an Initialization Failed error. I have tried a second 1.44MB disk drive and get the same errors. I have even tried a FloppyEmu as the internal drive and as an external drive and get the same errors. The SCSI2SD drive always boots to System 7.1 fine and reading and writing files to the SCSI2SD drive works fine without errors. Has anyone had a similar issue?I am thinking that my SWIM chip is bad. I have replaced RP10 (resistor network supporting the floppy drive interface), but this issue persists.